aboutsummaryrefslogtreecommitdiff
path: root/games/adonthell
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /games/adonthell
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Notes
Notes: svn path=/head/; revision=196700
Diffstat (limited to 'games/adonthell')
-rw-r--r--games/adonthell/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 2c23abefeb7e..ef100a64d6ea 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -22,13 +22,14 @@ BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13 \
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis
USE_SDL= mixer sdl
-USE_PYTHON= yes
+USE_PYTHON= -2.4
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-py-debug
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib \
+ PYPACKAGE=${PYTHON_CMD}
.include <bsd.port.pre.mk>