aboutsummaryrefslogtreecommitdiff
path: root/games/agame/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-08-02 09:13:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-08-02 09:13:33 +0000
commit538b09d390824b0d62995bafc04ee1e0fe11b4d6 (patch)
treea44e37f251e8fc351edfe9b1c6405f203d231dc8 /games/agame/Makefile
parent85f2263e297dc72860118a5a16677307e49ef67e (diff)
downloadports-538b09d390824b0d62995bafc04ee1e0fe11b4d6.tar.gz
ports-538b09d390824b0d62995bafc04ee1e0fe11b4d6.zip
Notes
Diffstat (limited to 'games/agame/Makefile')
-rw-r--r--games/agame/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/agame/Makefile b/games/agame/Makefile
new file mode 100644
index 000000000000..cab4a770d265
--- /dev/null
+++ b/games/agame/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: agame
+# Date created: 30 Jul 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= agame
+PORTVERSION= 1577
+CATEGORIES= games
+MASTER_SITES= http://zevv.nl/code/game/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+DISTNAME= game-src-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A simple tetris-like game
+
+USE_SDL= sdl image mixer
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/game
+
+PORTDOCS= README.TXT
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,wav/|mp3/|img/,${DATADIR}/&,g' ${WRKSRC}/main.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/game ${PREFIX}/bin
+.for dir in wav mp3 img
+ ${MKDIR} ${DATADIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}/
+.endfor
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>