aboutsummaryrefslogtreecommitdiff
path: root/games/ags
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-05 15:14:48 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-05 15:14:48 +0000
commit83dc5a133c687a269fce3b058542bb2bdc80eac1 (patch)
treebb64f76ccc488c00777ba8733f93ac3b0a5abc0f /games/ags
parentb8d1d43c2b1b34d91aabbbf9e391c16ab116c14d (diff)
downloadports-83dc5a133c687a269fce3b058542bb2bdc80eac1.tar.gz
ports-83dc5a133c687a269fce3b058542bb2bdc80eac1.zip
Notes
Diffstat (limited to 'games/ags')
-rw-r--r--games/ags/Makefile5
-rw-r--r--games/ags/distinfo6
-rw-r--r--games/ags/files/patch-Common_debug_assert.h34
3 files changed, 4 insertions, 41 deletions
diff --git a/games/ags/Makefile b/games/ags/Makefile
index 57a44b48122a..4bfb47403ef1 100644
--- a/games/ags/Makefile
+++ b/games/ags/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ags
-DISTVERSION= 3.4.1.15
-PORTREVISION= 1
+DISTVERSION= 3.4.3.0
CATEGORIES= games
MASTER_SITES= https://github.com/adventuregamestudio/ags/releases/download/v.${DISTVERSION}/
DISTNAME= ags_linux_v.${DISTVERSION}
@@ -32,8 +31,6 @@ PLIST_FILES= bin/ags
post-patch:
@${REINPLACE_CMD} 's|<endian.h>|<sys/endian.h>|' \
${WRKSRC}/Common/core/endianness.h
- @${REINPLACE_CMD} 's|HWND editor_window_handle = NULL;|HWND editor_window_handle = 0;|g' \
- ${WRKSRC}/Engine/debug/debug.cpp
@${REINPLACE_CMD} -e 's|return cd_player|return 0; // cd_player|g' \
-e 's|cd_exit|//cd_exit|g' \
${WRKSRC}/Engine/platform/linux/acpllnx.cpp
diff --git a/games/ags/distinfo b/games/ags/distinfo
index 32af996512b6..5a2739d8f4f5 100644
--- a/games/ags/distinfo
+++ b/games/ags/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548136778
-SHA256 (ags_linux_v.3.4.1.15.tar.xz) = 7edcc091692bd3d5402a8135a13d0c3e066aa8de78185e1205e2a6cc9189122c
-SIZE (ags_linux_v.3.4.1.15.tar.xz) = 862120
+TIMESTAMP = 1549378770
+SHA256 (ags_linux_v.3.4.3.0.tar.xz) = 7dae922a94efbe31f70a212b7788d8f8e7073f115e040b1869032b469068912c
+SIZE (ags_linux_v.3.4.3.0.tar.xz) = 864832
diff --git a/games/ags/files/patch-Common_debug_assert.h b/games/ags/files/patch-Common_debug_assert.h
deleted file mode 100644
index 1129fefbfcca..000000000000
--- a/games/ags/files/patch-Common_debug_assert.h
+++ /dev/null
@@ -1,34 +0,0 @@
---- Common/debug/assert.h.orig 2017-08-03 13:21:09 UTC
-+++ Common/debug/assert.h
-@@ -18,31 +18,6 @@
- #ifndef __AGS_CN_DEBUG__ASSERT_H
- #define __AGS_CN_DEBUG__ASSERT_H
-
--#ifdef _DEBUG
--
--// TODO: revise this later (add platform-specific output maybe?)
--#if defined(WINDOWS_VERSION)
--
--inline void assert(bool expr)
--{
-- if (!expr) {
-- _asm {
-- int 3
-- }
-- }
--}
--
--#else // !WINDOWS_VERSION
--
- #include <assert.h>
--
--#endif
--
--#else // !_DEBUG
--
--// JJS: GCC has trouble with macro overloading
--inline void assert(bool expr) {}
--
--#endif // !_DEBUG
-
- #endif // __AGS_CN_DEBUG__ASSERT_H