aboutsummaryrefslogtreecommitdiff
path: root/games/alephone/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-03-31 03:28:56 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-03-31 03:28:56 +0000
commitf4da74c013dcaa2df241f35cdbb50adde048c6b0 (patch)
tree10686af9c353c035406470597c8f6dccce0faab2 /games/alephone/Makefile
parent65f53fe072d93aa926222cd437ff18974c368bc9 (diff)
Notes
Diffstat (limited to 'games/alephone/Makefile')
-rw-r--r--games/alephone/Makefile33
1 files changed, 9 insertions, 24 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 6eeef5f590ff..44abb20145aa 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= alephone
-PORTVERSION= 20061202
-PORTREVISION= 1
+PORTVERSION= 20061228
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= marathon
@@ -20,7 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GL= yes
USE_GNOME= gnometarget
USE_LUA= 5.0
@@ -30,28 +28,15 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500035
-CXXFLAGS+= -ftemplate-depth-30
-.endif
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|<SDL/SDL|<SDL|g' \
- ${WRKSRC}/Source_Files/Misc/thread_priority_sdl_posix.cpp
-.if ${OSVERSION} < 500035
- @${REINPLACE_CMD} -e 's|streambuf>|streambuf\.h>|' \
- ${WRKSRC}/Source_Files/CSeries/snprintf.h
- @${REINPLACE_CMD} -e 's|m_buffer\.clear()|m_buffer.resize(0)|g ; \
- s|m_displayBuffer\.clear()|m_displayBuffer.resize(0)|g' \
- ${WRKSRC}/Source_Files/Misc/Console.cpp
-.endif
+DATADIR= ${PREFIX}/share/AlephOne
post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README docs/* ${DOCSDIR}
+.endif
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>