aboutsummaryrefslogtreecommitdiff
path: root/games/alephone/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-08-02 18:33:29 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-08-02 18:33:29 +0000
commit6b1fe9fd71e4dcfd36ece5fdafdde994327d5351 (patch)
treebfc7aea5d71a0397031ab8bb3c8dec34f838edb8 /games/alephone/Makefile
parent33c09221a0a2ca46753ff8462837866d96db9759 (diff)
downloadports-6b1fe9fd71e4dcfd36ece5fdafdde994327d5351.tar.gz
ports-6b1fe9fd71e4dcfd36ece5fdafdde994327d5351.zip
Notes
Diffstat (limited to 'games/alephone/Makefile')
-rw-r--r--games/alephone/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index d7d215d81ea2..dcabe0de2b3a 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= alephone
-PORTVERSION= 20080913
-PORTREVISION= 4
+PORTVERSION= 20100424
CATEGORIES= games
-MASTER_SITES= SF/marathon/Aleph%20One/2008-09-13
+MASTER_SITES= SF/marathon/Aleph%20One/2010-04-24
DISTNAME= AlephOne-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fiziologus@gmail.com
COMMENT= The open source version of Bungie's Marathon game
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/include/zzip/lib.h:${PORTSDIR}/devel/zziplib
USE_BZIP2= yes
USE_GL= yes
-USE_GNOME= gnometarget
USE_LUA= 5.1
-USE_SDL= image net sdl sound
+USE_SDL= image ttf net sdl sound
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}" \
LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}"
@@ -31,17 +30,14 @@ DATADIR= ${PREFIX}/share/AlephOne
MAN6= alephone.6
-PORTDOCS= *
-
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README docs/* ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${DOCSDIR}
.endif
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>