aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-06-17 18:45:16 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-06-17 18:45:16 +0000
commit6ead93ac151c886fd3664245758deb96ce26b59c (patch)
tree401f99e8eb50ab20a8e49eebea10cbef5f8e6209 /games/alephone
parent2c00f3f2267983083dbbd7de0b8216c2341dc6fd (diff)
downloadports-6ead93ac151c886fd3664245758deb96ce26b59c.tar.gz
ports-6ead93ac151c886fd3664245758deb96ce26b59c.zip
Notes
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile25
-rw-r--r--games/alephone/distinfo4
-rw-r--r--games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp11
-rw-r--r--games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h20
-rw-r--r--games/alephone/files/patch-aa10
-rw-r--r--games/alephone/files/patch-ab10
-rw-r--r--games/alephone/files/patch-ac32
-rw-r--r--games/alephone/pkg-descr2
-rw-r--r--games/alephone/pkg-message11
9 files changed, 38 insertions, 87 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 8f677a4475c5..a21b49d5d9a0 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= alephone
-PORTVERSION= 0.12.0
-PORTREVISION= 2
+PORTVERSION= 20050118
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= marathon
@@ -16,20 +15,28 @@ DISTNAME= AlephOne-${PORTVERSION}
MAINTAINER= malyn@strangeGizmo.com
COMMENT= The open source version of Bungie's Marathon game
-USE_SDL= image net sdl
-USE_PERL5_BUILD=yes
+USE_SDL= image net sdl sound
+USE_GL= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+USE_REINPLACE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CFLAGS="${CFLAGS} -I${X11BASE}/include" \
+ CXXFLAGS="${CXXFLAGS} -I${X11BASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
+CONFIGURE_ARGS+=--program-transform-name=""
+
+.include <bsd.port.pre.mk>
post-patch:
- @${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
- ${WRKSRC}/Source_Files/Network/network.cpp \
- ${WRKSRC}/Source_Files/Network/network_stream.cpp \
+.if ${OSVERSION} < 500035
+ @${REINPLACE_CMD} -e 's|streambuf>|streambuf\.h>|' \
+ ${WRKSRC}/Source_Files/CSeries/snprintf.h
+.endif
post-install:
.if !defined(NOPORTDOCS)
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index d1657d58ad67..e2040dad666c 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,2 +1,2 @@
-MD5 (AlephOne-0.12.0.tar.gz) = 7a44d2ed10699012836320584b9920ba
-SIZE (AlephOne-0.12.0.tar.gz) = 938589
+MD5 (AlephOne-20050118.tar.gz) = c30c96b7b24c7b44f39c1a83534e1446
+SIZE (AlephOne-20050118.tar.gz) = 1335814
diff --git a/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp b/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp
new file mode 100644
index 000000000000..f45f5af01053
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files-Misc-thread_priority_sdl_posix.cpp
@@ -0,0 +1,11 @@
+--- Source_Files/Misc/thread_priority_sdl_posix.cpp.orig Wed Mar 23 10:41:58 2005
++++ Source_Files/Misc/thread_priority_sdl_posix.cpp Wed Mar 23 10:42:10 2005
+@@ -12,7 +12,7 @@
+ #if defined(TARGET_API_MAC_CARBON) && __MACH__
+ #include <SDL/SDL_Thread.h>
+ #else
+-#include <SDL/SDL_thread.h>
++#include <SDL_thread.h>
+ #endif
+
+ #include <pthread.h>
diff --git a/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h b/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h
deleted file mode 100644
index 89bc01409e5b..000000000000
--- a/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- Source_Files/Misc/sdl_widgets.h.orig Mon Jul 16 21:37:51 2001
-+++ Source_Files/Misc/sdl_widgets.h Mon Sep 20 20:46:48 2004
-@@ -402,7 +402,7 @@
- protected:
- void draw_items(SDL_Surface *s) const
- {
-- vector<T>::const_iterator i = items.begin() + top_item;
-+ typename vector<T>::const_iterator i = items.begin() + top_item;
- int x = rect.x + get_dialog_space(LIST_L_SPACE);
- int y = rect.y + get_dialog_space(LIST_T_SPACE);
- int width = rect.w - get_dialog_space(LIST_L_SPACE) - get_dialog_space(LIST_R_SPACE);
-@@ -413,7 +413,7 @@
- const vector<T> &items; // List of items
-
- private:
-- virtual void draw_item(vector<T>::const_iterator i, SDL_Surface *s, int x, int y, int width, bool selected) const = 0;
-+ virtual void draw_item(typename vector<T>::const_iterator i, SDL_Surface *s, int x, int y, int width, bool selected) const = 0;
- };
-
- #endif
diff --git a/games/alephone/files/patch-aa b/games/alephone/files/patch-aa
deleted file mode 100644
index be3cacca3600..000000000000
--- a/games/alephone/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- Source_Files/ModelView/ModelRenderer.cpp.orig Sun Sep 2 07:24:31 2001
-+++ Source_Files/ModelView/ModelRenderer.cpp Thu Feb 7 10:33:05 2002
-@@ -5,7 +5,6 @@
- */
-
- #include <string.h>
--#include <alloca.h>
- #include "cseries.h"
- #include "ModelRenderer.h"
-
diff --git a/games/alephone/files/patch-ab b/games/alephone/files/patch-ab
deleted file mode 100644
index ed445293c9b1..000000000000
--- a/games/alephone/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/dumpwad.cpp.orig Wed Jun 6 08:31:42 2001
-+++ tools/dumpwad.cpp Thu Feb 7 10:51:25 2002
-@@ -13,6 +13,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <stdarg.h>
-
- // Dummy declarations to avoid link errors
- void set_game_error(short a, short b) {}
diff --git a/games/alephone/files/patch-ac b/games/alephone/files/patch-ac
deleted file mode 100644
index e1fee5ad452a..000000000000
--- a/games/alephone/files/patch-ac
+++ /dev/null
@@ -1,32 +0,0 @@
---- Source_Files/Misc/FileHandler.h.orig Fri Aug 8 15:00:21 2003
-+++ Source_Files/Misc/FileHandler.h Fri Aug 8 15:01:07 2003
-@@ -46,6 +46,7 @@
- #endif
- #endif
-
-+using namespace std;
-
- // Symbolic constant for a closed file's reference number (refnum) (MacOS only)
- const short RefNum_Closed = -1;
---- Source_Files/Misc/resource_manager.h.orig Fri Aug 8 15:00:22 2003
-+++ Source_Files/Misc/resource_manager.h Fri Aug 8 15:04:02 2003
-@@ -10,6 +10,8 @@
- #include <stdio.h>
- #include <vector>
-
-+using namespace std;
-+
- class FileSpecifier;
- class LoadedResource;
-
---- Source_Files/Misc/sdl_dialogs.h.orig Fri Aug 8 15:00:22 2003
-+++ Source_Files/Misc/sdl_dialogs.h Fri Aug 8 15:01:43 2003
-@@ -9,6 +9,8 @@
-
- #include <vector>
-
-+using namespace std;
-+
- class widget;
- struct SDL_Surface;
- class sdl_font_info;
diff --git a/games/alephone/pkg-descr b/games/alephone/pkg-descr
index 94d87770d260..c4c1cfc11e3c 100644
--- a/games/alephone/pkg-descr
+++ b/games/alephone/pkg-descr
@@ -16,7 +16,7 @@ Aleph One is OpenGL-accelerated, but performs well without OpenGL if you
do not have a graphics card with the appropriate functionality (you need
to use the -g/--nogl option).
-WWW: http://www.uni-mainz.de/~bauec002/A1Main.html
+WWW: http://source.bungie.org/
Michael Alyn Miller
malyn@strangeGizmo.com
diff --git a/games/alephone/pkg-message b/games/alephone/pkg-message
index 83017adfada6..40f43ef7a7c9 100644
--- a/games/alephone/pkg-message
+++ b/games/alephone/pkg-message
@@ -3,16 +3,21 @@
This package does not include any Aleph One data files. There are a few
ways of getting a fully-playable version of Aleph One:
- * Install the `alephone-data' port. This port includes the demo files
+ * Install the `alephone-data' port. This port includes the data files
from Marathon Infinity.
- * Buy a copy of Marathon 2 or Marathon Infinity and convert those data
+ * Get a copy of Marathon 2 or Marathon Infinity and convert those data
files into the appropriate AlephOne format (http://source.bungie.org
- has more information).
+ has more information). You can get any of the Marathon series (and
+ AlephOne conversions of Marathon 2 and Marathon Infinity) from
+ http://trilogyrelease.bungie.org/.
* Go to http://archives.bungie.org and download one or more of the SDL
scenarios.
+ * The games/marathon2-data port contains the AlephOne versions of the
+ "Marathon 2: Durandal" data files.
+
AlephOne works best with OpenGL; if you do not have an OpenGL-savvy card
and the game is sluggish, try using the -g option to disable OpenGL.