aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/alephone
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
Notes
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile56
1 files changed, 26 insertions, 30 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 10de25cf82da..92e54a37bb62 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alephone
-# Date created: 27 February 2001
-# Whom: Michael Alyn Miller <malyn@strangeGizmo.com>
-#
+# Created by: Michael Alyn Miller <malyn@strangeGizmo.com>
# $FreeBSD$
-#
PORTNAME= alephone
PORTVERSION= 20120514
@@ -30,53 +26,53 @@ DATADIR= ${PREFIX}/share/AlephOne
MAN6= alephone.6
-OPTIONS= MAD "use libmad for mp3 playback" on \
- OGG "enable ogg/vorbis music playback" on \
- SPEEX "enable speex net mic playback" on \
- SMPEG "use SMPEG for movie playback" on \
- TTF "enable SDL_ttf font rendering" on \
- ZZIP "enable zziplib support" on
+OPTIONS_DEFINE= MAD OGG SPEEX SMPEG TTF ZZIP
+SMPEG_DESC= Use SMPEG for movie playback
+TTF_DESC= Enable SDL_ttf font rendering
+ZZIP_DESC= Enable zziplib support
+
+OPTIONS_DEFAULT= MAD OGG SPEEX SMPEG TTF ZZIP
.include <bsd.port.options.mk>
-.if defined(WITHOUT_MAD)
-CONFIGURE_ARGS+=--disable-mad
-.else
+.if ${PORT_OPTIONS:MMAD}
LIB_DEPEND+= mad.2:${PORTSDIR}/audio/libmad
+.else
+CONFIGURE_ARGS+=--disable-mad
.endif
-.if defined(WITHOUT_OGG)
-CONFIGURE_ARGS+=--disable-vorbis
-.else
+.if ${PORT_OPTIONS:MOGG}
LIB_DEPEND+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+=--disable-vorbis
.endif
-.if defined(WITHOUT_SPEEX)
-CONFIGURE_ARGS+=--disable-speex
-.else
+.if ${PORT_OPTIONS:MSPEEX}
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+.else
+CONFIGURE_ARGS+=--disable-speex
.endif
-.if defined(WITHOUT_SMPEG)
-CONFIGURE_ARGS+=--disable-smpeg
-.else
+.if ${PORT_OPTIONS:MSMPEG}
LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+.else
+CONFIGURE_ARGS+=--disable-smpeg
.endif
-.if defined(WITHOUT_TTF)
-CONFIGURE_ARGS+=--disable-ttf
-.else
+.if ${PORT_OPTIONS:MTTF}
USE_SDL+= ttf
+.else
+CONFIGURE_ARGS+=--disable-ttf
.endif
-.if defined(WITHOUT_ZZIP)
-CONFIGURE_ARGS+=--disable-zzip
-.else
+.if ${PORT_OPTIONS:MZZIP}
LIB_DEPENDS+= zzip.13:${PORTSDIR}/devel/zziplib
+.else
+CONFIGURE_ARGS+=--disable-zzip
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${DOCSDIR}