aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-03 18:58:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-03 18:58:57 +0000
commitff57a36a5814648f6bbfc2b0c2df08bc52a60e40 (patch)
tree2338a6cdc3ec0a38a33fcec714afb3bcb87bc1fa /games/alephone
parentdad068d84dfe0bc26ed25ce1f808672be2a764c2 (diff)
downloadports-ff57a36a5814648f6bbfc2b0c2df08bc52a60e40.tar.gz
ports-ff57a36a5814648f6bbfc2b0c2df08bc52a60e40.zip
Notes
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile33
-rw-r--r--games/alephone/pkg-plist1
2 files changed, 12 insertions, 22 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 3699037309bc..f31870e1754f 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -3,7 +3,7 @@
PORTNAME= alephone
PORTVERSION= 20120514
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/marathon/Aleph%20One/2012-05-14
DISTNAME= AlephOne-${PORTVERSION}
@@ -13,21 +13,14 @@ COMMENT= The open source version of Bungie's Marathon game
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
-USE_GMAKE= yes
-
-USES= pkgconfig
-USE_BZIP2= yes
-USE_SDL+= image net sdl sound
+USES= gmake pkgconfig tar:bzip2
+USE_SDL= image net sdl sound
USE_GL= yes
-PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-alsa --disable-sndfile
-CONFIGURE_ENV= PKG_CONFIG="${PKG_CONFIG}"
DATADIR= ${PREFIX}/share/AlephOne
-MAN6= alephone.6
-
OPTIONS_DEFINE= MAD OGG SPEEX SMPEG TTF ZZIP
SMPEG_DESC= Use SMPEG for movie playback
TTF_DESC= Enable SDL_ttf font rendering
@@ -35,29 +28,28 @@ ZZIP_DESC= Enable zziplib support
OPTIONS_DEFAULT= MAD OGG SPEEX SMPEG TTF ZZIP
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMAD}
-LIB_DEPEND+= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPEND+= libmad.so:${PORTSDIR}/audio/libmad
.else
CONFIGURE_ARGS+=--disable-mad
.endif
.if ${PORT_OPTIONS:MOGG}
-LIB_DEPEND+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
+LIB_DEPEND+= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+=--disable-vorbis
.endif
.if ${PORT_OPTIONS:MSPEEX}
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
.else
CONFIGURE_ARGS+=--disable-speex
.endif
.if ${PORT_OPTIONS:MSMPEG}
-LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+LIB_DEPENDS+= libsmpeg.so:${PORTSDIR}/multimedia/smpeg
.else
CONFIGURE_ARGS+=--disable-smpeg
.endif
@@ -69,19 +61,16 @@ CONFIGURE_ARGS+=--disable-ttf
.endif
.if ${PORT_OPTIONS:MZZIP}
-LIB_DEPENDS+= zzip.13:${PORTSDIR}/devel/zziplib
+LIB_DEPENDS+= libzzip.so:${PORTSDIR}/devel/zziplib
.else
CONFIGURE_ARGS+=--disable-zzip
.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
- cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${STAGEDIR}${DOCSDIR}
.endif
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
.include <bsd.port.mk>
diff --git a/games/alephone/pkg-plist b/games/alephone/pkg-plist
index 1dbd89580bbf..cf857b79a57f 100644
--- a/games/alephone/pkg-plist
+++ b/games/alephone/pkg-plist
@@ -1,4 +1,5 @@
bin/alephone
+man/man6/alephone.6.gz
%%DATADIR%%/Fonts
%%DATADIR%%/MML/Interface_Rects.mml
%%DATADIR%%/MML/Transparent_Liquids.mml