aboutsummaryrefslogtreecommitdiff
path: root/games/alephone
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-04-22 16:53:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-04-22 16:53:23 +0000
commita2ae031ff8bb33938089e2440616eafe346dfc24 (patch)
tree452d0a84410b93e94c116c98d4de0e2d33f1b565 /games/alephone
parent71e2f877ab869947b6a60945ef4af90954dc0449 (diff)
downloadports-a2ae031ff8bb33938089e2440616eafe346dfc24.tar.gz
ports-a2ae031ff8bb33938089e2440616eafe346dfc24.zip
Notes
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile10
-rw-r--r--games/alephone/distinfo4
-rw-r--r--games/alephone/files/patch-Source_Files-Lua-lua_templates.h11
3 files changed, 17 insertions, 8 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index cbe263f78f20..44d268d6dfe4 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= alephone
-PORTVERSION= 20111201
-PORTREVISION= 1
+PORTVERSION= 20120128
CATEGORIES= games
-MASTER_SITES= SF/marathon/Aleph%20One/2011-12-01
+MASTER_SITES= SF/marathon/Aleph%20One/2012-01-28
DISTNAME= AlephOne-${PORTVERSION}
MAINTAINER= fiziologus@gmail.com
@@ -22,7 +21,6 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_SDL+= image net sdl sound
USE_GL= yes
-USE_LUA= 5.1
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-alsa --disable-sndfile
@@ -39,7 +37,7 @@ OPTIONS= MAD "use libmad for mp3 playback" on \
TTF "enable SDL_ttf font rendering" on \
ZZIP "enable zziplib support" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_MAD)
CONFIGURE_ARGS+=--disable-mad
@@ -87,4 +85,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/alephone/distinfo b/games/alephone/distinfo
index 43101f11bf84..469f3af06060 100644
--- a/games/alephone/distinfo
+++ b/games/alephone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (AlephOne-20111201.tar.bz2) = c844b347cdba3bcfba33cf459aa94bcc7729f8865b5cfdb688da24262a918fca
-SIZE (AlephOne-20111201.tar.bz2) = 4576989
+SHA256 (AlephOne-20120128.tar.bz2) = 45a65f34074b93358bbba2e2f1232324f850f7f7d1a20512363d411e5c46298a
+SIZE (AlephOne-20120128.tar.bz2) = 4578336
diff --git a/games/alephone/files/patch-Source_Files-Lua-lua_templates.h b/games/alephone/files/patch-Source_Files-Lua-lua_templates.h
new file mode 100644
index 000000000000..2ba07bdcca2c
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files-Lua-lua_templates.h
@@ -0,0 +1,11 @@
+--- Source_Files/Lua/lua_templates.h.orig 2012-04-21 17:57:45.000000000 +0400
++++ Source_Files/Lua/lua_templates.h 2012-04-21 17:58:22.000000000 +0400
+@@ -496,7 +496,7 @@
+ static index_t ToIndex(lua_State *L, int index) {
+ index_t to;
+ if(lua_isnil(L, index)) return -1;
+- else if(_lookup(L, index, to)) return to;
++ else if(L_Enum<name, index_t>::_lookup(L, index, to)) return to;
+ else {
+ std::string error;
+ if(lua_isnumber(L, index) || lua_isstring(L, index)) \ No newline at end of file