aboutsummaryrefslogtreecommitdiff
path: root/games/alienarena
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-01-27 17:51:23 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-01-27 17:51:23 +0000
commit187317159997d73a903cd3903f60d0a7ff2b6cc8 (patch)
tree8df2e1658454aef6e2dca2d42235a2985764c5ce /games/alienarena
parent35438ffe1569570e68ce10673f43fb97bdc33c83 (diff)
downloadports-187317159997d73a903cd3903f60d0a7ff2b6cc8.tar.gz
ports-187317159997d73a903cd3903f60d0a7ff2b6cc8.zip
- Update 2009.733
- Move pkg-message to files directory - Respect freedesktop config directory
Notes
Notes: svn path=/head/; revision=248710
Diffstat (limited to 'games/alienarena')
-rw-r--r--games/alienarena/Makefile32
-rw-r--r--games/alienarena/distinfo6
-rw-r--r--games/alienarena/files/patch-qcommon_files.c20
-rw-r--r--games/alienarena/files/pkg-message.in (renamed from games/alienarena/pkg-message)5
-rw-r--r--games/alienarena/pkg-plist2
5 files changed, 37 insertions, 28 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 366ec8dbd092..3deafba29995 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -6,21 +6,21 @@
#
PORTNAME= alienarena
-PORTVERSION= 2008.721
-PORTREVISION= 1
+PORTVERSION= 2009.733
CATEGORIES= games
MASTER_SITES= ftp://ftp.linux.kiev.ua/pub/Linux/Gentoo/distfiles/ \
http://ftp.jeuxlinux.fr/files/ \
http://mirror.ipgn.com.au/games/alienarena/ \
http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/ \
http://offload2.icculus.org:9090/alienarena/Files/ \
- http://offload1.icculus.org:9090/alienarena/Files/
-DISTNAME= ${PORTNAME}2008-linux20090109
+ http://offload1.icculus.org:9090/alienarena/Files/ \
+ ${MASTER_SITE_GENTOO:S|$|distfiles/|}
+DISTNAME= ${PORTNAME}7_33-linux20091227
MAINTAINER= acm@FreeBSD.org
COMMENT= Alien Arena (native version)
-RUN_DEPENDS= ${DATADIR}/arena/default.cfg:${PORTSDIR}/games/alienarena-data
+RUN_DEPENDS= ${DATADIR}/data1/default.cfg:${PORTSDIR}/games/alienarena-data
USE_ZIP= yes
USE_DOS2UNIX= yes
@@ -28,13 +28,14 @@ USE_GMAKE= yes
MAKE_ENV= WITH_DATADIR=yes WITH_LIBDIR=yes \
DATADIR="${DATADIR}" LIBDIR="${LIBDIR}"
-WRKSRC= ${WRKDIR}/${PORTNAME}2008/source
+WRKSRC= ${WRKDIR}/${PORTNAME}7_33/source
+
+SUB_FILES= pkg-message
ALL_TARGET= build-release
OPTIONS= CLIENT "Build client" on \
DEDICATED "Build dedicated server" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL "Build SDL sound client (needs CLIENT)" on
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on
PLIST_SUB= LIBDIR=${LIBDIR:S/${PREFIX}\///}
@@ -47,6 +48,7 @@ LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl \
jpeg.10:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_GL= yes
+USE_OPENAL= soft alut
USE_XORG= xxf86dga
.endif
@@ -76,13 +78,9 @@ PLIST_SUB+= DEDICATED="@comment "
MAKE_ENV+= OPTIMIZED_CFLAGS=no
.endif
-.if defined(WITH_SDL)
-USE_SDL= sdl
-PLIST_SUB+= SDL=""
-.else
-MAKE_ENV+= SDLSOUND=0
-PLIST_SUB+= SDL="@comment "
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/client/snd_openal.c
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile
do-install:
${MKDIR} ${LIBDIR}/arena ${LIBDIR}/data1
@@ -100,10 +98,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/release/crded \
${PREFIX}/bin/${PORTNAME}-ded
.endif
-.if defined(WITH_SDL)
- ${INSTALL_PROGRAM} ${WRKSRC}/release/crx.sdl \
- ${PREFIX}/bin/${PORTNAME}-sdl
-.endif
post-install:
@${ECHO_CMD}
diff --git a/games/alienarena/distinfo b/games/alienarena/distinfo
index f4993b3b9f4e..42544afd2f0b 100644
--- a/games/alienarena/distinfo
+++ b/games/alienarena/distinfo
@@ -1,3 +1,3 @@
-MD5 (alienarena2008-linux20090109.zip) = 41ca2df4b37751843600e2e8f80ae7a2
-SHA256 (alienarena2008-linux20090109.zip) = cbdca7196858fc70b05d49919ef636e9d002e9681d7fca9c61310e6033692db0
-SIZE (alienarena2008-linux20090109.zip) = 283698378
+MD5 (alienarena7_33-linux20091227.zip) = d1106130fdcef6c2d4cf039c933213d7
+SHA256 (alienarena7_33-linux20091227.zip) = 5d5ab6ab16a8c277035b7b2cbeba96ba6f3cbcb14aa84217c9b41f54b3f6df74
+SIZE (alienarena7_33-linux20091227.zip) = 299663490
diff --git a/games/alienarena/files/patch-qcommon_files.c b/games/alienarena/files/patch-qcommon_files.c
new file mode 100644
index 000000000000..aa540242a8ba
--- /dev/null
+++ b/games/alienarena/files/patch-qcommon_files.c
@@ -0,0 +1,20 @@
+--- qcommon/files.c 2010-01-27 11:24:33.000000000 -0500
++++ qcommon/files.c 2010-01-27 11:26:40.000000000 -0500
+@@ -568,7 +568,7 @@
+ ================
+ FS_AddHomeAsGameDirectory
+
+-Use ~/.codered/dir as fs_gamedir
++Use ~/.config/alienarena/dir as fs_gamedir
+ ================
+ */
+ void FS_AddHomeAsGameDirectory (char *dir)
+@@ -586,7 +586,7 @@
+ homedir = getenv("HOME");
+ if (!homedir)
+ return;
+- len = snprintf(gdir,sizeof(gdir),"%s/.codered/%s/", homedir, dir);
++ len = snprintf(gdir,sizeof(gdir),"%s/.config/alienarena/%s/", homedir, dir);
+ }
+
+ Com_Printf("using %s for writing\n",gdir);
diff --git a/games/alienarena/pkg-message b/games/alienarena/files/pkg-message.in
index ea0c046576a2..171781480fe2 100644
--- a/games/alienarena/pkg-message
+++ b/games/alienarena/files/pkg-message.in
@@ -2,7 +2,7 @@
Alien Arena (native version) has been installed.
-1) The OSS (native FreeBSD sound) version of Alien Arena 2008 (named
+1) The OSS (native FreeBSD sound) version of Alien Arena 2009 (named
"alienarena") uses by default a slow sound speed, which causes a notable
delay. To solve this you have to run it once like this:
@@ -12,9 +12,6 @@ Where <speed> could be 22050 and 44100 for example (the default that has the
delay is 11025, and the SDL version uses 22050). The value of "sndspeed" will
be saved in the configuration file for future runs.
-NOTE: in FreeBSD 7 or newer please use the SDL version, as the other one has
-problems with sound.
-
2) Enjoy it :)
###############################################################################
diff --git a/games/alienarena/pkg-plist b/games/alienarena/pkg-plist
index 2e55f7276265..7fa140c3428e 100644
--- a/games/alienarena/pkg-plist
+++ b/games/alienarena/pkg-plist
@@ -1,7 +1,5 @@
%%CLIENT%%bin/alienarena
%%DEDICATED%%bin/alienarena-ded
-%%SDL%%bin/alienarena-sdl
-%%LIBDIR%%/arena/default.cfg
%%LIBDIR%%/arena/game.so
%%LIBDIR%%/arena/maps.lst
%%LIBDIR%%/arena/motd.txt