aboutsummaryrefslogtreecommitdiff
path: root/games/alienblaster/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:00:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:00:23 +0000
commit1234c0f04efffad282370050d45a0423c3a401ce (patch)
treed39a16146152c53180c941adfcbecd9d4805cb3d /games/alienblaster/Makefile
parente9c1c8f5f2dd887239b8b54d11c2f8ca4b081949 (diff)
Alien Blaster
Your mission is simple: stop the invasion of the aliens and blast them! PR: ports/83193 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=139074
Diffstat (limited to 'games/alienblaster/Makefile')
-rw-r--r--games/alienblaster/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/games/alienblaster/Makefile b/games/alienblaster/Makefile
new file mode 100644
index 000000000000..3f34f55214e3
--- /dev/null
+++ b/games/alienblaster/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: games/alienblaster
+# Date created: 8 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alienblaster
+PORTVERSION= 1.1.0
+CATEGORIES= games
+MASTER_SITES= http://www.informatik.uni-bremen.de/~schwardt/alienblaster/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Alien Blaster
+
+USE_GMAKE= yes
+USE_SDL= mixer sdl
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ''
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "use atoll() interface"
+.endif
+
+post-patch:
+# Fix make command
+ @${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/${MAKEFILE}
+
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|alienBlaster|${PORTNAME}|g ; \
+ s|g++|${CXX}|g ; \
+ s|-g||g ; \
+ s|sdl-config|${SDL_CONFIG}|g ; \
+ s|@echo ""||g' \
+ ${WRKSRC}/src/Makefile
+
+# Fix paths to ${DATADIR}
+ @${REINPLACE_CMD} -e 's|\./|${DATADIR}/|g' \
+ ${WRKSRC}/src/global.h \
+ ${WRKSRC}/src/global.cc
+ @${REINPLACE_CMD} -e 's|\./|${DATADIR}/|g ; \
+ s|=\(images\)|=${DATADIR}/\1|g' \
+ ${WRKSRC}/cfg/level*.cfg
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ ${MKDIR} ${DATADIR}
+.for d in cfg images sound
+ ${CP} -R ${WRKSRC}/${d} ${DATADIR}
+.endfor
+
+.include <bsd.port.post.mk>