aboutsummaryrefslogtreecommitdiff
path: root/games/alienblaster/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 19:52:24 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-29 19:52:24 +0000
commit018c274bd8f9aa8d37a6dd21cecf5cef3826df12 (patch)
tree110ea9352256cafaed6719d5876750c8100700c3 /games/alienblaster/Makefile
parentfc88e7a87a098a1053931f8573002351cb9cb9ec (diff)
downloadports-018c274bd8f9aa8d37a6dd21cecf5cef3826df12.tar.gz
ports-018c274bd8f9aa8d37a6dd21cecf5cef3826df12.zip
Notes
Diffstat (limited to 'games/alienblaster/Makefile')
-rw-r--r--games/alienblaster/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/alienblaster/Makefile b/games/alienblaster/Makefile
index 7cd4740eeed2..28ae2b436273 100644
--- a/games/alienblaster/Makefile
+++ b/games/alienblaster/Makefile
@@ -13,13 +13,12 @@ COMMENT= Alien Blaster
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
USE_SDL= mixer sdl
REINPLACE_ARGS= -i ''
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
post-patch:
# Fix make command
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/${MAKEFILE}
@@ -42,12 +41,12 @@ post-patch:
do-install:
# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
# Data
- ${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for d in cfg images sound
- ${CP} -R ${WRKSRC}/${d} ${DATADIR}
+ ${CP} -R ${WRKSRC}/${d} ${STAGEDIR}${DATADIR}
.endfor
.include <bsd.port.mk>