aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/allacrost
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/allacrost')
-rw-r--r--games/allacrost/Makefile6
-rw-r--r--games/allacrost/files/patch-src-engine-video-image.cpp10
-rw-r--r--games/allacrost/files/patch-src-engine-video-image_base.cpp10
3 files changed, 23 insertions, 3 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 69da252d1e68..4a41a3ac6149 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -7,7 +7,7 @@
PORTNAME= allacrost
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-demo/${PORTVERSION}
DISTNAME= ${PORTNAME}_demo_source_${PORTVERSION}
@@ -16,7 +16,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A single player 2D role-playing game
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
ogg.7:${PORTSDIR}/audio/libogg \
vorbis.4:${PORTSDIR}/audio/libvorbis \
boost_thread.4:${PORTSDIR}/devel/boost-libs
@@ -34,7 +34,7 @@ USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --datadir=${DATADIR}
-CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR} -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/allacrost/files/patch-src-engine-video-image.cpp b/games/allacrost/files/patch-src-engine-video-image.cpp
new file mode 100644
index 000000000000..46f36cd87638
--- /dev/null
+++ b/games/allacrost/files/patch-src-engine-video-image.cpp
@@ -0,0 +1,10 @@
+--- src/engine/video/image.cpp.orig 2010-05-17 01:38:27.000000000 +0200
++++ src/engine/video/image.cpp 2012-05-03 05:56:08.000000000 +0200
+@@ -17,6 +17,7 @@
+ #include <math.h>
+
+ #include "video.h"
++#include "pngpriv.h"
+
+ using namespace std;
+ using namespace hoa_utils;
diff --git a/games/allacrost/files/patch-src-engine-video-image_base.cpp b/games/allacrost/files/patch-src-engine-video-image_base.cpp
new file mode 100644
index 000000000000..6ce0a13b3a14
--- /dev/null
+++ b/games/allacrost/files/patch-src-engine-video-image_base.cpp
@@ -0,0 +1,10 @@
+--- src/engine/video/image_base.cpp.orig 2010-05-17 01:38:27.000000000 +0200
++++ src/engine/video/image_base.cpp 2012-05-03 05:51:57.000000000 +0200
+@@ -18,6 +18,7 @@
+
+ #include "image_base.h"
+ #include "video.h"
++#include "pngpriv.h"
+
+ using namespace std;
+ using namespace hoa_utils;