aboutsummaryrefslogtreecommitdiff
path: root/games/angband/Makefile
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>2005-07-21 03:36:15 +0000
committerMatthew Hunt <mph@FreeBSD.org>2005-07-21 03:36:15 +0000
commit10fb866a1e3a4dc0a02b287e874fdd272fa55433 (patch)
tree7e6c7a9a4cf51355c3f6f49117305082ba623120 /games/angband/Makefile
parentaa3fa2254647c1b2aea82ff52e749be46599ea90 (diff)
downloadports-10fb866a1e3a4dc0a02b287e874fdd272fa55433.tar.gz
ports-10fb866a1e3a4dc0a02b287e874fdd272fa55433.zip
Notes
Diffstat (limited to 'games/angband/Makefile')
-rw-r--r--games/angband/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/games/angband/Makefile b/games/angband/Makefile
index d9f2c0ceb78f..cca64ea3e94d 100644
--- a/games/angband/Makefile
+++ b/games/angband/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= angband
-PORTVERSION= 3.0.5
+PORTVERSION= 3.0.6
CATEGORIES= games
-MASTER_SITES= ftp://ftp.sunet.se/pub/games/Angband/Source/ \
+MASTER_SITES= ftp://ftp.thangorodrim.net/pub/angband/Source/ \
+ ftp://ftp.sunet.se/pub/games/Angband/Source/ \
ftp://ftp.planetmirror.com/pub/angband/Source/
MAINTAINER= mph@freebsd.org
COMMENT= Rogue-like game with color, X11 support
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-setgid=games
.if !defined(WITHOUT_X11)
USE_XLIB= yes
-CONFIGURE_ARGS= --with-setgid=games --with-x
+CONFIGURE_ARGS+= --with-x
.else
-CONFIGURE_ARGS= --with-setgid=games --with-x=no
+CONFIGURE_ARGS+= --with-x=no
.endif
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
pre-fetch:
.if !defined(WITHOUT_X11)
@${ECHO_MSG} "You could define WITHOUT_X11, if you don't want X support"
@@ -29,4 +34,7 @@ pre-fetch:
@${ECHO_MSG} "Building without X support"
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>