aboutsummaryrefslogtreecommitdiff
path: root/games/angband/files
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-03-31 11:27:27 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-03-31 11:27:27 +0000
commit7ea75d1bac6a553df64366616419d0ec70eae3c6 (patch)
treebd2e4850314c13ca5360d5a37a0425127c08ddf7 /games/angband/files
parent36ff53c9eb7a9d69575eba5c988340751c9b21e9 (diff)
downloadports-7ea75d1bac6a553df64366616419d0ec70eae3c6.tar.gz
ports-7ea75d1bac6a553df64366616419d0ec70eae3c6.zip
Notes
Diffstat (limited to 'games/angband/files')
-rw-r--r--games/angband/files/patch-aa50
-rw-r--r--games/angband/files/patch-ac18
-rw-r--r--games/angband/files/patch-ad13
3 files changed, 39 insertions, 42 deletions
diff --git a/games/angband/files/patch-aa b/games/angband/files/patch-aa
index 42eddaa6dbf6..a6739d10f6bd 100644
--- a/games/angband/files/patch-aa
+++ b/games/angband/files/patch-aa
@@ -1,6 +1,5 @@
-diff -r -P -u ../../angband-280/Makefile angband-280/Makefile
---- ../../angband-280/Makefile Wed Dec 31 19:00:00 1969
-+++ angband-280/Makefile Thu Feb 20 19:54:23 1997
+--- Makefile.orig Mon Mar 31 20:08:53 1997
++++ Makefile Mon Mar 31 20:08:53 1997
@@ -0,0 +1,17 @@
+# My makefile for Angband
+# Matthew Hunt <mph@pobox.com>
@@ -11,44 +10,11 @@ diff -r -P -u ../../angband-280/Makefile angband-280/Makefile
+ cd src && make
+
+install: angband
-+ install -c -o games -g bin -m 4755 angband ${PREFIX}/bin
-+ mkdir -p ${PREFIX}/lib/X11/angband
-+ (cd lib && tar cf - * ) | (cd ${PREFIX}/lib/X11/angband && tar xf - )
-+# install -c lib/* ${PREFIX}/lib/X11/angband
-+ /usr/sbin/chown -R games.bin ${PREFIX}/lib/X11/angband
-+ (cd ${PREFIX}/lib/X11/angband && \
++ install -c -o games -g bin -m 4755 testing ${PREFIX}/bin/angband
++ mkdir -p ${PREFIX}/lib/angband
++ (cd lib && tar cf - * ) | (cd ${PREFIX}/lib/angband && tar xf - )
++# install -c lib/* ${PREFIX}/lib/angband
++ /usr/sbin/chown -R games.bin ${PREFIX}/lib/angband
++ (cd ${PREFIX}/lib/angband && \
+ /bin/chmod 755 apex bone data edit file help info xtra && \
+ /bin/chmod 1777 save user )
-diff -r -P -u ../../angband-280/src/Makefile angband-280/src/Makefile
---- ../../angband-280/src/Makefile Sun Oct 13 20:06:49 1996
-+++ angband-280/src/Makefile Thu Feb 20 19:56:09 1997
-@@ -136,8 +136,8 @@
- ##
- ## Variation -- Use "main-xaw.c" instead of "main-x11.c"
- ##
--#CFLAGS = -Wall -O1 -pipe -g -D"USE_XAW" -D"USE_GCU"
--#LIBS = -lXaw -lXmu -lXt -lX11 -lcurses -ltermcap
-+CFLAGS = -Wall -O1 -pipe -I/usr/X11R6/include -DDEFAULT_PATH=\"${PREFIX}/lib/X11/angband/\" -D"USE_XAW" -D"USE_GCU"
-+LIBS = -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 -lcurses -ltermcap
-
-
- ##
-diff -r -P -u ../../angband-280/src/config.h angband-280/src/config.h
---- ../../angband-280/src/config.h Sun Oct 13 19:13:01 1996
-+++ angband-280/src/config.h Thu Feb 20 19:56:09 1997
-@@ -48,13 +48,13 @@
- * OPTION: define "SPECIAL_BSD" for using certain versions of UNIX
- * that use the 4.4BSD Lite version of Curses in "main-gcu.c"
- */
--/* #define SPECIAL_BSD */
-+#define SPECIAL_BSD
-
-
- /*
- * OPTION: Use the POSIX "termios" methods in "main-gcu.c"
- */
--/* #define USE_TPOSIX */
-+#define USE_TPOSIX
-
- /*
- * OPTION: Use the "termio" methods in "main-gcu.c"
diff --git a/games/angband/files/patch-ac b/games/angband/files/patch-ac
new file mode 100644
index 000000000000..275e8c0dcfb0
--- /dev/null
+++ b/games/angband/files/patch-ac
@@ -0,0 +1,18 @@
+--- src/config.h.orig Tue Mar 4 12:19:58 1997
++++ src/config.h Mon Mar 31 20:10:18 1997
+@@ -48,13 +48,13 @@
+ * OPTION: define "SPECIAL_BSD" for using certain versions of UNIX
+ * that use the 4.4BSD Lite version of Curses in "main-gcu.c"
+ */
+-/* #define SPECIAL_BSD */
++#define SPECIAL_BSD
+
+
+ /*
+ * OPTION: Use the POSIX "termios" methods in "main-gcu.c"
+ */
+-/* #define USE_TPOSIX */
++#define USE_TPOSIX
+
+ /*
+ * OPTION: Use the "termio" methods in "main-gcu.c"
diff --git a/games/angband/files/patch-ad b/games/angband/files/patch-ad
new file mode 100644
index 000000000000..aef51b9b9df1
--- /dev/null
+++ b/games/angband/files/patch-ad
@@ -0,0 +1,13 @@
+--- src/Makefile.orig Sat Mar 8 05:52:32 1997
++++ src/Makefile Mon Mar 31 20:10:52 1997
+@@ -136,8 +136,8 @@
+ ##
+ ## Variation -- Use "main-xaw.c" instead of "main-x11.c"
+ ##
+-#CFLAGS = -Wall -O1 -pipe -g -D"USE_XAW" -D"USE_GCU"
+-#LIBS = -lXaw -lXmu -lXt -lX11 -lcurses -ltermcap
++CFLAGS = -Wall -O1 -pipe -I/usr/X11R6/include -DDEFAULT_PATH=\"${PREFIX}/lib/angband/\" -D"USE_XAW" -D"USE_GCU"
++LIBS = -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 -lcurses -ltermcap
+
+
+ ##