aboutsummaryrefslogtreecommitdiff
path: root/games/annelid/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-04-23 15:15:44 +0000
committerRene Ladan <rene@FreeBSD.org>2016-04-23 15:15:44 +0000
commit37ac791a5bbc8c529d7f02a957526d3772ff8a34 (patch)
tree9271065265636e2ba9b37dab584f5f29be74ef4a /games/annelid/Makefile
parente471497d971f53f95508b5eb6602223c51d0ccae (diff)
downloadports-37ac791a5bbc8c529d7f02a957526d3772ff8a34.tar.gz
ports-37ac791a5bbc8c529d7f02a957526d3772ff8a34.zip
Notes
Diffstat (limited to 'games/annelid/Makefile')
-rw-r--r--games/annelid/Makefile61
1 files changed, 0 insertions, 61 deletions
diff --git a/games/annelid/Makefile b/games/annelid/Makefile
deleted file mode 100644
index a9bba2ee4e0d..000000000000
--- a/games/annelid/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# Created by: Alejandro Pulver <alejandro@varnet.biz>
-# $FreeBSD$
-
-PORTNAME= annelid
-PORTVERSION= 1
-PORTREVISION= 7
-CATEGORIES= games
-MASTER_SITES= http://www.garthgillespie.com/annelid/
-DISTFILES= ${PORTNAME}-src${EXTRACT_SUFX} \
- ${PORTNAME}-media${EXTRACT_SUFX}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Remake of the ubiquitous "Snake" and "Worm" games
-
-RESTRICTED= No redistribution allowed
-BROKEN= does not fetch: connect timeout
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-04-15
-
-USES= gmake zip
-USE_SDL= sdl
-USE_GL= gl
-NO_WRKSUBDIR= yes
-
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS
-OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
-
-SUB_FILES= ${PORTNAME}-sh
-
-DATAFILES= annelid.dat apple.tga apple.wav backd.tga backn.tga font.dat \
- font.tga front.tga grow.wav head.tga powerup.tga readme.txt \
- score.wav segment.tga shrink.wav slow.wav speed.wav title.tga \
- vortex.wav
-
-.include <bsd.port.options.mk>
-
-post-patch:
-# Fix Makefile.
- @${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}| ; \
- s|%%LOCALBASE%%|${LOCALBASE}| ; \
- s|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
-
-# Fix SDL include statement.
- @${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
- ${WRKSRC}/*.cpp ${WRKSRC}/*.h
-
-# Enable/disable compilation optimizations.
-.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -e 's|$$(OPT)||' ${WRKSRC}/${MAKEFILE}
-.endif
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/libexec
- @${MKDIR} ${STAGEDIR}${DATADIR}
-.for f in ${DATAFILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
-.endfor
-
-.include <bsd.port.mk>