aboutsummaryrefslogtreecommitdiff
path: root/games/apricots
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-19 14:09:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-19 14:09:29 +0000
commita980bf7d70e93cf588c232f8bbdd6c93f3398928 (patch)
treef200baa6015a91d8f8de30251986f0a87bf3b3b8 /games/apricots
parent0ec6c58f6644077d318b96363c7fc8e7bc48f7b9 (diff)
downloadports-a980bf7d70e93cf588c232f8bbdd6c93f3398928.tar.gz
ports-a980bf7d70e93cf588c232f8bbdd6c93f3398928.zip
Notes
Diffstat (limited to 'games/apricots')
-rw-r--r--games/apricots/Makefile10
-rw-r--r--games/apricots/files/patch-apricots-init.cpp24
-rw-r--r--games/apricots/files/patch-apricots-sampleio.cpp9
3 files changed, 28 insertions, 15 deletions
diff --git a/games/apricots/Makefile b/games/apricots/Makefile
index 4b619308b2c0..0c7d5f42f59f 100644
--- a/games/apricots/Makefile
+++ b/games/apricots/Makefile
@@ -31,13 +31,9 @@ DESKTOP_ENTRIES="Apricots" \
OPTIONS_DEFINE= DOCS OPENAL
OPTIONS_DEFAULT=OPENAL
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENAL}
-USES+= openal:al,alut
-CPPFLAGS+= -DAP_AUDIO_OPENAL
-LDFLAGS+= -L${LOCALBASE}/lib -lopenal -lalut
-.endif
+OPENAL_USES= openal:al,alut
+OPENAL_CPPFLAGS=-DAP_AUDIO_OPENAL
+OPENAL_LDFLAGS= -L${LOCALBASE}/lib -lopenal -lalut
do-build:
cd ${WRKSRC}/apricots && ${CXX} ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} \
diff --git a/games/apricots/files/patch-apricots-init.cpp b/games/apricots/files/patch-apricots-init.cpp
index c03bdf9dcac4..a55634717a59 100644
--- a/games/apricots/files/patch-apricots-init.cpp
+++ b/games/apricots/files/patch-apricots-init.cpp
@@ -1,6 +1,24 @@
---- apricots/init.cpp.orig 2013-10-18 03:20:08.162773332 +0400
-+++ apricots/init.cpp 2013-10-18 03:21:49.134378818 +0400
-@@ -275,7 +275,7 @@
+--- apricots/init.cpp.orig 2015-08-19 14:00:09 UTC
++++ apricots/init.cpp
+@@ -218,7 +218,7 @@ void init_gameconstants(gamedata &g){
+ string getConfig(string config, string name, string defval)
+ {
+ // Pull out just the name line
+- unsigned int ndx = config.find(name);
++ size_t ndx = config.find(name);
+
+ if (ndx == string::npos)
+ {
+@@ -241,7 +241,7 @@ string getConfig(string config, string n
+ int getConfig(string config, string name, int defval, int min, int max)
+ {
+ // Pull out just the name line
+- unsigned int ndx = config.find(name);
++ size_t ndx = config.find(name);
+
+ if (ndx == string::npos)
+ {
+@@ -275,7 +275,7 @@ int getConfig(string config, string name
void init_gamedata(gamedata &g){
//--JAM: Read from config file
diff --git a/games/apricots/files/patch-apricots-sampleio.cpp b/games/apricots/files/patch-apricots-sampleio.cpp
index b5fdc695941a..0671c664f0ca 100644
--- a/games/apricots/files/patch-apricots-sampleio.cpp
+++ b/games/apricots/files/patch-apricots-sampleio.cpp
@@ -1,7 +1,6 @@
-Patch to build with newer openal. Not sure whether it doesn't leak memory
---- apricots/sampleio.cpp.orig 2003-08-06 03:21:22.000000000 +0400
-+++ apricots/sampleio.cpp 2010-04-07 18:32:05.000000000 +0400
-@@ -74,28 +74,21 @@
+--- apricots/sampleio.cpp.orig 2015-08-19 14:00:09 UTC
++++ apricots/sampleio.cpp
+@@ -74,28 +74,21 @@ void sampleio :: init(int nsamples, char
alListenerfv(AL_ORIENTATION, front );
// Load in samples
@@ -35,7 +34,7 @@ Patch to build with newer openal. Not sure whether it doesn't leak memory
}
// Generate Sources
-@@ -107,8 +100,6 @@
+@@ -107,8 +100,6 @@ void sampleio :: init(int nsamples, char
alSourcefv(sources[j], AL_ORIENTATION, back );
}