aboutsummaryrefslogtreecommitdiff
path: root/games/aqbubble/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-04-18 22:25:41 +0000
committerRene Ladan <rene@FreeBSD.org>2011-04-18 22:25:41 +0000
commit48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79 (patch)
tree5509f9ae2d797f02944d429c11a7b43a3c3d2cf3 /games/aqbubble/Makefile
parent1042e1bbe987939d4dce45f572cba84222b10aa9 (diff)
downloadports-48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79.tar.gz
ports-48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79.zip
Notes
Diffstat (limited to 'games/aqbubble/Makefile')
-rw-r--r--games/aqbubble/Makefile70
1 files changed, 0 insertions, 70 deletions
diff --git a/games/aqbubble/Makefile b/games/aqbubble/Makefile
deleted file mode 100644
index 9422f803c333..000000000000
--- a/games/aqbubble/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# New ports collection makefile for: aqbubble
-# Date created: 2006-04-01
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
-# $FreeBSD$
-#
-
-PORTNAME= aqbubble
-PORTVERSION= 0.3
-PORTREVISION= 10
-CATEGORIES= games
-MASTER_SITES= http://www.losersjuegos.com.ar/_media/juegos/aqbubble/descargas/
-
-MAINTAINER= acm@FreeBSD.org
-COMMENT= Game similar to snow bros
-
-BROKEN= Broken with gcc 4.2
-DEPRECATED= does not compile on FreeBSD 7.x or newer
-EXPIRATION_DATE=2011-04-17
-
-USE_SDL= sdl mixer image
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
-AQBUBBLEDIRS= ima sonidos
-
-OPTIONS= NLS "Native Language Support" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
-post-extract:
- @${REINPLACE_CMD} -e 's/-lSDL /`sdl-config --libs`/g' ${WRKSRC}/configure
-
-post-configure:
- @${REINPLACE_CMD} -e 's/-lSDL /`sdl-config --libs` -lintl /g' ${WRKSRC}/src/Makefile
-
-do-install:
- ${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/src && \
- ${INSTALL_PROGRAM} aqbubble ${PREFIX}/bin && \
- ${FIND} ${AQBUBBLEDIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} -E ${AQBUBBLEDIRS} -type f -iregex ".*\.(png|jpg|wav)" \
- -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
-
-.if !defined(WITHOUT_NLS)
-.for FILE in es
- ${MKDIR} ${PREFIX}/share/locale/${FILE}/LC_MESSAGES && \
- ${INSTALL_DATA} ${WRKSRC}/po/${FILE}.gmo ${PREFIX}/share/locale/${FILE}/LC_MESSAGES/${PORTNAME}.mo
-.endfor
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && \
- ${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>