aboutsummaryrefslogtreecommitdiff
path: root/games/armagetron/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-06-29 15:21:08 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-06-29 15:21:08 +0000
commit56ae4435c043493786cbd50e17363285f1a56407 (patch)
treed7c126b52b9773d46d7dc77837b847af6cd98d19 /games/armagetron/Makefile
parentb68102dc049151f1c846b5a78e9ce1735a8e2b7e (diff)
Notes
Diffstat (limited to 'games/armagetron/Makefile')
-rw-r--r--games/armagetron/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 1a44612487ae..c627914170b6 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -7,23 +7,27 @@
#
PORTNAME= armagetron
-PORTVERSION= 0.2.7.1
-PORTREVISION= 3
+PORTVERSION= 0.2.8.2.1
CATEGORIES= games
MASTER_SITES= SF/armagetronad
DISTNAME= armagetronad-${PORTVERSION}
+EXTRACT_SUFX= .src.tar.gz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ianthetechie@gmail.com
COMMENT= A multiplayer networked Tron clone in 3D
USE_GL= gl
USE_SDL= sdl image
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_ENV= CXXFLAGS="${CFLAGS} -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-etc
+BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
+ png.5:${PORTSDIR}/graphics/png \
+ xml2.5:${PORTSDIR}/textproc/libxml2
OPTIONS= MUSIC "Compile in support for background music" on
@@ -34,11 +38,14 @@ USE_SDL+= mixer
CONFIGURE_ARGS+=--enable-music
.endif
+# This script isn't needed and only causes install problems
+CONFIGURE_ARGS+=--disable-uninstall
+
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^#!/bin/bash$$|#!/bin/sh|g' ${WRKSRC}/batch/*
+ @${FIND} ${WRKSRC}/batch -type f -exec ${REINPLACE_CMD} -e 's|^#!/bin/bash$$|#!/bin/sh|g' {} \+
@${REINPLACE_CMD} -e 's|^INSTALL=.*$$|INSTALL=${DATADIR}|g' \
${WRKSRC}/batch/*.in
- @${RM} -f ${WRKSRC}/batch/*.bak ${WRKSRC}/batch/*.orig
+ @${FIND} ${WRKSRC}/batch -name '*.bak' -o -name '*.orig' -delete
.include <bsd.port.post.mk>