aboutsummaryrefslogtreecommitdiff
path: root/games/armagetron
diff options
context:
space:
mode:
authorMaxime Henrion <mux@FreeBSD.org>2005-11-13 16:23:39 +0000
committerMaxime Henrion <mux@FreeBSD.org>2005-11-13 16:23:39 +0000
commit7f4ee2cc596e2b230512748c1fce771c0b4d85dc (patch)
tree954364690d7e9aa12a24e4b79ab9bbc10f453fbe /games/armagetron
parentc5a43099671f573436c6524dbf3f8df229304cf2 (diff)
downloadports-7f4ee2cc596e2b230512748c1fce771c0b4d85dc.tar.gz
ports-7f4ee2cc596e2b230512748c1fce771c0b4d85dc.zip
Notes
Diffstat (limited to 'games/armagetron')
-rw-r--r--games/armagetron/Makefile45
-rw-r--r--games/armagetron/distinfo3
-rw-r--r--games/armagetron/files/patch-Makefile.global.in11
-rw-r--r--games/armagetron/files/patch-batch-install.in36
-rw-r--r--games/armagetron/files/patch-configure31
-rw-r--r--games/armagetron/pkg-descr14
-rw-r--r--games/armagetron/pkg-plist79
7 files changed, 219 insertions, 0 deletions
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
new file mode 100644
index 000000000000..90eba0886e0f
--- /dev/null
+++ b/games/armagetron/Makefile
@@ -0,0 +1,45 @@
+# ex:ts=8
+# New ports collection makefile for: armagetron
+# Date created: 12 November 2005
+# Whom: Maxime Henrion <mux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= armagetron
+PORTVERSION= 0.2.7.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= armagetronad
+DISTNAME= armagetronad-${PORTVERSION}
+
+MAINTAINER= mux@FreeBSD.org
+COMMENT= A multiplayer networked Tron clone in 3D
+
+USE_REINPLACE= yes
+USE_GL= yes
+USE_SDL= sdl image
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CXXFLAGS="${CFLAGS} -I${X11BASE}/include"
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+OPTIONS= MUSIC "Compile in support for background music" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_MUSIC)
+USE_SDL+= mixer
+CONFIGURE_ARGS+=--enable-music
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^#!/bin/bash$$|#!/bin/sh|g' ${WRKSRC}/batch/*
+ @${REINPLACE_CMD} -e 's|^INSTALL=.*$$|INSTALL=${DATADIR}|g' \
+ ${WRKSRC}/batch/*.in
+ @${RM} -f ${WRKSRC}/batch/*.bak ${WRKSRC}/batch/*.orig
+
+.include <bsd.port.post.mk>
diff --git a/games/armagetron/distinfo b/games/armagetron/distinfo
new file mode 100644
index 000000000000..2662c3650ffe
--- /dev/null
+++ b/games/armagetron/distinfo
@@ -0,0 +1,3 @@
+MD5 (armagetronad-0.2.7.1.tar.gz) = 1359977836fd68ba732419649366c3df
+SHA256 (armagetronad-0.2.7.1.tar.gz) = 3001fc78409b9e0978b59a0e2be40855444717c40f2cac31214289d71c9e42c9
+SIZE (armagetronad-0.2.7.1.tar.gz) = 1344874
diff --git a/games/armagetron/files/patch-Makefile.global.in b/games/armagetron/files/patch-Makefile.global.in
new file mode 100644
index 000000000000..fc8b79618164
--- /dev/null
+++ b/games/armagetron/files/patch-Makefile.global.in
@@ -0,0 +1,11 @@
+--- Makefile.global.in.orig Sat Nov 12 16:05:46 2005
++++ Makefile.global.in Sat Nov 12 16:05:55 2005
+@@ -116,7 +116,7 @@
+ for f in ${srcdir}/*.m4 ; do\
+ echo >> .m4.dep;\
+ echo -n $$( echo $$f | sed -e "s/.m4$$/.ghost/" -e "s|${srcdir}/||" ) >> .m4.dep;\
+- echo -en ":" >> .m4.dep;\
++ echo -n ":" >> .m4.dep;\
+ { echo -n "define(include,\$$1\) define(m4,ghost)" ; grep "include(" $$f; }| m4 >> .m4.dep;\
+ done
+
diff --git a/games/armagetron/files/patch-batch-install.in b/games/armagetron/files/patch-batch-install.in
new file mode 100644
index 000000000000..afec92f8fd10
--- /dev/null
+++ b/games/armagetron/files/patch-batch-install.in
@@ -0,0 +1,36 @@
+--- batch/install.in.orig Sat Feb 19 17:54:22 2005
++++ batch/install.in Sun Nov 13 01:26:26 2005
+@@ -8,7 +8,7 @@
+
+ #find old configuration
+ if test @enable_etc@ = yes ; then
+- CONFIG=@rpmroot@/etc/@prognamebase@
++ CONFIG=@rpmroot@@prefix@/etc/@prognamebase@
+ else
+ CONFIG=$INSTALL/config
+ fi
+@@ -114,10 +114,6 @@
+ cp $INSTALL/config/* $CONFIG
+ fi
+
+-rm -rf $CONFIG_NEW
+-mkdir $CONFIG_NEW
+-cp $CONFIG/* $CONFIG_NEW
+-
+ if test "$UPDATE" = "yes" && test -d $CONFIG_ORIG; then
+ echo "Integrating user changes..." #"from $CONFIG_USER to $CONFIG_ORIG and $CONFIG..."
+ test -r $CONFIG_USER || mkdir $CONFIG_USER
+@@ -140,13 +136,6 @@
+ done
+ cd $PWD_OLD
+ fi
+-
+-rm -rf $CONFIG_ORIG
+-rm -rf $NEW_CONFIG_ORIG
+-mv $CONFIG_NEW $NEW_CONFIG_ORIG
+-chmod 755 $NEW_CONFIG_ORIG
+-chmod 400 $NEW_CONFIG_ORIG/*
+-echo -e "Don't change anything in this directory; it will be needed exactly as it is now\nwhen you upgrate to a new version." >> $NEW_CONFIG_ORIG/README
+
+ #delete obsolete configuration
+ if test @enable_etc@ = yes ; then
diff --git a/games/armagetron/files/patch-configure b/games/armagetron/files/patch-configure
new file mode 100644
index 000000000000..7ba65094d1f5
--- /dev/null
+++ b/games/armagetron/files/patch-configure
@@ -0,0 +1,31 @@
+--- configure.orig Sat Nov 12 20:05:56 2005
++++ configure Sat Nov 12 20:08:47 2005
+@@ -4455,7 +4455,7 @@
+
+ fi
+
+-test x$enable_etc = xyes && configdir="--configdir /etc/$prognamebase"
++test x$enable_etc = xyes && configdir="--configdir $prefix/etc/$prognamebase"
+
+
+
+@@ -8878,7 +8878,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lSDL `sdl-config --libs` $LIBS"
++LIBS="`sdl-config --libs` $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -8941,9 +8941,7 @@
+ CPPFLAGS="$CPPFLAGS `sdl-config --cflags`"
+ export CPPFLAGS
+ export CXXFLAGS
+-for LIBRARY in `sdl-config --libs`; do
+- echo "$LIBRARY" | grep "^-l" > /dev/null && LIBS="$LIBRARY $LIBS"
+-done
++LIBS="`sdl-config --libs` $LIBS"
+ export LIBS
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIBSDL 1
diff --git a/games/armagetron/pkg-descr b/games/armagetron/pkg-descr
new file mode 100644
index 000000000000..f029c49eafe1
--- /dev/null
+++ b/games/armagetron/pkg-descr
@@ -0,0 +1,14 @@
+"A Tron clone in 3D"
+This has been the tagline of Armagetron, since, well, a very long time, and is
+probably the shortest and most accurate description possible. Tron was an
+arcade game based on the movie of the same name, release by Disney in 1982. The
+original game consisted of 4 sub-games, the only one of concern is the 'Light
+Cycles' one, in which the player uses a left/right joystick to control a 'Light
+Cycle' which leaves a wall behind it wherever the cycle it goes, turning only
+at 90 degree angles. The player must then get the AI to crash into their wall
+while avoiding hitting the AI's own wall themselves. Those were the humble
+beginnings of Armagetron Advanced's game play, which has now blossomed into 16
+player mayhem, with highly advanced AI, network game play, and of course all in
+a 3D environment.
+
+WWW: http://armagetronad.net/
diff --git a/games/armagetron/pkg-plist b/games/armagetron/pkg-plist
new file mode 100644
index 000000000000..a9b4da34ef64
--- /dev/null
+++ b/games/armagetron/pkg-plist
@@ -0,0 +1,79 @@
+bin/armagetronad
+bin/armagetronad-stat
+etc/armagetronad/aiplayers.cfg
+etc/armagetronad/default.cfg
+etc/armagetronad/master.srv
+etc/armagetronad/rc.config
+etc/armagetronad/settings.cfg
+etc/armagetronad/settings_dedicated.cfg
+@dirrm etc/armagetronad
+%%DATADIR%%/COPYING.txt
+%%DATADIR%%/arenas/basic.aar
+%%DATADIR%%/bin/armagetronad
+%%DATADIR%%/bin/armagetronad-stat
+%%DATADIR%%/bin/pushscores
+%%DATADIR%%/bin/rcd_config
+%%DATADIR%%/bin/rcd_master
+%%DATADIR%%/bin/rcd_server
+%%DATADIR%%/bin/rcd_startstop
+%%DATADIR%%/bin/uninstall
+%%DATADIR%%/doc/COPYING.txt
+%%DATADIR%%/doc/artr.cfg
+%%DATADIR%%/doc/bugs.html
+%%DATADIR%%/doc/changelog.html
+%%DATADIR%%/doc/commands.html
+%%DATADIR%%/doc/commands.txt
+%%DATADIR%%/doc/compile.html
+%%DATADIR%%/doc/config.html
+%%DATADIR%%/doc/faq.html
+%%DATADIR%%/doc/index.html
+%%DATADIR%%/doc/install_linux.html
+%%DATADIR%%/doc/install_macosx.html
+%%DATADIR%%/doc/install_windows.html
+%%DATADIR%%/doc/net/index.html
+%%DATADIR%%/doc/net/lower.html
+%%DATADIR%%/doc/net/middle.html
+%%DATADIR%%/doc/net/upper.html
+%%DATADIR%%/doc/network.html
+%%DATADIR%%/doc/readme_linux.html
+%%DATADIR%%/doc/readme_macosx.html
+%%DATADIR%%/doc/readme_windows.html
+%%DATADIR%%/doc/todo.html
+%%DATADIR%%/doc/versions.html
+%%DATADIR%%/language/.tag
+%%DATADIR%%/language/deutsch.txt
+%%DATADIR%%/language/english.txt
+%%DATADIR%%/language/languages.txt
+%%DATADIR%%/language/new.txt
+%%DATADIR%%/models/cycle_body.mod
+%%DATADIR%%/models/cycle_front.mod
+%%DATADIR%%/models/cycle_rear.mod
+%%DATADIR%%/sound/cyclrun.wav
+%%DATADIR%%/sound/expl.wav
+%%DATADIR%%/textures/KGN_logo.png
+%%DATADIR%%/textures/cycle_body.png
+%%DATADIR%%/textures/cycle_wheel.png
+%%DATADIR%%/textures/dir_wall.png
+%%DATADIR%%/textures/floor.png
+%%DATADIR%%/textures/floor_a.png
+%%DATADIR%%/textures/floor_b.png
+%%DATADIR%%/textures/font.png
+%%DATADIR%%/textures/font_extra.png
+%%DATADIR%%/textures/font_s.png
+%%DATADIR%%/textures/icon.png
+%%DATADIR%%/textures/rim_wall.png
+%%DATADIR%%/textures/shadow.png
+%%DATADIR%%/textures/sky.png
+%%DATADIR%%/textures/title.jpg
+%%DATADIR%%/textures/wrap.png
+@dirrm %%DATADIR%%/arenas
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/doc/net
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%/language
+@dirrm %%DATADIR%%/log
+@dirrm %%DATADIR%%/models
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/textures
+@dirrm %%DATADIR%%