aboutsummaryrefslogtreecommitdiff
path: root/games/arx-libertatis
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-20 01:12:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-20 01:12:35 +0000
commitc3518c09735f98fa041e7abcb06664caf8dbd6b2 (patch)
treebf80761c4c0a451b9800bedd835b9ea8373db013 /games/arx-libertatis
parent343dc0a4b951c6b31e937cc0402b99c2ebaf29f1 (diff)
downloadports-c3518c09735f98fa041e7abcb06664caf8dbd6b2.tar.gz
ports-c3518c09735f98fa041e7abcb06664caf8dbd6b2.zip
Notes
Diffstat (limited to 'games/arx-libertatis')
-rw-r--r--games/arx-libertatis/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index 6a743ffc9ca2..753c58576142 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -14,13 +14,12 @@ COMMENT= Cross-platform port of Arx Fatalis
LICENSE= GPLv3 # or later
LICENSE_FILE= ${WRKSRC}/ARX_PUBLIC_LICENSE.txt
-LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew \
- libfreetype.so:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/foreach.hpp:${PORTSDIR}/devel/boost-libs
USES= cmake openal tar:xz
USE_SDL= sdl
-USE_GL= gl
+USE_GL= gl glew
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx -DSTRICT_USE=ON
SUB_FILES= pkg-message
@@ -28,19 +27,16 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS CHANGELOG README.md
OPTIONS_DEFINE= CRASHREPORTER DOCS
+OPTIONS_SUB= yes
+
CRASHREPORTER_DESC= Build crash reporter (requires Qt4)
+CRASHREPORTER_USE= QT4=corelib,gui,network \
+ QT4=rcc_build,moc_build,uic_build,qmake_build
+CRASHREPORTER_CMAKE_ON= -DBUILD_CRASHREPORTER=ON -DUSE_QT5=OFF
+CRASHREPORTER_CMAKE_OFF=-DBUILD_CRASHREPORTER=OFF
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCRASHREPORTER}
-USE_QT4= corelib gui network rcc_build moc_build uic_build qmake_build
-CMAKE_ARGS+= -DBUILD_CRASHREPORTER=ON -DUSE_QT5=OFF
-PLIST_SUB+= CRASHREPORTER=""
-.else
-CMAKE_ARGS+= -DBUILD_CRASHREPORTER=OFF
-PLIST_SUB+= CRASHREPORTER="@comment "
-.endif
-
post-patch:
.if ${OPSYS} == FreeBSD && ((${OSVERSION} >= 1000705 && ${OSVERSION} < 1001503) || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100046))
# Workaround for clang 3.4 bug: it crashes when debug info is enabled