aboutsummaryrefslogtreecommitdiff
path: root/games/asc/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-10 15:11:41 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-10 15:11:41 +0000
commit0267b6b98c9b24f18e6dc04e7fa7a3f4851c2c78 (patch)
tree4a99d48a62818bb97d034490c707399a98d84ab5 /games/asc/files
parentb00ce03804169e506f1aa2b8ab006ddd407890df (diff)
downloadports-0267b6b98c9b24f18e6dc04e7fa7a3f4851c2c78.tar.gz
ports-0267b6b98c9b24f18e6dc04e7fa7a3f4851c2c78.zip
Notes
Diffstat (limited to 'games/asc/files')
-rw-r--r--games/asc/files/patch-source::controls.cpp24
-rw-r--r--games/asc/files/patch-source::gamedlg.cpp100
-rw-r--r--games/asc/files/patch-source::mapedit::Makefile.in8
-rw-r--r--games/asc/files/patch-source::replay.cpp14
-rw-r--r--games/asc/files/patch-source::tools::linux::Makefile.in33
5 files changed, 28 insertions, 151 deletions
diff --git a/games/asc/files/patch-source::controls.cpp b/games/asc/files/patch-source::controls.cpp
deleted file mode 100644
index a738b3dbf60a..000000000000
--- a/games/asc/files/patch-source::controls.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
-
-$FreeBSD$
-
---- source/controls.cpp 2001/02/17 15:52:35 1.1
-+++ source/controls.cpp 2001/02/17 15:54:41
-@@ -3039,7 +3039,7 @@
- displaymessage("no human players found !", 1 );
- delete actmap;
- actmap = NULL;
-- throw NoMapLoaded();
-+ goto except1;
- }
-
- } while ( actmap->player[actmap->actplayer].stat != ps_human ); /* enddo */
-@@ -3048,6 +3048,9 @@
-
- if (bb)
- cursor.display();
-+
-+except1:
-+ throw NoMapLoaded();
- }
-
- void initNetworkGame ( void )
diff --git a/games/asc/files/patch-source::gamedlg.cpp b/games/asc/files/patch-source::gamedlg.cpp
deleted file mode 100644
index 1490a2208dc5..000000000000
--- a/games/asc/files/patch-source::gamedlg.cpp
+++ /dev/null
@@ -1,100 +0,0 @@
-
-$FreeBSD$
-
---- source/gamedlg.cpp 2001/02/17 16:01:39 1.1
-+++ source/gamedlg.cpp 2001/02/17 16:06:51
-@@ -1233,7 +1233,7 @@
- displaymessage("no human players found !", 1 );
- delete actmap;
- actmap = NULL;
-- throw NoMapLoaded();
-+ goto except1;
- }
- } while ( actmap->player[actmap->actplayer].stat != ps_human ); /* enddo */
-
-@@ -1242,26 +1242,29 @@
- catch ( InvalidID err ) {
- displaymessage( err.getMessage().c_str(), 1 );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( tinvalidversion err ) {
- displaymessage( "File %s has invalid version.\nExpected version %d\nFound version %d\n", 1, err.filename, err.expected, err.found );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( tfileerror err) {
- displaymessage( "error reading map filename %s ", 1, err.filename );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( ASCexception ) {
- displaymessage( "error loading map", 1 );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
-
- removemessage();
-+ return;
-
-+except1:
-+ throw NoMapLoaded();
- }
-
-
-@@ -1722,7 +1725,7 @@
- displaymessage ( "no human players found !", 1 );
- delete actmap;
- actmap = NULL;
-- throw NoMapLoaded();
-+ goto except1;
- }
-
- if ( human > 1 )
-@@ -1743,7 +1746,7 @@
- displaymessage("no human players found !", 1 );
- delete actmap;
- actmap = NULL;
-- throw NoMapLoaded();
-+ goto except1;
- }
- } while ( actmap->player[actmap->actplayer].stat != ps_human ); /* enddo */
-
-@@ -1752,25 +1755,29 @@
- catch ( InvalidID err ) {
- displaymessage( err.getMessage().c_str(), 1 );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( tinvalidversion err ) {
- displaymessage( "File %s has invalid version.\nExpected version %d\nFound version %d\n", 1, err.filename, err.expected, err.found );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( tfileerror err) {
- displaymessage( "error reading map filename %s ", 1, err.filename );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
- catch ( ASCexception ) {
- displaymessage( "error loading map", 1 );
- if ( !actmap || actmap->xsize <= 0)
-- throw NoMapLoaded();
-+ goto except1;
- } /* endcatch */
-
- }
-+ return;
-+
-+except1:
-+ throw NoMapLoaded();
- }
-
-
diff --git a/games/asc/files/patch-source::mapedit::Makefile.in b/games/asc/files/patch-source::mapedit::Makefile.in
index 37beaa311c0f..c9482f477620 100644
--- a/games/asc/files/patch-source::mapedit::Makefile.in
+++ b/games/asc/files/patch-source::mapedit::Makefile.in
@@ -1,16 +1,16 @@
$FreeBSD$
---- source/mapedit/Makefile.in.orig Mon Jan 29 01:11:06 2001
-+++ source/mapedit/Makefile.in Sat Feb 17 18:19:08 2001
+--- source/mapedit/Makefile.in.orig Mon Feb 26 14:37:52 2001
++++ source/mapedit/Makefile.in Sat Mar 10 15:32:13 2001
@@ -76,10 +76,10 @@
bin_PROGRAMS = ascmapedit ascmap2pcx
- ascmapedit_SOURCES = edevents.cpp edgen.cpp edglobal.cpp edmain.cpp edselfnt.cpp edmisc.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp
+ ascmapedit_SOURCES = edevents.cpp edgen.cpp edglobal.cpp edmain.cpp edselfnt.cpp edmisc.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp vehicle.cpp buildings.cpp networkdata.cpp
-ascmapedit_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL -lpthread @LDADDLIBBZ2@
+ascmapedit_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a @LDADDLIBBZ2@
- ascmap2pcx_SOURCES = map2pcx.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp
+ ascmap2pcx_SOURCES = map2pcx.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp vehicle.cpp buildings.cpp networkdata.cpp
-ascmap2pcx_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL -lpthread -lSDL_image @LDADDLIBBZ2@
+ascmap2pcx_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL_image @LDADDLIBBZ2@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/games/asc/files/patch-source::replay.cpp b/games/asc/files/patch-source::replay.cpp
deleted file mode 100644
index 846b52343104..000000000000
--- a/games/asc/files/patch-source::replay.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- source/replay.cpp 2001/02/17 15:46:05 1.1
-+++ source/replay.cpp 2001/02/17 15:49:13
-@@ -22,6 +22,8 @@
- * *
- ***************************************************************************/
-
-+#include <stdarg.h>
-+
- #include "replay.h"
- #include "typen.h"
- #include "buildingtype.h"
diff --git a/games/asc/files/patch-source::tools::linux::Makefile.in b/games/asc/files/patch-source::tools::linux::Makefile.in
index 04095528c46c..843d615067f7 100644
--- a/games/asc/files/patch-source::tools::linux::Makefile.in
+++ b/games/asc/files/patch-source::tools::linux::Makefile.in
@@ -1,16 +1,31 @@
$FreeBSD$
---- source/tools/linux/Makefile.in 2001/02/17 15:22:10 1.1
-+++ source/tools/linux/Makefile.in 2001/02/17 15:22:33
-@@ -79,8 +79,8 @@
+--- source/tools/linux/Makefile.in 2001/03/10 14:10:17 1.1
++++ source/tools/linux/Makefile.in 2001/03/10 14:19:07
+@@ -81,11 +81,11 @@
+ asc_makegfx_SOURCES = makegfx.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp
+ asc_mntgraph_SOURCES = mntgraph.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp
- ascmount_SOURCES = mount.cpp basestrm.cpp misc.cpp ascstring.cpp
-
--ascmount_LDADD = -lSDL -lpthread @LDADDLIBBZ2@
--ascdemount_LDADD = -lSDL -lpthread @LDADDLIBBZ2@
-+ascmount_LDADD = @LDADDLIBBZ2@
-+ascdemount_LDADD = @LDADDLIBBZ2@
+-asc_mount_LDADD = -lSDL -lpthread @LDADDLIBBZ2@
+-asc_demount_LDADD = -lSDL -lpthread @LDADDLIBBZ2@
+-asc_gfx2pcx_LDADD = ../../sdl/libsdl.a -lSDL -lpthread @LDADDLIBBZ2@
+-asc_makegfx_LDADD = ../../sdl/libsdl.a -lSDL -lpthread @LDADDLIBBZ2@
+-asc_mntgraph_LDADD = ../../sdl/libsdl.a -lSDL -lpthread @LDADDLIBBZ2@
++asc_mount_LDADD = @LDADDLIBBZ2@
++asc_demount_LDADD = @LDADDLIBBZ2@
++asc_gfx2pcx_LDADD = ../../sdl/libsdl.a @LDADDLIBBZ2@
++asc_makegfx_LDADD = ../../sdl/libsdl.a @LDADDLIBBZ2@
++asc_mntgraph_LDADD = ../../sdl/libsdl.a @LDADDLIBBZ2@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =
+@@ -93,7 +93,7 @@
+
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../../..
+-CPPFLAGS = @CPPFLAGS@
++CPPFLAGS = @CPPFLAGS@ -DPREFIX=\"$(prefix)\"
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ asc_demount_OBJECTS = demount.o basestrm.o misc.o ascstring.o