aboutsummaryrefslogtreecommitdiff
path: root/games/assaultcube
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2011-05-04 16:31:28 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2011-05-04 16:31:28 +0000
commit63680caae08a410fba2a1133e37cd9d3baaef851 (patch)
tree10efe86514bd11d16a7025d24878ee3d74718dbc /games/assaultcube
parent64d31bd0e9516deb87788b44148b06f1792bd545 (diff)
downloadports-63680caae08a410fba2a1133e37cd9d3baaef851.tar.gz
ports-63680caae08a410fba2a1133e37cd9d3baaef851.zip
Notes
Diffstat (limited to 'games/assaultcube')
-rw-r--r--games/assaultcube/Makefile28
-rw-r--r--games/assaultcube/files/assaultcube_client.in2
2 files changed, 20 insertions, 10 deletions
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 8c2491708729..f045db176a25 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -7,6 +7,7 @@
PORTNAME= assaultcube
PORTVERSION= 1.1.0.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/actiongame/AssaultCube%20Version%20${PORTVERSION}
DISTFILES= AssaultCube_v${PORTVERSION}_source${EXTRACT_SUFX} \
@@ -15,6 +16,18 @@ DISTFILES= AssaultCube_v${PORTVERSION}_source${EXTRACT_SUFX} \
MAINTAINER= lightside@safebox.ru
COMMENT= Total conversion of the FPS game called Cube
+LICENSE_COMB= multi
+LICENSE= ACUBE CUBE MIT OTHER
+LICENSE_NAME_ACUBE= AssaultCube ZLIB-like license with additions
+LICENSE_FILE_ACUBE= ${WRKSRC}/source/README.txt
+LICENSE_PERMS_ACUBE= ${_LICENSE_PERMS_DEFAULT}
+LICENSE_NAME_CUBE= Cube game engine ZLIB-like license with additions
+LICENSE_FILE_CUBE= ${WRKSRC}/source/README_CUBEENGINE.txt
+LICENSE_PERMS_CUBE= ${_LICENSE_PERMS_DEFAULT}
+LICENSE_NAME_OTHER= various package licences
+LICENSE_FILE_OTHER= ${WRKSRC}/docs/package_copyrights.txt
+LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
+
USE_BZIP2= yes
USE_OPENAL= al
USE_GMAKE= yes
@@ -29,12 +42,9 @@ MAKE_JOBS_SAFE= yes
PORTDATA= config demos packages
PORTDOCS= *
-CFLAGS+= -DFREEBSD
-
OPTIONS= CLIENT "Build client" on \
DEDICATED "Build dedicated server" on \
- MASTER "Build master server" off \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+ MASTER "Build master server" off
.include <bsd.port.pre.mk>
@@ -43,11 +53,16 @@ IGNORE= needs at least one executable (CLIENT, DEDICATED or MASTER)
.endif
.if !defined(WITHOUT_CLIENT)
+USE_GETTEXT= yes
USE_GL= yes
USE_SDL= image mixer sdl
ALL_TARGET+= client
SUB_FILES+= ${PORTNAME}_client
ACUBE_BIN+= client
+
+DESKTOP_ENTRIES="AssaultCube" "${COMMENT}" \
+ "${DATADIR}/packages/misc/startscreen.png" "${PORTNAME}_client" \
+ "Application;Game;" ${FALSE}
.endif
.if !defined(WITHOUT_DEDICATED)
@@ -62,11 +77,6 @@ SUB_FILES+= ${PORTNAME}_master
ACUBE_BIN+= master
.endif
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(CXXOPTFLAGS)||' ${WRKSRC}/source/src/Makefile
-.endif
-
do-install:
.for f in ${ACUBE_BIN}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}_${f} ${PREFIX}/bin
diff --git a/games/assaultcube/files/assaultcube_client.in b/games/assaultcube/files/assaultcube_client.in
index 0bdd6781ce8f..a57f79969148 100644
--- a/games/assaultcube/files/assaultcube_client.in
+++ b/games/assaultcube/files/assaultcube_client.in
@@ -6,7 +6,7 @@
# are copied, and write permission for the user is added to them.
APPNAME="assaultcube"
-CUBE_OPTIONS="--home=~/.${APPNAME} --init"
+CUBE_OPTIONS="--home=${HOME}/.${APPNAME} --init"
if [ -d ~/.$APPNAME ]
then