aboutsummaryrefslogtreecommitdiff
path: root/games/asteroid
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-19 14:27:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-19 14:27:07 +0000
commit48ac5f73f84ca73eb1d545b2369adb06ddf2e06d (patch)
tree248bea5d83ed43c1ccbd56d52c9695a777b31275 /games/asteroid
parent9d32add2974bb224631e724d2f1203c1fcdb0933 (diff)
downloadports-48ac5f73f84ca73eb1d545b2369adb06ddf2e06d.tar.gz
ports-48ac5f73f84ca73eb1d545b2369adb06ddf2e06d.zip
Notes
Diffstat (limited to 'games/asteroid')
-rw-r--r--games/asteroid/Makefile13
-rw-r--r--games/asteroid/distinfo4
-rw-r--r--games/asteroid/pkg-descr2
-rw-r--r--games/asteroid/pkg-plist12
4 files changed, 24 insertions, 7 deletions
diff --git a/games/asteroid/Makefile b/games/asteroid/Makefile
index c5112b495799..cccd6ab558d7 100644
--- a/games/asteroid/Makefile
+++ b/games/asteroid/Makefile
@@ -2,15 +2,20 @@
# $FreeBSD$
PORTNAME= asteroid
-PORTVERSION= 1.2
+PORTVERSION= 1.2.1
CATEGORIES= games
-MASTER_SITES= SF/chaoslizard/Asteroid/v1.2%20%282012%20Apr.%2022%29/
MAINTAINER= nemysis@gmx.ch
COMMENT= Modern version of the arcade classic Asteroid
LICENSE= GPLv3
+USE_GITHUB= yes
+GH_ACCOUNT= chazomaticus
+GH_PROJECT= asteroid
+GH_TAGNAME= master
+GH_COMMIT= 6d23595
+
USE_GL= glut
USE_SDL= mixer sdl
USE_GNOME= gtk20
@@ -19,8 +24,7 @@ INSTALLS_ICONS= yes
USE_CMAKE= yes
CMAKE_VERBOSE= yes
-PORTDATA= *
-PORTDOCS= AUTHORS NEWS README
+PORTDOCS= AUTHORS NEWS README.md
.include <bsd.port.options.mk>
@@ -29,5 +33,6 @@ post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+ @-update-desktop-database -q
.include <bsd.port.mk>
diff --git a/games/asteroid/distinfo b/games/asteroid/distinfo
index 90b1673c8774..a9e82fa893fa 100644
--- a/games/asteroid/distinfo
+++ b/games/asteroid/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asteroid-1.2.tar.gz) = e268985efd23e65ad0e96d93bcc711d48f9a58da419645eb20a24a6a0ceaabe1
-SIZE (asteroid-1.2.tar.gz) = 310346
+SHA256 (asteroid-1.2.1.tar.gz) = 83c22a15bce77b4d040cbdae3c19f8fe87197a3202a1c70415deb2744b5f1c0e
+SIZE (asteroid-1.2.1.tar.gz) = 307691
diff --git a/games/asteroid/pkg-descr b/games/asteroid/pkg-descr
index 1e2311f6e3e9..6846adcbc2c8 100644
--- a/games/asteroid/pkg-descr
+++ b/games/asteroid/pkg-descr
@@ -18,4 +18,4 @@ collect the powerups, run over them; or you can shoot them for bonus points
to figure out the different powerup types.
-WWW: http://chaoslizard.sourceforge.net/asteroid/
+WWW: http://chazomaticus.github.com/asteroid/
diff --git a/games/asteroid/pkg-plist b/games/asteroid/pkg-plist
index 8ed1202e1c1a..c25587c8b272 100644
--- a/games/asteroid/pkg-plist
+++ b/games/asteroid/pkg-plist
@@ -1,8 +1,20 @@
bin/asteroid
share/applications/asteroid.desktop
+%%DATADIR%%/gfx/asteroid.bmp
+%%DATADIR%%/sfx/exp_asteroid.wav
+%%DATADIR%%/sfx/exp_other.wav
+%%DATADIR%%/sfx/exp_ship.wav
+%%DATADIR%%/sfx/get_powerup.wav
+%%DATADIR%%/sfx/newlevel.wav
+%%DATADIR%%/sfx/spawn_alien.wav
+%%DATADIR%%/sfx/spawn_powerup.wav
+%%DATADIR%%/sfx/spawn_shot.wav
share/icons/hicolor/scalable/apps/asteroid.svg
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@dirrm %%DATADIR%%/sfx
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%
@dirrmtry share/applications