aboutsummaryrefslogtreecommitdiff
path: root/games/asteroids3d/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:06:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-20 18:06:58 +0000
commit6beff77a3b4bc3a465458136bd208f1b585bcc86 (patch)
tree32fbd01aabe421289a8a0ffd0310250c79fda8c4 /games/asteroids3d/Makefile
parent92399528a7b2dd04c56e4856fe5679df8c05f380 (diff)
downloadports-6beff77a3b4bc3a465458136bd208f1b585bcc86.tar.gz
ports-6beff77a3b4bc3a465458136bd208f1b585bcc86.zip
Notes
Diffstat (limited to 'games/asteroids3d/Makefile')
-rw-r--r--games/asteroids3d/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index 38f7dbf05fd0..1283e8f7348c 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -3,45 +3,35 @@
PORTNAME= asteroids3d
PORTVERSION= 0.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/a3d/${PORTVERSION}/ \
SF/nemysisfreebsdp/:icons
DISTNAME= ${PORTNAME:S/3d/3D/}-${DISTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- asteroids3d_icons.tbz:icons
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
MAINTAINER= nemysis@gmx.ch
COMMENT= First-person shooter blowing up asteroids in 3D space
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- drm:${PORTSDIR}/graphics/libdrm \
- xcb:${PORTSDIR}/x11/libxcb
-
USE_BZIP2= yes
USE_AUTOTOOLS= aclocal autoheader
GNU_CONFIGURE= yes
CONFIGURE_ENV= with_gamesdir="${PREFIX}/bin" with_gamedatadir="${DATADIR}"
-USE_XORG= x11 xau xdamage xdmcp xext xfixes xi xrandr xrender xxf86vm
USE_GL= glut glu
MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-WRKSRC= ${WRKDIR}/${PORTNAME:S/3d/3D/}-${PORTVERSION}
-
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}_128.png \
- share/pixmaps/${PORTNAME}_48.png
-
-PORTDATA= *
PORTDOCS= README.html
-DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
+
+DESKTOP_ENTRIES="Asteroids3D" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
pre-configure:
@@ -58,7 +48,13 @@ do-install:
${MKDIR} ${DATADIR}
@(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${DATADIR})
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}