aboutsummaryrefslogtreecommitdiff
path: root/games/asteroids3d
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-21 08:45:50 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-21 08:45:50 +0000
commit61e223b2384e9ee36c7c1560e260da670f46d460 (patch)
treeda0037e42a4ec464c205d3b94ec22548c5dc5783 /games/asteroids3d
parent9c4246bd07a7a3e9d32a6184b4e49b856a7b86aa (diff)
downloadports-61e223b2384e9ee36c7c1560e260da670f46d460.tar.gz
ports-61e223b2384e9ee36c7c1560e260da670f46d460.zip
Notes
Diffstat (limited to 'games/asteroids3d')
-rw-r--r--games/asteroids3d/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/games/asteroids3d/Makefile b/games/asteroids3d/Makefile
index a40092e5c6e6..21a86f3bf592 100644
--- a/games/asteroids3d/Makefile
+++ b/games/asteroids3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asteroids3d
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/a3d/${PORTVERSION}/ \
LOCAL/madpilot/asteroids3d/:icons
@@ -44,17 +45,20 @@ pre-configure:
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/autogen.sh
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/3d/3D/} ${PREFIX}/bin/${PORTNAME}
-# Pixmaps
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+
# Data
-.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
@(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.ub *.ppm" ${DATADIR})
-.endif
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+
# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
.endif