aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-05 09:26:34 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-05 09:26:34 +0000
commit97a551d5d0120e113c38c2faa1df36ccd38dcb8f (patch)
tree46b710bd8bb2681976bb83932bc2b1a9df0733e9 /games/atr3d
parentb0c120b64446c3b888f2ed321f14e182978d8379 (diff)
downloadports-97a551d5d0120e113c38c2faa1df36ccd38dcb8f.tar.gz
ports-97a551d5d0120e113c38c2faa1df36ccd38dcb8f.zip
Notes
Diffstat (limited to 'games/atr3d')
-rw-r--r--games/atr3d/Makefile10
-rw-r--r--games/atr3d/files/patch-main.cpp13
2 files changed, 15 insertions, 8 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 84ee1cb441fb..978db7866ae3 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -27,10 +27,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_AUTOTOOLS= automake autoconf
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
@@ -53,9 +52,4 @@ post-patch:
pre-configure:
cd ${WRKSRC}; ${SH} autogen.sh
-post-configure:
- @${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/games/atr3d/files/patch-main.cpp b/games/atr3d/files/patch-main.cpp
new file mode 100644
index 000000000000..94f740ba9312
--- /dev/null
+++ b/games/atr3d/files/patch-main.cpp
@@ -0,0 +1,13 @@
+--- main.cpp.orig 2014-02-05 10:21:41.000000000 +0100
++++ main.cpp 2014-02-05 10:22:16.000000000 +0100
+@@ -58,6 +58,10 @@
+
+ initsound(&argc, argv);
+
++ /* initialize glut here, so we have
++ * access to argv and argc */
++ glutInit (&argc, argv);
++
+ DoInitializations();
+
+ playsound(NewLifeSound);