aboutsummaryrefslogtreecommitdiff
path: root/games/atris-sounds/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 14:07:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 14:07:41 +0000
commit8455f0e8414df5bfef7e4af56ea37141335a3906 (patch)
tree37358f11069cfbc6dce1a9c46691b9a7bf0c3958 /games/atris-sounds/Makefile
parent319b5d5fda6e9394fdc7b0b09121bc8710c31276 (diff)
downloadports-8455f0e8414df5bfef7e4af56ea37141335a3906.tar.gz
ports-8455f0e8414df5bfef7e4af56ea37141335a3906.zip
Notes
Diffstat (limited to 'games/atris-sounds/Makefile')
-rw-r--r--games/atris-sounds/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/atris-sounds/Makefile b/games/atris-sounds/Makefile
new file mode 100644
index 000000000000..9314ff52918e
--- /dev/null
+++ b/games/atris-sounds/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: games/atris-sounds
+# Date created: 9 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atris
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.cs.berkeley.edu/~weimer/atris/
+PKGNAMESUFFIX= -sounds
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Sounds for Atris: Alizarin Tetris
+
+RUN_DEPENDS= atris:${PORTSDIR}/games/atris
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+GNU_CONFIGURE= yes
+
+post-patch:
+# Fix path to ${DATADIR}
+ ${REINPLACE_CMD} -e 's|\(GAME_INSTALLDIR=\).*|\1"${DATADIR}"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>