aboutsummaryrefslogtreecommitdiff
path: root/games/atris-sounds
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 14:07:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 14:07:41 +0000
commit8455f0e8414df5bfef7e4af56ea37141335a3906 (patch)
tree37358f11069cfbc6dce1a9c46691b9a7bf0c3958 /games/atris-sounds
parent319b5d5fda6e9394fdc7b0b09121bc8710c31276 (diff)
downloadports-8455f0e8414df5bfef7e4af56ea37141335a3906.tar.gz
ports-8455f0e8414df5bfef7e4af56ea37141335a3906.zip
Notes
Diffstat (limited to 'games/atris-sounds')
-rw-r--r--games/atris-sounds/Makefile30
-rw-r--r--games/atris-sounds/distinfo2
-rw-r--r--games/atris-sounds/pkg-descr9
-rw-r--r--games/atris-sounds/pkg-plist65
4 files changed, 106 insertions, 0 deletions
diff --git a/games/atris-sounds/Makefile b/games/atris-sounds/Makefile
new file mode 100644
index 000000000000..9314ff52918e
--- /dev/null
+++ b/games/atris-sounds/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: games/atris-sounds
+# Date created: 9 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atris
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.cs.berkeley.edu/~weimer/atris/
+PKGNAMESUFFIX= -sounds
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Sounds for Atris: Alizarin Tetris
+
+RUN_DEPENDS= atris:${PORTSDIR}/games/atris
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+GNU_CONFIGURE= yes
+
+post-patch:
+# Fix path to ${DATADIR}
+ ${REINPLACE_CMD} -e 's|\(GAME_INSTALLDIR=\).*|\1"${DATADIR}"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/atris-sounds/distinfo b/games/atris-sounds/distinfo
new file mode 100644
index 000000000000..8689e9028a81
--- /dev/null
+++ b/games/atris-sounds/distinfo
@@ -0,0 +1,2 @@
+MD5 (atris-sounds-1.0.1.tar.gz) = 2e77d43aa09b106f23883599965bdd4a
+SIZE (atris-sounds-1.0.1.tar.gz) = 653737
diff --git a/games/atris-sounds/pkg-descr b/games/atris-sounds/pkg-descr
new file mode 100644
index 000000000000..b7a43de91579
--- /dev/null
+++ b/games/atris-sounds/pkg-descr
@@ -0,0 +1,9 @@
+Alizarin Tetris is a Tetris-like game with a twist for Unix, Win32 and BeOS
+systems. It includes multi-player support, user-extensible color, shape and
+sound styles, can use TCP/IP networking and features a few different AI
+opponents. It was written using the SDL Library.
+
+WWW: http://www.cs.berkeley.edu/~weimer/atris/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/atris-sounds/pkg-plist b/games/atris-sounds/pkg-plist
new file mode 100644
index 000000000000..9f1bfb103ea2
--- /dev/null
+++ b/games/atris-sounds/pkg-plist
@@ -0,0 +1,65 @@
+%%DATADIR%%/sounds/Abuse-Ammo.wav
+%%DATADIR%%/sounds/Abuse-Crumble.wav
+%%DATADIR%%/sounds/Abuse-Death.wav
+%%DATADIR%%/sounds/Abuse-Explode.wav
+%%DATADIR%%/sounds/Abuse-Hit.wav
+%%DATADIR%%/sounds/Abuse-Save.wav
+%%DATADIR%%/sounds/Abuse-Scream.wav
+%%DATADIR%%/sounds/Abuse-Speed.wav
+%%DATADIR%%/sounds/Abuse.Sound
+%%DATADIR%%/sounds/AllRight.wav
+%%DATADIR%%/sounds/AndSoItBegins.wav
+%%DATADIR%%/sounds/B5.Sound
+%%DATADIR%%/sounds/Boom.wav
+%%DATADIR%%/sounds/BoomBoom.wav
+%%DATADIR%%/sounds/Default.Sound
+%%DATADIR%%/sounds/Doh.Sound
+%%DATADIR%%/sounds/Doh.wav
+%%DATADIR%%/sounds/Effects.Sound
+%%DATADIR%%/sounds/EnemyFire.wav
+%%DATADIR%%/sounds/ExplosionM.wav
+%%DATADIR%%/sounds/HesDeadJim.wav
+%%DATADIR%%/sounds/Lemming.Sound
+%%DATADIR%%/sounds/Makefile
+%%DATADIR%%/sounds/Makefile.in
+%%DATADIR%%/sounds/Mirror1.Sound
+%%DATADIR%%/sounds/Mirror2.Sound
+%%DATADIR%%/sounds/MrMorden.wav
+%%DATADIR%%/sounds/NoNoNoNo.wav
+%%DATADIR%%/sounds/NotReady.wav
+%%DATADIR%%/sounds/PhotonShot.wav
+%%DATADIR%%/sounds/ShortWhoop2.wav
+%%DATADIR%%/sounds/Siren.wav
+%%DATADIR%%/sounds/StarTrek.Sound
+%%DATADIR%%/sounds/TwoPointThreeMinutes.wav
+%%DATADIR%%/sounds/UnpleasantSituation.wav
+%%DATADIR%%/sounds/VorlonNo.wav
+%%DATADIR%%/sounds/VorlonPerhaps.wav
+%%DATADIR%%/sounds/Vortex.wav
+%%DATADIR%%/sounds/antigrav.wav
+%%DATADIR%%/sounds/autsch.wav
+%%DATADIR%%/sounds/bombh.wav
+%%DATADIR%%/sounds/bong.wav
+%%DATADIR%%/sounds/borkh.wav
+%%DATADIR%%/sounds/bounce.wav
+%%DATADIR%%/sounds/bowl.wav
+%%DATADIR%%/sounds/clock.wav
+%%DATADIR%%/sounds/entrmenu.wav
+%%DATADIR%%/sounds/gavel.wav
+%%DATADIR%%/sounds/halle.wav
+%%DATADIR%%/sounds/halloffame.wav
+%%DATADIR%%/sounds/kabumm.wav
+%%DATADIR%%/sounds/laser.wav
+%%DATADIR%%/sounds/lem-letsgo.wav
+%%DATADIR%%/sounds/lem-mantrap.wav
+%%DATADIR%%/sounds/lem-ohno.wav
+%%DATADIR%%/sounds/lem-tenton.wav
+%%DATADIR%%/sounds/lem-yippee.wav
+%%DATADIR%%/sounds/nazgulh.wav
+%%DATADIR%%/sounds/quiek.wav
+%%DATADIR%%/sounds/roaaar.wav
+%%DATADIR%%/sounds/sneaky.wav
+%%DATADIR%%/sounds/staffh.wav
+%%DATADIR%%/sounds/whirling.wav
+%%DATADIR%%/sounds/whoosh.wav
+@dirrm %%DATADIR%%/sounds