aboutsummaryrefslogtreecommitdiff
path: root/games/avanor
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-30 03:42:03 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-30 03:42:03 +0000
commite6da6bcb3206512759d340d1355ed35261e811b6 (patch)
treef84415fc214d76ac9dba157b3becf717977b1f4b /games/avanor
parentddda6c8e505a74976130a15d0b586b54e6414e8d (diff)
downloadports-e6da6bcb3206512759d340d1355ed35261e811b6.tar.gz
ports-e6da6bcb3206512759d340d1355ed35261e811b6.zip
- Add stage support
- Fix build with clang - Convert USE_GMAKE to USES
Notes
Notes: svn path=/head/; revision=332059
Diffstat (limited to 'games/avanor')
-rw-r--r--games/avanor/Makefile9
-rw-r--r--games/avanor/files/patch-game__cave.cpp12
2 files changed, 16 insertions, 5 deletions
diff --git a/games/avanor/Makefile b/games/avanor/Makefile
index 86ae56807fd9..07082e6af8bb 100644
--- a/games/avanor/Makefile
+++ b/games/avanor/Makefile
@@ -11,11 +11,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Rogue-like game with easy ADOM-like user interface
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS+= VERSION=${PORTVERSION} DATA_DIR=${DATADIR}/
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|g++|${CXX}|; \
s|CFLAGS =|CFLAGS+=|;" \
@@ -25,8 +24,8 @@ post-patch:
${WRKSRC}/helpers/hiscore.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/avanor ${PREFIX}/bin
- ${MKDIR} ${DATADIR}/manual
- ${INSTALL_DATA} ${WRKSRC}/manual/* ${DATADIR}/manual/
+ ${INSTALL_PROGRAM} ${WRKSRC}/avanor ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}/manual
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${STAGEDIR}${DATADIR}/manual/
.include <bsd.port.mk>
diff --git a/games/avanor/files/patch-game__cave.cpp b/games/avanor/files/patch-game__cave.cpp
new file mode 100644
index 000000000000..c6b3f9dea1d8
--- /dev/null
+++ b/games/avanor/files/patch-game__cave.cpp
@@ -0,0 +1,12 @@
+--- ./game/cave.cpp.orig 2013-10-30 01:23:52.000000000 -0200
++++ ./game/cave.cpp 2013-10-30 01:25:33.000000000 -0200
+@@ -192,7 +192,8 @@
+ }
+
+ }
+- r.Setup(&XRect(x, y, x + l, y + h));
++ XRect xrecttemp = XRect(x, y, x + l, y + h);
++ r.Setup(&xrecttemp);
+ }
+
+ int XCave::Compare(XObject * o)