aboutsummaryrefslogtreecommitdiff
path: root/games/avoision/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:41:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:41:12 +0000
commit28e66b9e9318fdde67c1d8ec78aaf14122da25f8 (patch)
tree4ca7f6998d356c98e1a75d64503b73b79e89e964 /games/avoision/Makefile
parentcb208bc502607f6ffd5bc251b7e84cce4f1b8a10 (diff)
downloadports-28e66b9e9318fdde67c1d8ec78aaf14122da25f8.tar.gz
ports-28e66b9e9318fdde67c1d8ec78aaf14122da25f8.zip
Notes
Diffstat (limited to 'games/avoision/Makefile')
-rw-r--r--games/avoision/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/games/avoision/Makefile b/games/avoision/Makefile
new file mode 100644
index 000000000000..2d4ca788b313
--- /dev/null
+++ b/games/avoision/Makefile
@@ -0,0 +1,49 @@
+# New Ports collection makefile for: Avoision
+# Date created: 2012-05-17
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= avoision
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= SF/avsn/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Avoision is a simple collect-dots-avoid-blocks game
+
+LICENSE= GPLv2 CCbyNCSA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
+LICENSE_FILE= ${WRKSRC}/License.txt
+LICENSE_FILE_CCbyNCSA3=${WRKSRC}/License.txt
+LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+
+LIB_DEPENDS= radius:${PORTSDIR}/graphics/radius-engine \
+ lua-5.1:${PORTSDIR}/lang/lua \
+ png:${PORTSDIR}/graphics/png \
+ physfs.1:${PORTSDIR}/devel/physfs
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
+USE_SDL= sdl sound
+USE_GL= glu
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/applications
+
+PORTDATA= *
+PORTDOCS= ChangeLog
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>