aboutsummaryrefslogtreecommitdiff
path: root/games/barbie_seahorse_adventures
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-05 20:12:35 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-05 20:12:35 +0000
commitf4079f29183255c94aff8d8d127c5fabba12c9c5 (patch)
treec4ea81ca74707c283166209c3d104c8ba547ab17 /games/barbie_seahorse_adventures
parentb62db23e438b80ccc560df20c92ee3cda34f46a2 (diff)
downloadports-f4079f29183255c94aff8d8d127c5fabba12c9c5.tar.gz
ports-f4079f29183255c94aff8d8d127c5fabba12c9c5.zip
Notes
Diffstat (limited to 'games/barbie_seahorse_adventures')
-rw-r--r--games/barbie_seahorse_adventures/Makefile35
-rw-r--r--games/barbie_seahorse_adventures/distinfo6
-rw-r--r--games/barbie_seahorse_adventures/pkg-plist18
3 files changed, 23 insertions, 36 deletions
diff --git a/games/barbie_seahorse_adventures/Makefile b/games/barbie_seahorse_adventures/Makefile
index 4218d72ed97d..fbb0dc092449 100644
--- a/games/barbie_seahorse_adventures/Makefile
+++ b/games/barbie_seahorse_adventures/Makefile
@@ -1,18 +1,15 @@
-# Created by: nemysis@gmx.ch
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= barbie_seahorse_adventures
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.1
CATEGORIES= games python
-MASTER_SITES= http://www.imitationpickles.org/barbie/files/ \
- SF/nemysisfreebsdp/:icons
-DISTFILES= barbie-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}_icons.tar.gz:icons
+MASTER_SITES= http://www.imitationpickles.org/barbie/files/
+DISTNAME= barbie-${DISTVERSION}
+EXTRACT_SUFX= .tgz
DIST_SUBDIR= python
MAINTAINER= nemysis@FreeBSD.org
-
COMMENT= You are a seahorse and you want to go to the moon!
LICENSE= GPLv2
@@ -21,38 +18,46 @@ RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/barbie-${DISTVERSION}
-USE_PYTHON= yes
+USE_PYTHON= 2
NO_BUILD= yes
-PORTDOCS= CHANGES.txt LEVELS.txt NOTES.txt README.txt TODO.txt
+PORTDOCS= CHANGES.txt LEVELS.txt NOTES.txt README.txt
+OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
-ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+ICON_SIZES= 32x32 64x64 128x128
SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="Barbie Seahorse Adventures" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
+post-extract:
+ @cd ${WRKSRC} && ${RM} -f data/REMOVE_ME.txt data/sample.txt \
+ lib/pgu/LICENSE.txt
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
${WRKSRC}/leveledit.py ${WRKSRC}/tileedit.py
@${FIND} ${WRKSRC} -name "*.bak" -delete
+.for s in 32 64 128
+ @cd ${WRKSRC} && \
+ ${MV} icon${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
do-install:
@${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
${WRKDIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "data lib" ${STAGEDIR}${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}_${s}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/64x64/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/barbie_seahorse_adventures/distinfo b/games/barbie_seahorse_adventures/distinfo
index f84693412a7e..b1ca444d7045 100644
--- a/games/barbie_seahorse_adventures/distinfo
+++ b/games/barbie_seahorse_adventures/distinfo
@@ -1,4 +1,2 @@
-SHA256 (python/barbie-1.0.tar.gz) = 8a5312545e51b94a28194679b2a8b8a7558ac105b706fe07ccabab6d47537861
-SIZE (python/barbie-1.0.tar.gz) = 2172446
-SHA256 (python/barbie_seahorse_adventures_icons.tar.gz) = fa19defbd017b8b80f672327faa69ce694f56760b9478cb32f365804a57bd280
-SIZE (python/barbie_seahorse_adventures_icons.tar.gz) = 16896
+SHA256 (python/barbie-1.1.tgz) = 915e261ae6b4321a38740c38ddf5f32b791b2c00b6f9f0cdd9fb87b0acf4f9f0
+SIZE (python/barbie-1.1.tgz) = 2205215
diff --git a/games/barbie_seahorse_adventures/pkg-plist b/games/barbie_seahorse_adventures/pkg-plist
index 0a5f1ba35051..9eb2f2c57055 100644
--- a/games/barbie_seahorse_adventures/pkg-plist
+++ b/games/barbie_seahorse_adventures/pkg-plist
@@ -1,7 +1,6 @@
bin/barbie_seahorse_adventures
%%DATADIR%%/create-upload.py
%%DATADIR%%/data/6x12.png
-%%DATADIR%%/data/REMOVE_ME.txt
%%DATADIR%%/data/bkgr.png
%%DATADIR%%/data/bkgr/1.png
%%DATADIR%%/data/bkgr/2.png
@@ -144,7 +143,6 @@ bin/barbie_seahorse_adventures
%%DATADIR%%/data/music/lvlwin.ogg
%%DATADIR%%/data/music/title.ogg
%%DATADIR%%/data/pal.png
-%%DATADIR%%/data/sample.txt
%%DATADIR%%/data/sfx/boss_explode.wav
%%DATADIR%%/data/sfx/bubble.wav
%%DATADIR%%/data/sfx/capsule.wav
@@ -415,24 +413,10 @@ bin/barbie_seahorse_adventures
%%DATADIR%%/run_game.py
%%DATADIR%%/setup.py
%%DATADIR%%/tileedit.py
+share/icons/hicolor/128x128/apps/barbie_seahorse_adventures.png
share/icons/hicolor/32x32/apps/barbie_seahorse_adventures.png
-share/icons/hicolor/48x48/apps/barbie_seahorse_adventures.png
share/icons/hicolor/64x64/apps/barbie_seahorse_adventures.png
-share/icons/hicolor/72x72/apps/barbie_seahorse_adventures.png
-share/icons/hicolor/96x96/apps/barbie_seahorse_adventures.png
share/pixmaps/barbie_seahorse_adventures.png
-@dirrmtry share/icons/hicolor/96x96/apps
-@dirrmtry share/icons/hicolor/96x96
-@dirrmtry share/icons/hicolor/72x72/apps
-@dirrmtry share/icons/hicolor/72x72
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
@dirrm %%DATADIR%%/lib/pgu/gui
@dirrm %%DATADIR%%/lib/pgu
@dirrm %%DATADIR%%/lib