aboutsummaryrefslogtreecommitdiff
path: root/games/battleball
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2011-01-20 11:07:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2011-01-20 11:07:06 +0000
commitbdc3d88407a3fa1ff7f2da8014cadbf18c78fedb (patch)
tree1ce09af15a10cac05751e9a325c993f1c5cbf7cf /games/battleball
parent1b78ff3c003a1e36de7bb89541e1cbf3f5ebf9f3 (diff)
downloadports-bdc3d88407a3fa1ff7f2da8014cadbf18c78fedb.tar.gz
ports-bdc3d88407a3fa1ff7f2da8014cadbf18c78fedb.zip
Notes
Diffstat (limited to 'games/battleball')
-rw-r--r--games/battleball/Makefile4
-rw-r--r--games/battleball/files/patch-lib3d-bsppanel3d.C11
-rw-r--r--games/battleball/files/patch-lib3d-bspregion3d.C11
3 files changed, 22 insertions, 4 deletions
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index 7470c7f74cef..bf2f0c383fff 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -31,10 +31,6 @@ PORTDOCS= CHANGELOG README
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
-BROKEN= Does not compile
-.endif
-
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64 or sparc64
.endif
diff --git a/games/battleball/files/patch-lib3d-bsppanel3d.C b/games/battleball/files/patch-lib3d-bsppanel3d.C
new file mode 100644
index 000000000000..3067ce05d590
--- /dev/null
+++ b/games/battleball/files/patch-lib3d-bsppanel3d.C
@@ -0,0 +1,11 @@
+--- lib3d/bsppanel3d.C.orig 2011-01-20 12:02:35.000000000 +0100
++++ lib3d/bsppanel3d.C 2011-01-20 12:03:32.000000000 +0100
+@@ -42,7 +42,7 @@
+ }
+
+ pt3d2Vec3f(normal,poly.plane_normal);
+- poly.material_index= (int) this;
++ poly.material_index= (intptr_t) this;
+ return poly;
+ }
+
diff --git a/games/battleball/files/patch-lib3d-bspregion3d.C b/games/battleball/files/patch-lib3d-bspregion3d.C
new file mode 100644
index 000000000000..f9d74f42fe3c
--- /dev/null
+++ b/games/battleball/files/patch-lib3d-bspregion3d.C
@@ -0,0 +1,11 @@
+--- lib3d/bspregion3d.C.orig 2011-01-20 12:04:50.000000000 +0100
++++ lib3d/bspregion3d.C 2011-01-20 12:05:08.000000000 +0100
+@@ -97,7 +97,7 @@
+ xpanel3d& panel= * (xpanel3d *) poly->material_index;
+
+ poly->material_index=
+- (int) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
++ (intptr_t) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
+ }
+ MakeBspTreePanels(bspt->negative);
+ MakeBspTreePanels(bspt->positive);