aboutsummaryrefslogtreecommitdiff
path: root/games/battleball
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-09 02:47:51 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-10-09 02:47:51 +0000
commitc3ef22e5074da76f3c1ee829ef48d204ce040fc8 (patch)
treee774af268961483556ceccc49ef1a585f2e45ce0 /games/battleball
parentb701e182a654c26eba0d8736d26c90cc1ffc7811 (diff)
downloadports-c3ef22e5074da76f3c1ee829ef48d204ce040fc8.tar.gz
ports-c3ef22e5074da76f3c1ee829ef48d204ce040fc8.zip
Notes
Diffstat (limited to 'games/battleball')
-rw-r--r--games/battleball/Makefile52
-rw-r--r--games/battleball/distinfo2
-rw-r--r--games/battleball/files/patch-ab22
-rw-r--r--games/battleball/files/patch-lib3d-bsppanel3d.C11
-rw-r--r--games/battleball/files/patch-lib3d-bspregion3d.C11
-rw-r--r--games/battleball/files/patch-lib3d-general.h18
-rw-r--r--games/battleball/files/patch-lib3d-xform.h10
-rw-r--r--games/battleball/pkg-descr14
8 files changed, 0 insertions, 140 deletions
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
deleted file mode 100644
index 389eefdb0339..000000000000
--- a/games/battleball/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# New ports collection makefile for: battleball
-# Date created: 18 December 1998
-# Whom: Andrey Zakhvatov
-#
-# $FreeBSD$
-#
-
-PORTNAME= battleball
-PORTVERSION= 2.1
-PORTREVISION= 3
-CATEGORIES= games
-MASTER_SITES= http://freebsd.aeternal.net/ports/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= 3D single/multiplayer military soccer game for X Window System
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-USE_GL= glu gl
-USE_XORG= xmu xi
-WRKSRC= ${WRKDIR}/battleball-2.1-src
-CFLAGS+= -Wno-deprecated ${PTHREAD_CFLAGS}
-MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- XLIBS="-L${LOCALBASE}/lib -lX11" \
- LIBS="-lm ${XLIBS} ${PTHREAD_LIBS}" \
- GLINCS="-I${LOCALBASE}/include" \
- GLLIBS="-lXi -lXmu -lXext -L${LOCALBASE}/lib -lGL"
-
-PLIST_FILES= bin/battleball
-.if !defined(NOPORTDOCS)
-PORTDOCS= CHANGELOG README
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64 or sparc64
-.endif
-
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/battleball ${PREFIX}/bin
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/games/battleball/distinfo b/games/battleball/distinfo
deleted file mode 100644
index 3e8c542c5ed1..000000000000
--- a/games/battleball/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (battleball-2.1.tar.gz) = 167cf95608eb16761179bb5f2f273ab621d0f52ed6785d66c99bc3b8a9a99caa
-SIZE (battleball-2.1.tar.gz) = 102001
diff --git a/games/battleball/files/patch-ab b/games/battleball/files/patch-ab
deleted file mode 100644
index 6db63fcfcb25..000000000000
--- a/games/battleball/files/patch-ab
+++ /dev/null
@@ -1,22 +0,0 @@
---- bb/main.C Thu Sep 2 22:25:19 1999
-+++ bb/main.C.new Sun Apr 16 17:23:35 2000
-@@ -11,6 +11,9 @@
- #include <stdio.h> // to get sprintf()
- #include <string.h> // to get strncpy()
- #include <time.h> // to get time(time_t *)
-+#if defined(__FreeBSD__) && !defined(__alpha__) && !defined(__amd64__)
-+#include <floatingpoint.h>
-+#endif
- #include "bb.h"
- #include "bbgfxtarget.h"
- #include "player.h"
-@@ -803,6 +806,9 @@
- /*=========================================================================*/
- // A long and complicated main() function!
- main (int argc, char *argv[]) {
-+#if defined(__FreeBSD__) && !defined(__alpha__) && !defined(__amd64__)
-+ fpsetmask(0);
-+#endif
- bb= new battleBall(argc,argv);
- bb->Play();
- delete bb;
diff --git a/games/battleball/files/patch-lib3d-bsppanel3d.C b/games/battleball/files/patch-lib3d-bsppanel3d.C
deleted file mode 100644
index 3067ce05d590..000000000000
--- a/games/battleball/files/patch-lib3d-bsppanel3d.C
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib3d/bsppanel3d.C.orig 2011-01-20 12:02:35.000000000 +0100
-+++ lib3d/bsppanel3d.C 2011-01-20 12:03:32.000000000 +0100
-@@ -42,7 +42,7 @@
- }
-
- pt3d2Vec3f(normal,poly.plane_normal);
-- poly.material_index= (int) this;
-+ poly.material_index= (intptr_t) this;
- return poly;
- }
-
diff --git a/games/battleball/files/patch-lib3d-bspregion3d.C b/games/battleball/files/patch-lib3d-bspregion3d.C
deleted file mode 100644
index f9d74f42fe3c..000000000000
--- a/games/battleball/files/patch-lib3d-bspregion3d.C
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib3d/bspregion3d.C.orig 2011-01-20 12:04:50.000000000 +0100
-+++ lib3d/bspregion3d.C 2011-01-20 12:05:08.000000000 +0100
-@@ -97,7 +97,7 @@
- xpanel3d& panel= * (xpanel3d *) poly->material_index;
-
- poly->material_index=
-- (int) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
-+ (intptr_t) & *treePanels.insert(treePanels.end(),xpanel3d(*poly,pts,panel));
- }
- MakeBspTreePanels(bspt->negative);
- MakeBspTreePanels(bspt->positive);
diff --git a/games/battleball/files/patch-lib3d-general.h b/games/battleball/files/patch-lib3d-general.h
deleted file mode 100644
index e795d45e4463..000000000000
--- a/games/battleball/files/patch-lib3d-general.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- lib3d/general.h.orig Fri Sep 3 04:25:19 1999
-+++ lib3d/general.h Fri Jul 18 17:42:41 2003
-@@ -25,9 +25,15 @@
- typedef unsigned int uint;
- typedef unsigned long ulong;
-
-+#ifdef __GNUC__
-+#if __GNUC__ < 3
- #define and &&
- #define or ||
- #define not !
-+#endif
-+
-+// TODO - what about non-GNU C++ compilers?
-+#endif
-
- #define forii(limit) for (int i= 0; i <limit; i++)
- #define forij(limit) for (int j= 0; j <limit; j++)
diff --git a/games/battleball/files/patch-lib3d-xform.h b/games/battleball/files/patch-lib3d-xform.h
deleted file mode 100644
index bca2ac7076d7..000000000000
--- a/games/battleball/files/patch-lib3d-xform.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib3d/xform.h.orig Fri Jul 18 17:28:08 2003
-+++ lib3d/xform.h Fri Jul 18 17:26:11 2003
-@@ -64,6 +64,7 @@
-
- //===========================================================================
- class tmtrx {
-+ friend struct player;
- typedef double fourby3[4][3];
- fourby3 m;
-
diff --git a/games/battleball/pkg-descr b/games/battleball/pkg-descr
deleted file mode 100644
index fd6adc946f19..000000000000
--- a/games/battleball/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-BattleBall is essentially the game of soccer, played with military
-vehicles rather than with people. Each player drives a tank or flies
-a helicopter, and tries to move the ball down the playfield to the
-other team's goal. In BattleBall, the teams' "goals" are their
-headquarters buildings, positioned at the ends of the playfield.
-Hitting another team's headquarters building with the ball scores a
-point, knocking the building over in the process. Yes, realism was
-my ultimate goal in this game.
-
-Players are organized into teams. Up to six teams can play at once, and
-teams may have any combination of human and computer players. All teams
-compete on the playfield simultaneously. To reduce disorientation and
-chaos, players' vehicles are painted with their team's colors, and
-headquarters buildings are marked with their team's insignia.