aboutsummaryrefslogtreecommitdiff
path: root/games/biniax2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 08:48:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 08:48:10 +0000
commit0059c76a1c1dc2b83592a4e291abc24cad8e584a (patch)
treea84d838c991fb408aa749b4d927ef8ed2f8339a2 /games/biniax2
parent129c27a433516da2b9288daa34398abdd5fa7616 (diff)
downloadports-0059c76a1c1dc2b83592a4e291abc24cad8e584a.tar.gz
ports-0059c76a1c1dc2b83592a4e291abc24cad8e584a.zip
Notes
Diffstat (limited to 'games/biniax2')
-rw-r--r--games/biniax2/Makefile38
-rw-r--r--games/biniax2/distinfo3
-rw-r--r--games/biniax2/files/patch-biniax.c18
-rw-r--r--games/biniax2/pkg-descr7
-rw-r--r--games/biniax2/pkg-plist43
5 files changed, 109 insertions, 0 deletions
diff --git a/games/biniax2/Makefile b/games/biniax2/Makefile
new file mode 100644
index 000000000000..ba29259e4638
--- /dev/null
+++ b/games/biniax2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: biniax2
+# Date created: 16 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= biniax2
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://mordred.dir.bg/biniax/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}-fullsrc
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Original logic game with arcade and tactics modes
+
+USE_SDL= sdl mixer image
+
+WRKSRC= ${WRKDIR}
+
+post-patch:
+ @${RM} -f ${WRKSRC}/data/Thumbs.db
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|g' \
+ ${WRKSRC}/desktop/gfx.c ${WRKSRC}/desktop/snd.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} biniax.c hof.c desktop/cfg.c \
+ desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c \
+ -I. -Idesktop `${SDL_CONFIG} --cflags --libs` \
+ -lSDL_image -lSDL_mixer -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/biniax2/distinfo b/games/biniax2/distinfo
new file mode 100644
index 000000000000..8a7751aeddd7
--- /dev/null
+++ b/games/biniax2/distinfo
@@ -0,0 +1,3 @@
+MD5 (biniax2-fullsrc.tar.gz) = 2bd3a46f5caea361ed8a7ec60a16f110
+SHA256 (biniax2-fullsrc.tar.gz) = 50db7c7a6bd7377aa1b4de617ad4d3abebc81212b8d72f384d59cf937f758508
+SIZE (biniax2-fullsrc.tar.gz) = 2972058
diff --git a/games/biniax2/files/patch-biniax.c b/games/biniax2/files/patch-biniax.c
new file mode 100644
index 000000000000..31ba89e86886
--- /dev/null
+++ b/games/biniax2/files/patch-biniax.c
@@ -0,0 +1,18 @@
+--- biniax.c.orig 2008-04-08 09:25:14.000000000 +0400
++++ biniax.c 2008-04-16 22:33:02.000000000 +0400
+@@ -89,6 +89,15 @@
+
+ int main( int argc, char *argv[] )
+ {
++ if (chdir(getenv("HOME")) != 0)
++ err(1, "cannot chdir to $HOME");
++
++ if (mkdir(".biniax2", 0755) != 0 && errno != EEXIST)
++ err(1, "cannot mkdir $HOME/.biniax2");
++
++ if (chdir(".biniax2") != 0)
++ err(1, "cannot chdir to $HOME/.biniax2");
++
+ BNX_BOOL bquit = BNX_FALSE;
+ BNX_INT16 enterState = cStateMainMenu;
+ BNX_INT16 nmenu = 0;
diff --git a/games/biniax2/pkg-descr b/games/biniax2/pkg-descr
new file mode 100644
index 000000000000..125b31940d78
--- /dev/null
+++ b/games/biniax2/pkg-descr
@@ -0,0 +1,7 @@
+Biniax-2 is original and entertaining game. Takes a minute to learn
+and gives you hours and hours of gameplay. Discover the different
+Biniax-2 faces - for action heroes or careful strategists. Biniax-2
+has three game modes (two singleplayer and one multiplayer), hall
+of fame, dynamic music and nice cartoon look.
+
+WWW: http://biniax.com/index2.html
diff --git a/games/biniax2/pkg-plist b/games/biniax2/pkg-plist
new file mode 100644
index 000000000000..3b312342120a
--- /dev/null
+++ b/games/biniax2/pkg-plist
@@ -0,0 +1,43 @@
+bin/biniax2
+%%DATADIR%%/graphics/background0.png
+%%DATADIR%%/graphics/background1.png
+%%DATADIR%%/graphics/background2.png
+%%DATADIR%%/graphics/cursor0.png
+%%DATADIR%%/graphics/cursor1.png
+%%DATADIR%%/graphics/element0.png
+%%DATADIR%%/graphics/element1.png
+%%DATADIR%%/graphics/element2.png
+%%DATADIR%%/graphics/element3.png
+%%DATADIR%%/graphics/elementB.png
+%%DATADIR%%/graphics/font.png
+%%DATADIR%%/graphics/help.png
+%%DATADIR%%/graphics/logo.png
+%%DATADIR%%/graphics/marker0.png
+%%DATADIR%%/graphics/marker1.png
+%%DATADIR%%/graphics/movecount.png
+%%DATADIR%%/graphics/particle0.png
+%%DATADIR%%/graphics/particle1.png
+%%DATADIR%%/graphics/particle2.png
+%%DATADIR%%/graphics/roadmap.png
+%%DATADIR%%/graphics/splash.png
+%%DATADIR%%/graphics/sweep.png
+%%DATADIR%%/graphics/window.png
+%%DATADIR%%/music/biniax_common00.it
+%%DATADIR%%/music/biniax_common01.it
+%%DATADIR%%/music/biniax_common02.it
+%%DATADIR%%/music/biniax_common03.it
+%%DATADIR%%/music/biniax_common04.it
+%%DATADIR%%/music/biniax_common05.it
+%%DATADIR%%/music/biniax_common06.it
+%%DATADIR%%/music/biniax_common07.it
+%%DATADIR%%/sound/sfx1.wav
+%%DATADIR%%/sound/sfx2.wav
+%%DATADIR%%/sound/sfx3.wav
+%%DATADIR%%/sound/sfx4.wav
+%%DATADIR%%/sound/sfx5.wav
+%%DATADIR%%/text/help.txt
+@dirrm %%DATADIR%%/text
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%