aboutsummaryrefslogtreecommitdiff
path: root/games/biorythm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 23:00:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 23:00:11 +0000
commitb008129835f6baa6c7cd9651e13911d0060c3cea (patch)
tree4b977657571ef94ae088c2d326890060855e7569 /games/biorythm
parentf7a354dee19e238aa6300424b155c5db4a19bfa7 (diff)
downloadports-b008129835f6baa6c7cd9651e13911d0060c3cea.tar.gz
ports-b008129835f6baa6c7cd9651e13911d0060c3cea.zip
Notes
Diffstat (limited to 'games/biorythm')
-rw-r--r--games/biorythm/Makefile20
-rw-r--r--games/biorythm/distinfo6
-rw-r--r--games/biorythm/files/patch-aa48
-rw-r--r--games/biorythm/files/patch-ab12
-rw-r--r--games/biorythm/pkg-plist5
5 files changed, 18 insertions, 73 deletions
diff --git a/games/biorythm/Makefile b/games/biorythm/Makefile
index cfa88b9c7ba9..dc593f4eb03f 100644
--- a/games/biorythm/Makefile
+++ b/games/biorythm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= biorythm
-PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTVERSION= 1.1.3
CATEGORIES= games
MASTER_SITES= http://shh.thathost.com/pub-unix/files/
@@ -17,11 +16,22 @@ COMMENT= Simple biorythm calculation program
LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
shhopt.1:${PORTSDIR}/devel/libshhopt
-USE_GMAKE= yes
+MAN6= ${PORTNAME}.6
+PORTDOCS= CREDITS ChangeLog README
+PLIST_FILES= bin/${PORTNAME}
-MAN6= biorythm.6
+post-patch:
+ @${REINPLACE_CMD} -e '/VERSION/s|[[:space:]]"$$|\\n"| ; \
+ /COMPILED_DATE/d' ${WRKSRC}/biorythm.c
-post-install:
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -I. -I${LOCALBASE}/include \
+ -DVERSION=\"${PORTVERSION}\" -D_ANSI_SOURCE *.c \
+ -o ${PORTNAME} -L${LOCALBASE}/lib -lshhmsg -lshhopt -lm
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MAN6PREFIX}/man/man6
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in CREDITS ChangeLog README
diff --git a/games/biorythm/distinfo b/games/biorythm/distinfo
index eb947d291934..b4a551c177fe 100644
--- a/games/biorythm/distinfo
+++ b/games/biorythm/distinfo
@@ -1,3 +1,3 @@
-MD5 (biorythm-1.1.2.tar.gz) = 4a85612ec675ce9fae4bb77cc48a6143
-SHA256 (biorythm-1.1.2.tar.gz) = 39037605c34e05d72ba6a1fecb5d7bae4cc43acdad1c6c2281e0a5ae0c400c79
-SIZE (biorythm-1.1.2.tar.gz) = 6481
+MD5 (biorythm-1.1.3.tar.gz) = 5138036284617e783e1ee6901b441739
+SHA256 (biorythm-1.1.3.tar.gz) = 53a510b28eaa3308e4bd84b9e5c71c02580cbb9556ab23652aaf71839a4a2d35
+SIZE (biorythm-1.1.3.tar.gz) = 6490
diff --git a/games/biorythm/files/patch-aa b/games/biorythm/files/patch-aa
deleted file mode 100644
index 0c3ee4f49ca5..000000000000
--- a/games/biorythm/files/patch-aa
+++ /dev/null
@@ -1,48 +0,0 @@
---- Makefile.orig Sat Mar 2 21:32:42 2002
-+++ Makefile Wed May 8 21:34:35 2002
-@@ -5,33 +5,29 @@
- VERMIN = 1
- VERPAT = 2
- VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
--COMPILED_DATE = `date '+%Y-%m-%d %H:%M:%S'`
--COMPILED_BY = `whoami`
-
- ###########################################################################
-
- # where are shhmsg and shhopt?
--INCDIR = -I/usr/local/include
--LIBDIR = -L/usr/local/lib
-+INCDIR = -I${LOCALBASE}/include
-+LIBDIR = -L${LOCALBASE}/lib
-
--INSTBASEDIR = /usr/local
--INSTBINDIR = $(INSTBASEDIR)/games
-+INSTBASEDIR = ${PREFIX}
-+INSTBINDIR = $(INSTBASEDIR)/bin
- INSTMANDIR = $(INSTBASEDIR)/man/man6
--INSTALL = install -m 644
--INSTALLPROG = install -s -m 755
--MKDIRP = install -d -m 755
--
--DEFINES = -DVERSION=\"$(VERSION)\" \
-- "-DCOMPILED_DATE=\"$(COMPILED_DATE)\"" \
-- "-DCOMPILED_BY=\"$(COMPILED_BY)\""
-+INSTALL = ${BSD_INSTALL_DATA}
-+INSTALLPROG = ${BSD_INSTALL_PROGRAM}
-+MKDIRP = mkdir -p
-+
-+DEFINES = -DVERSION=\"$(VERSION)\" -D_ANSI_SOURCE
-
- ###########################################################################
-
--CC = gcc
-+#CC = gcc
-
- OPTIM = -O2
--CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
--LDOPT = -s $(LIBDIR) $(LDFLAGS)
-+CCOPT = $(INCDIR) $(DEFINES) $(CFLAGS)
-+LDOPT = $(LIBDIR) $(LDFLAGS)
-
- LIBS = -lshhmsg -lshhopt -lm
- OBJS = $(PROG).o date.o
diff --git a/games/biorythm/files/patch-ab b/games/biorythm/files/patch-ab
deleted file mode 100644
index 0f482d686d19..000000000000
--- a/games/biorythm/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- biorythm.c.orig Sat Mar 2 21:31:53 2002
-+++ biorythm.c Wed May 8 21:52:41 2002
-@@ -148,8 +148,7 @@
- version(void)
- {
- printf(
-- "biorythm " VERSION ", by Sverre H. Huseby "
-- "(compiled " COMPILED_DATE " by " COMPILED_BY ")\n"
-+ "biorythm " VERSION ", by Sverre H. Huseby\n"
- );
- exit(0);
- }
diff --git a/games/biorythm/pkg-plist b/games/biorythm/pkg-plist
deleted file mode 100644
index 987dcb10af53..000000000000
--- a/games/biorythm/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/biorythm
-%%PORTDOCS%%share/doc/biorythm/CREDITS
-%%PORTDOCS%%share/doc/biorythm/ChangeLog
-%%PORTDOCS%%share/doc/biorythm/README
-%%PORTDOCS%%@dirrm share/doc/biorythm