aboutsummaryrefslogtreecommitdiff
path: root/games/black-box
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-11 15:57:28 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-11 15:57:28 +0000
commit50ce52e352bab056e7cb43c2095f8a8435113135 (patch)
treedc213890fc830caf6a24f3aafc92770eab15742c /games/black-box
parent52c0b1fb36b63ccee0a348b31d18a58ee25c4e4b (diff)
downloadports-50ce52e352bab056e7cb43c2095f8a8435113135.tar.gz
ports-50ce52e352bab056e7cb43c2095f8a8435113135.zip
Notes
Diffstat (limited to 'games/black-box')
-rw-r--r--games/black-box/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/games/black-box/Makefile b/games/black-box/Makefile
index a8528fe693da..73196ee1f76e 100644
--- a/games/black-box/Makefile
+++ b/games/black-box/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= black-box
@@ -6,34 +6,32 @@ PORTVERSION= 1.4.8
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.linux-games.com/black-box/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Shoot in and watch where the shot leaves the box
LICENSE= GPLv2
-GNU_CONFIGURE= yes
USE_SDL= sdl image mixer
+GNU_CONFIGURE= yes
-PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
+PORTDOCS= AUTHORS ChangeLog NEWS README
-DESKTOP_ENTRIES="Black-Box" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="Black-Box" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
post-install:
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>