aboutsummaryrefslogtreecommitdiff
path: root/games/blackshadeselite
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-13 18:10:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-13 18:10:23 +0000
commit409a4f1e73627a6dbae76b5e0004dc5df0513797 (patch)
treea4192880f0ba278362ffac223fa0c14183267db4 /games/blackshadeselite
parent250767ac7746c6eceb9de06c1bf9d9cfee076ac3 (diff)
downloadports-409a4f1e73627a6dbae76b5e0004dc5df0513797.tar.gz
ports-409a4f1e73627a6dbae76b5e0004dc5df0513797.zip
Notes
Diffstat (limited to 'games/blackshadeselite')
-rw-r--r--games/blackshadeselite/Makefile50
-rw-r--r--games/blackshadeselite/distinfo3
-rw-r--r--games/blackshadeselite/files/patch-Makefile23
-rw-r--r--games/blackshadeselite/files/patch-Source-Config.cpp15
-rw-r--r--games/blackshadeselite/pkg-descr18
-rw-r--r--games/blackshadeselite/pkg-message7
-rw-r--r--games/blackshadeselite/pkg-plist198
7 files changed, 314 insertions, 0 deletions
diff --git a/games/blackshadeselite/Makefile b/games/blackshadeselite/Makefile
new file mode 100644
index 000000000000..a9d9077d9850
--- /dev/null
+++ b/games/blackshadeselite/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: blackshadeselite
+# Date created: 27 Jan 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blackshadeselite
+PORTVERSION= 0.0.1
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/blackshadeselite/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Psychic Bodyguard FPS - protect the VIP
+
+LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
+ openal.0:${PORTSDIR}/audio/openal \
+ alut.1:${PORTSDIR}/audio/freealut
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GL= yes
+
+MAKE_ARGS= CC=${CC} CXX=${CXX}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= Readme Readme.elite
+
+post-patch:
+ @${REINPLACE_CMD} -e '/InitGL/ s|.*|chdir("${DATADIR}"); &|' ${WRKSRC}/Source/Main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/objs/blackshades ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} Data ${DATADIR}/
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/blackshadeselite/distinfo b/games/blackshadeselite/distinfo
new file mode 100644
index 000000000000..8691dd714de7
--- /dev/null
+++ b/games/blackshadeselite/distinfo
@@ -0,0 +1,3 @@
+MD5 (blackshadeselite-0.0.1.tar.bz2) = 51e9873b43b669ee7c83beaa66085c14
+SHA256 (blackshadeselite-0.0.1.tar.bz2) = 212bdece1643188218a8bdd7726dea27e754dde0c64600d792de3adaa4f6cb58
+SIZE (blackshadeselite-0.0.1.tar.bz2) = 1171049
diff --git a/games/blackshadeselite/files/patch-Makefile b/games/blackshadeselite/files/patch-Makefile
new file mode 100644
index 000000000000..0d66b1c79d4a
--- /dev/null
+++ b/games/blackshadeselite/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2007-11-22 01:14:27.000000000 +0300
++++ Makefile 2008-01-27 23:53:31.000000000 +0300
+@@ -1,6 +1,4 @@
+-CC := gcc
+-CXX := g++
+-LINKER := g++
++LINKER := $(CXX)
+ ASM := nasm
+ SRCDIR := ./Source
+ NET_SRCDIR := ./Source/Net
+@@ -8,9 +6,9 @@
+ NET_BINDIR := ./objs/Net
+ EXE := $(BINDIR)/blackshades #$(BINDIR)/bse_viewer
+
+-CFLAGS := -O2 -fstrict-aliasing -Wall -g $(shell sdl-config --cflags) -I$(SRCDIR) -I$(NET_SRCDIR) -include Source/Support.h
+-CXXFLAGS := $(CFLAGS)
+-LDFLAGS := $(shell sdl-config --libs) -lGL -lGLU -lopenal -lalut # -framework QuickTime
++CFLAGS += -Wall `${SDL_CONFIG} --cflags` -I$(SRCDIR) -I$(NET_SRCDIR) -include Source/Support.h
++CXXFLAGS += -Wall `${SDL_CONFIG} --cflags` -I$(SRCDIR) -I$(NET_SRCDIR) -include Source/Support.h
++LDFLAGS := `${SDL_CONFIG} --libs` -lGL -lGLU -lopenal -lalut # -framework QuickTime
+
+ # Don't want ogg?
+ #CFLAGS += -DNOOGG
diff --git a/games/blackshadeselite/files/patch-Source-Config.cpp b/games/blackshadeselite/files/patch-Source-Config.cpp
new file mode 100644
index 000000000000..9c63df3d2286
--- /dev/null
+++ b/games/blackshadeselite/files/patch-Source-Config.cpp
@@ -0,0 +1,15 @@
+--- Source/Config.cpp.orig 2007-11-22 01:14:16.000000000 +0300
++++ Source/Config.cpp 2008-01-28 00:13:47.000000000 +0300
+@@ -44,8 +44,10 @@
+ customlevels = 0;
+ musictoggle = 1;
+ azertykeyboard = 0;
+-
+- const char *cfgFile = "config.txt";
++
++ char cfgFile[PATH_MAX];
++ strcpy(cfgFile, getenv("HOME"));
++ strcat(cfgFile, "/.blackshades.config");
+
+ if(!ConfigExist(cfgFile)) {
+ WriteConfig(cfgFile);
diff --git a/games/blackshadeselite/pkg-descr b/games/blackshadeselite/pkg-descr
new file mode 100644
index 000000000000..0aa8ba040f2a
--- /dev/null
+++ b/games/blackshadeselite/pkg-descr
@@ -0,0 +1,18 @@
+Black Shades Elite is an action game that is more or less similar
+to the original Black Shades "Psychic Bodyguard FPS". Kill anyone
+that tries to kill the VIP (the white guy). The psychic part is
+seeing blue lines when bad guys line up on the VIP (when the line
+is red they are about to shoot). Other powers (slow down, and
+visions) are available - press F1 for how to use.
+
+It has a few more user friendly options (in the ~/blackshades.config
+file) as well as a help menu. Aside from that the internals have
+had some major changes, but there is still a lot more to do. Other
+options include 3rd person (which was in the original game, just
+disabled). The other change that I enjoy is the lack of a busy loop
+- now cpu usage isn't 100% - on any recent system it should be less
+than 25%.
+
+Feature and bug reports are encouraged. I'm sure it's buggy. Enjoy.
+
+WWW: http://home.gna.org/blackshadeselite/
diff --git a/games/blackshadeselite/pkg-message b/games/blackshadeselite/pkg-message
new file mode 100644
index 000000000000..d500db6cdfc2
--- /dev/null
+++ b/games/blackshadeselite/pkg-message
@@ -0,0 +1,7 @@
+Black Shades Elite has been installed. To start the game, type
+`blackshades'.
+
+Also, you may find those key combinations useful:
+
+Alt+Enter: toggle fullscreen
+Ctrl+G: toggle mouse grab
diff --git a/games/blackshadeselite/pkg-plist b/games/blackshadeselite/pkg-plist
new file mode 100644
index 000000000000..c5d4f7a1b733
--- /dev/null
+++ b/games/blackshadeselite/pkg-plist
@@ -0,0 +1,198 @@
+bin/blackshades
+%%DATADIR%%/Data/Animations/Aikidothrow
+%%DATADIR%%/Data/Animations/Aikidothrown
+%%DATADIR%%/Data/Animations/Assaultrifleaim
+%%DATADIR%%/Data/Animations/Breathe
+%%DATADIR%%/Data/Animations/Chestshot
+%%DATADIR%%/Data/Animations/Crouch
+%%DATADIR%%/Data/Animations/Dive
+%%DATADIR%%/Data/Animations/Getupfromback
+%%DATADIR%%/Data/Animations/Getupfromfront
+%%DATADIR%%/Data/Animations/Grenadeaim
+%%DATADIR%%/Data/Animations/Grenadethrow
+%%DATADIR%%/Data/Animations/Headshot
+%%DATADIR%%/Data/Animations/Leftarmshot
+%%DATADIR%%/Data/Animations/Leftlegshot
+%%DATADIR%%/Data/Animations/PistolAim
+%%DATADIR%%/Data/Animations/Rifleaim
+%%DATADIR%%/Data/Animations/Rifleaim(old)
+%%DATADIR%%/Data/Animations/Riflehit
+%%DATADIR%%/Data/Animations/Riflehold
+%%DATADIR%%/Data/Animations/Rightarmshot
+%%DATADIR%%/Data/Animations/Rightlegshot
+%%DATADIR%%/Data/Animations/Run
+%%DATADIR%%/Data/Animations/Stomachshot
+%%DATADIR%%/Data/Animations/Walk
+%%DATADIR%%/Data/Animations/ZombieRun
+%%DATADIR%%/Data/Animations/Zombiemunch
+%%DATADIR%%/Data/Animations/Zombiewalk
+%%DATADIR%%/Data/Animations/grenadecharge
+%%DATADIR%%/Data/Highscore
+%%DATADIR%%/Data/Models/Abdomen.solid
+%%DATADIR%%/Data/Models/AssaultRifle.solid
+%%DATADIR%%/Data/Models/Block1.solid
+%%DATADIR%%/Data/Models/Block1collide.solid
+%%DATADIR%%/Data/Models/Block1complete.solid
+%%DATADIR%%/Data/Models/Block2.solid
+%%DATADIR%%/Data/Models/Block2collide.solid
+%%DATADIR%%/Data/Models/Block2complete.solid
+%%DATADIR%%/Data/Models/Block3.solid
+%%DATADIR%%/Data/Models/Block3collide.solid
+%%DATADIR%%/Data/Models/Block3complete.solid
+%%DATADIR%%/Data/Models/Block4.solid
+%%DATADIR%%/Data/Models/Block4collide.solid
+%%DATADIR%%/Data/Models/Block4complete.solid
+%%DATADIR%%/Data/Models/BlockOcclude.solid
+%%DATADIR%%/Data/Models/Blocksimple.solid
+%%DATADIR%%/Data/Models/Chest.solid
+%%DATADIR%%/Data/Models/Foot.solid
+%%DATADIR%%/Data/Models/Glockbase.solid
+%%DATADIR%%/Data/Models/Glockslide.solid
+%%DATADIR%%/Data/Models/Grenadebase.solid
+%%DATADIR%%/Data/Models/Grenadepin.solid
+%%DATADIR%%/Data/Models/Grenadespoon.solid
+%%DATADIR%%/Data/Models/Hand.solid
+%%DATADIR%%/Data/Models/Handgunbase.solid
+%%DATADIR%%/Data/Models/Handgunslide.solid
+%%DATADIR%%/Data/Models/Head.solid
+%%DATADIR%%/Data/Models/Highblock1collide.solid
+%%DATADIR%%/Data/Models/Highblock2collide.solid
+%%DATADIR%%/Data/Models/Highblock3collide.solid
+%%DATADIR%%/Data/Models/Highblock4collide.solid
+%%DATADIR%%/Data/Models/Knife.solid
+%%DATADIR%%/Data/Models/Lower arm.solid
+%%DATADIR%%/Data/Models/Lower leg.solid
+%%DATADIR%%/Data/Models/Lowheightcollide.solid
+%%DATADIR%%/Data/Models/Path.solid
+%%DATADIR%%/Data/Models/Shades.solid
+%%DATADIR%%/Data/Models/Shotgun.solid
+%%DATADIR%%/Data/Models/Upper arm.solid
+%%DATADIR%%/Data/Models/Upper leg.solid
+%%DATADIR%%/Data/Models/lowsimplecollide1.solid
+%%DATADIR%%/Data/Models/lowsimplecollide2.solid
+%%DATADIR%%/Data/Models/lowsimplecollide3.solid
+%%DATADIR%%/Data/Models/lowsimplecollide4.solid
+%%DATADIR%%/Data/Models/sniperrifle.solid
+%%DATADIR%%/Data/Models/streetsubdivided2.solid
+%%DATADIR%%/Data/Skeleton/Basic Figure
+%%DATADIR%%/Data/Sounds/BodyHit.ogg
+%%DATADIR%%/Data/Sounds/DisguiseKill.ogg
+%%DATADIR%%/Data/Sounds/Lose.ogg
+%%DATADIR%%/Data/Sounds/Nearbullet.ogg
+%%DATADIR%%/Data/Sounds/SW.ogg
+%%DATADIR%%/Data/Sounds/SoulIn.ogg
+%%DATADIR%%/Data/Sounds/SoulOut.ogg
+%%DATADIR%%/Data/Sounds/WallHit.ogg
+%%DATADIR%%/Data/Sounds/bodyland.ogg
+%%DATADIR%%/Data/Sounds/bounce.ogg
+%%DATADIR%%/Data/Sounds/bounce2.ogg
+%%DATADIR%%/Data/Sounds/click.ogg
+%%DATADIR%%/Data/Sounds/explosion.ogg
+%%DATADIR%%/Data/Sounds/footstep1.ogg
+%%DATADIR%%/Data/Sounds/footstep2.ogg
+%%DATADIR%%/Data/Sounds/footstep3.ogg
+%%DATADIR%%/Data/Sounds/footstep4.ogg
+%%DATADIR%%/Data/Sounds/footstep5.ogg
+%%DATADIR%%/Data/Sounds/glock.ogg
+%%DATADIR%%/Data/Sounds/handlerelease.ogg
+%%DATADIR%%/Data/Sounds/headland.ogg
+%%DATADIR%%/Data/Sounds/headshot.ogg
+%%DATADIR%%/Data/Sounds/knifeslash.ogg
+%%DATADIR%%/Data/Sounds/knifesong.ogg
+%%DATADIR%%/Data/Sounds/machinegun.ogg
+%%DATADIR%%/Data/Sounds/mainmenusong.ogg
+%%DATADIR%%/Data/Sounds/pinpull.ogg
+%%DATADIR%%/Data/Sounds/pinreplace.ogg
+%%DATADIR%%/Data/Sounds/rain.ogg
+%%DATADIR%%/Data/Sounds/reload.ogg
+%%DATADIR%%/Data/Sounds/riflewhack.ogg
+%%DATADIR%%/Data/Sounds/shootsong.ogg
+%%DATADIR%%/Data/Sounds/shotgun.ogg
+%%DATADIR%%/Data/Sounds/sniperrifle.ogg
+%%DATADIR%%/Data/Sounds/underwater.ogg
+%%DATADIR%%/Data/Sounds/zombiesong.ogg
+%%DATADIR%%/Data/Textures/._Blood
+%%DATADIR%%/Data/Textures/._Blood.tga
+%%DATADIR%%/Data/Textures/._Blood.tga copy
+%%DATADIR%%/Data/Textures/._BulletHole.tga
+%%DATADIR%%/Data/Textures/._Crater.tga
+%%DATADIR%%/Data/Textures/._Deadpersonsprite.tga
+%%DATADIR%%/Data/Textures/._Flare.tga
+%%DATADIR%%/Data/Textures/._Font.tga
+%%DATADIR%%/Data/Textures/._HitFlash.tga
+%%DATADIR%%/Data/Textures/._MuzzleFlash.tga
+%%DATADIR%%/Data/Textures/._Personsprite.tga
+%%DATADIR%%/Data/Textures/._Scope.tga
+%%DATADIR%%/Data/Textures/._Smoke.tga
+%%DATADIR%%/Data/Textures/._rain.tga
+%%DATADIR%%/Data/Textures/._snow.tga
+%%DATADIR%%/Data/Textures/Blood.png
+%%DATADIR%%/Data/Textures/Blood.png copy
+%%DATADIR%%/Data/Textures/Blood.tga
+%%DATADIR%%/Data/Textures/Blood.tga copy
+%%DATADIR%%/Data/Textures/Blood/._Blood1.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood10.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood11.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood2.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood3.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood4.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood5.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood6.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood7.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood8.tga
+%%DATADIR%%/Data/Textures/Blood/._Blood9.tga
+%%DATADIR%%/Data/Textures/Blood/Blood1.png
+%%DATADIR%%/Data/Textures/Blood/Blood1.tga
+%%DATADIR%%/Data/Textures/Blood/Blood10.png
+%%DATADIR%%/Data/Textures/Blood/Blood10.tga
+%%DATADIR%%/Data/Textures/Blood/Blood11.png
+%%DATADIR%%/Data/Textures/Blood/Blood11.tga
+%%DATADIR%%/Data/Textures/Blood/Blood2.png
+%%DATADIR%%/Data/Textures/Blood/Blood2.tga
+%%DATADIR%%/Data/Textures/Blood/Blood3.png
+%%DATADIR%%/Data/Textures/Blood/Blood3.tga
+%%DATADIR%%/Data/Textures/Blood/Blood4.png
+%%DATADIR%%/Data/Textures/Blood/Blood4.tga
+%%DATADIR%%/Data/Textures/Blood/Blood5.png
+%%DATADIR%%/Data/Textures/Blood/Blood5.tga
+%%DATADIR%%/Data/Textures/Blood/Blood6.png
+%%DATADIR%%/Data/Textures/Blood/Blood6.tga
+%%DATADIR%%/Data/Textures/Blood/Blood7.png
+%%DATADIR%%/Data/Textures/Blood/Blood7.tga
+%%DATADIR%%/Data/Textures/Blood/Blood8.png
+%%DATADIR%%/Data/Textures/Blood/Blood8.tga
+%%DATADIR%%/Data/Textures/Blood/Blood9.png
+%%DATADIR%%/Data/Textures/Blood/Blood9.tga
+%%DATADIR%%/Data/Textures/BulletHole.png
+%%DATADIR%%/Data/Textures/BulletHole.tga
+%%DATADIR%%/Data/Textures/Crater.png
+%%DATADIR%%/Data/Textures/Crater.tga
+%%DATADIR%%/Data/Textures/Deadpersonsprite.png
+%%DATADIR%%/Data/Textures/Deadpersonsprite.tga
+%%DATADIR%%/Data/Textures/Flare.png
+%%DATADIR%%/Data/Textures/Flare.tga
+%%DATADIR%%/Data/Textures/Font.png
+%%DATADIR%%/Data/Textures/Font.tga
+%%DATADIR%%/Data/Textures/HitFlash.png
+%%DATADIR%%/Data/Textures/HitFlash.tga
+%%DATADIR%%/Data/Textures/MuzzleFlash.png
+%%DATADIR%%/Data/Textures/MuzzleFlash.tga
+%%DATADIR%%/Data/Textures/Personsprite.png
+%%DATADIR%%/Data/Textures/Personsprite.tga
+%%DATADIR%%/Data/Textures/Scope.png
+%%DATADIR%%/Data/Textures/Scope.tga
+%%DATADIR%%/Data/Textures/Smoke.png
+%%DATADIR%%/Data/Textures/Smoke.tga
+%%DATADIR%%/Data/Textures/rain.png
+%%DATADIR%%/Data/Textures/rain.tga
+%%DATADIR%%/Data/Textures/snow.png
+%%DATADIR%%/Data/Textures/snow.tga
+%%DATADIR%%/Data/customlevels.txt
+@dirrm %%DATADIR%%/Data/Textures/Blood
+@dirrm %%DATADIR%%/Data/Textures
+@dirrm %%DATADIR%%/Data/Sounds
+@dirrm %%DATADIR%%/Data/Skeleton
+@dirrm %%DATADIR%%/Data/Models
+@dirrm %%DATADIR%%/Data/Animations
+@dirrm %%DATADIR%%/Data
+@dirrm %%DATADIR%%