aboutsummaryrefslogtreecommitdiff
path: root/games/blinkensisters/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-11 16:21:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-11 16:21:04 +0000
commit972dfb0b2eeb72e4423b3f057812956d4b275ff2 (patch)
tree1d3002e88bfb997d8917e1529e7d60ca65a7d467 /games/blinkensisters/Makefile
parent2ce54071b71834f72c63fd5777a51e36f6d0c8e5 (diff)
Notes
Diffstat (limited to 'games/blinkensisters/Makefile')
-rw-r--r--games/blinkensisters/Makefile56
1 files changed, 23 insertions, 33 deletions
diff --git a/games/blinkensisters/Makefile b/games/blinkensisters/Makefile
index f066f1a56eeb..4a2ceab73a88 100644
--- a/games/blinkensisters/Makefile
+++ b/games/blinkensisters/Makefile
@@ -12,7 +12,7 @@ COMMENT= Parallax-style 2D scrolling platform game
USE_SDL= sdl image ttf
USE_PERL5= build
-USES= cmake perl5
+USES= cmake perl5 compiler:c++11-lang # actually, old gcc fails in theora.h
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -20,16 +20,33 @@ CXXFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/blinkensisters/lostpixels/game/software
ADDONS_WRKSRC= ${WRKDIR}/blinkensisters/lostpixels/game/addons
+PLIST_FILES= bin/LostPixels \
+ bin/bmfcompress \
+ bin/bmfdecompress
PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= ADDONS SDL_MIXER SDL_NET THEORA DOCS
+OPTIONS_DEFAULT=ADDONS SDL_MIXER SDL_NET THEORA
-OPTIONS_DEFINE= ADDONS SDL_MIXER SDL_NET THEORA
ADDONS_DESC= Install addons (~200 MB download size)
SDL_MIXER_DESC= Build with sound support
SDL_NET_DESC= Build with network support
-OPTIONS_DEFAULT= SDL_MIXER SDL_NET
+SDL_MIXER_USE= SDL=mixer
+SDL_MIXER_CMAKE_OFF= -DUSE_SDL_MIXER:BOOL=OFF
+SDL_MIXER_PLIST_FILES= bin/BlinkenPlayer
+
+SDL_NET_USE= SDL=net
+SDL_NET_CMAKE_OFF= -DUSE_SDL_NET:BOOL=OFF
+SDL_NET_PLIST_FILES= bin/blpmatrix \
+ bin/blpviewer \
+ bin/bxxviewer \
+ bin/mcufviewer
+
+THEORA_CMAKE_ON= -DUSE_THEORA:BOOL=ON
+THEORA_LIB_DEPENDS= libtheora.so:${PORTSDIR}/multimedia/libtheora
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -39,38 +56,11 @@ BROKEN= Does not compile on sparc64
.if ${PORT_OPTIONS:MADDONS}
DISTNAME= LostPixels-${PORTVERSION}-source-with-addons
PKGNAMESUFFIX= -with-addons
-PLIST_SUB+= ADDONS=""
.else
DISTNAME= LostPixels-${PORTVERSION}-source
-PLIST_SUB+= ADDONS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSDL_MIXER}
-USE_SDL+= mixer
-PLIST_SUB+= SDL_MIXER=""
-.else
-CMAKE_ARGS+= -DUSE_SDL_MIXER:BOOL=OFF
-PLIST_SUB+= SDL_MIXER="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSDL_NET}
-USE_SDL+= net
-PLIST_SUB+= SDL_NET=""
-.else
-CMAKE_ARGS+= -DUSE_SDL_NET:BOOL=OFF
-PLIST_SUB+= SDL_NET="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTHEORA}
-CMAKE_ARGS+= -DUSE_THEORA:BOOL=ON
-.else
-LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
.endif
post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^INSTALL.*doc/ d' ${WRKSRC}/CMakeLists.txt
-.endif
@${REINPLACE_CMD} -e 's|share/blinkensisters|${DATADIR:S,${PREFIX}/,,}|; \
s|share/doc/blinkensisters|${DOCSDIR:S,${PREFIX}/,,}|' \
${WRKSRC}/CMakeLists.txt
@@ -84,8 +74,8 @@ post-build:
cd ${ADDONS_WRKSRC} && ${MAKE}
post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${ADDONS_WRKSRC}/for_upload/*.bmf ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${ADDONS_WRKSRC}/for_upload/*.bmf ${STAGEDIR}${DATADIR}/
.endif
.include <bsd.port.mk>