aboutsummaryrefslogtreecommitdiff
path: root/games/blobby
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2017-02-11 21:32:32 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2017-02-11 21:32:32 +0000
commit5d48416e675ff7ac6f35d5ffd08728a3e1f6c2b1 (patch)
tree00f7c231a26af616104b583299be5f02de86ba59 /games/blobby
parented3aa7042b13a3c2bfac4ec79faec86d590999ad (diff)
downloadports-5d48416e675ff7ac6f35d5ffd08728a3e1f6c2b1.tar.gz
ports-5d48416e675ff7ac6f35d5ffd08728a3e1f6c2b1.zip
Notes
Diffstat (limited to 'games/blobby')
-rw-r--r--games/blobby/Makefile42
-rw-r--r--games/blobby/distinfo5
-rw-r--r--games/blobby/files/patch-src-InputManager.cpp8
-rw-r--r--games/blobby/files/patch-src-RenderManager.cpp8
-rw-r--r--games/blobby/files/patch-src-raknet-RakPeer.cpp10
-rw-r--r--games/blobby/files/patch-src_NetworkMessage.cpp10
-rw-r--r--games/blobby/pkg-plist3
7 files changed, 41 insertions, 45 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 87a41a6ebd65..5a1fc588f779 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -2,37 +2,47 @@
# $FreeBSD$
PORTNAME= blobby
-PORTVERSION= 1.0r3
-PORTREVISION= 6
+PORTVERSION= 1.0
+PORTEPOCH= 1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/1.0RC3/
-DISTNAME= blobby2-linux-1.0rc3
+MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/${PORTVERSION}
+DISTNAME= blobby2-linux-${PORTVERSION}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Official continuation of the famous Blobby Volley 1.x game
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libphysfs.so:devel/physfs \
- libdrm.so:graphics/libdrm
+LIB_DEPENDS= libphysfs.so:devel/physfs
BUILD_DEPENDS= zip:archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-USE_XORG= ice x11 xext xxf86vm xdamage xfixes xau xdmcp xrandr xrender
-USE_SDL= sdl
-USE_GL= glu
+BROKEN_aarch64= fails to compile: I can't tell what endian-ness to use for your architecture
-USES= dos2unix cmake
+USES= cmake dos2unix localbase:ldflags pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
-CMAKE_ARGS+= -DDATADIR:PATH="${DATADIR}"
-WRKSRC= ${WRKDIR}/blobby-1.0rc3
+CMAKE_ARGS= -DDATADIR:PATH="${DATADIR}"
+WRKSRC= ${WRKDIR}/blobby-${PORTVERSION}
+USE_SDL= sdl2
+USE_GL= gl
-PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+PORTDOCS= AUTHORS ChangeLog README TODO
-BROKEN_aarch64= Fails to compile: I can't tell what endian-ness to use for your architecture
+DESKTOP_ENTRIES="Blobby Volley" \
+ "" \
+ "${DATADIR}/Icon.bmp" \
+ "${PORTNAME}" \
+ "Game;ArcadeGame;" \
+ ""
+
+OPTIONS_DEFINE= DOCS
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/Icon.bmp ${STAGEDIR}${DATADIR}/
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/blobby/distinfo b/games/blobby/distinfo
index f245db6c2da8..397cecb597fd 100644
--- a/games/blobby/distinfo
+++ b/games/blobby/distinfo
@@ -1,2 +1,3 @@
-SHA256 (blobby2-linux-1.0rc3.tar.gz) = 45bdb2530b7eb1b508693d304e31088c9a9b366f978f716b5a0cf1e7c502c581
-SIZE (blobby2-linux-1.0rc3.tar.gz) = 2323776
+TIMESTAMP = 1479124820
+SHA256 (blobby2-linux-1.0.tar.gz) = ba7a049e298aaa2014c1e1ac1faf3b0256b4c66266cd4db06e7939e8695bf5e2
+SIZE (blobby2-linux-1.0.tar.gz) = 1772918
diff --git a/games/blobby/files/patch-src-InputManager.cpp b/games/blobby/files/patch-src-InputManager.cpp
deleted file mode 100644
index 3536ab13e962..000000000000
--- a/games/blobby/files/patch-src-InputManager.cpp
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/InputManager.cpp.orig 2012-08-07 18:12:49.000000000 +0200
-+++ src/InputManager.cpp 2012-08-07 18:17:04.000000000 +0200
-@@ -1,4 +1,4 @@
--/*=============================================================================
-+/*=============================================================================
- Blobby Volley 2
- Copyright (C) 2006 Jonathan Sieber (jonathan_sieber@yahoo.de)
-
diff --git a/games/blobby/files/patch-src-RenderManager.cpp b/games/blobby/files/patch-src-RenderManager.cpp
deleted file mode 100644
index a8a8f0798b65..000000000000
--- a/games/blobby/files/patch-src-RenderManager.cpp
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/RenderManager.cpp.orig 2012-08-07 18:22:07.000000000 +0200
-+++ src/RenderManager.cpp 2012-08-07 18:22:19.000000000 +0200
-@@ -1,4 +1,4 @@
--/*=============================================================================
-+/*=============================================================================
- Blobby Volley 2
- Copyright (C) 2006 Jonathan Sieber (jonathan_sieber@yahoo.de)
- Copyright (C) 2006 Daniel Knobe (daniel-knobe@web.de)
diff --git a/games/blobby/files/patch-src-raknet-RakPeer.cpp b/games/blobby/files/patch-src-raknet-RakPeer.cpp
deleted file mode 100644
index c51acb4009e1..000000000000
--- a/games/blobby/files/patch-src-raknet-RakPeer.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/raknet/RakPeer.cpp.orig 2013-03-28 17:46:00.000000000 +0100
-+++ src/raknet/RakPeer.cpp 2013-03-28 17:55:11.000000000 +0100
-@@ -1060,7 +1060,6 @@
-
- for ( ; index < banList.size(); index++ )
- {
-- delete [] banList[ index ]->IP;
- delete [] banList[ index ];
- }
-
diff --git a/games/blobby/files/patch-src_NetworkMessage.cpp b/games/blobby/files/patch-src_NetworkMessage.cpp
new file mode 100644
index 000000000000..0fe62c5b1cb1
--- /dev/null
+++ b/games/blobby/files/patch-src_NetworkMessage.cpp
@@ -0,0 +1,10 @@
+--- src/NetworkMessage.cpp.orig 2014-03-22 13:31:21 UTC
++++ src/NetworkMessage.cpp
+@@ -23,6 +23,7 @@ Foundation, Inc., 59 Temple Place, Suite
+
+ /* includes */
+ #include <cstring>
++#include <iostream>
+
+ #include "UserConfig.h"
+ #include "SpeedController.h"
diff --git a/games/blobby/pkg-plist b/games/blobby/pkg-plist
index b5f14a653f32..6f4e96892cb6 100644
--- a/games/blobby/pkg-plist
+++ b/games/blobby/pkg-plist
@@ -1,5 +1,6 @@
bin/blobby
bin/blobby-server
+%%DATADIR%%/Icon.bmp
%%DATADIR%%/backgrounds.zip
%%DATADIR%%/config.xml
%%DATADIR%%/gfx.zip
@@ -7,7 +8,7 @@ bin/blobby-server
%%DATADIR%%/lang_de.xml
%%DATADIR%%/lang_en.xml
%%DATADIR%%/lang_fr.xml
-%%DATADIR%%/rules.lua
+%%DATADIR%%/rules.zip
%%DATADIR%%/scripts.zip
%%DATADIR%%/server.xml
%%DATADIR%%/sounds.zip