aboutsummaryrefslogtreecommitdiff
path: root/games/blobby
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-11-15 07:27:43 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-11-15 07:27:43 +0000
commit61ac16aa5685e9dd13253475da550aff77cb6c82 (patch)
treef34af569599dd06a5957c84f246a1a25d9f6be5f /games/blobby
parente170141288853bbeedcde1e77737c2e11a9029d1 (diff)
downloadports-61ac16aa5685e9dd13253475da550aff77cb6c82.tar.gz
ports-61ac16aa5685e9dd13253475da550aff77cb6c82.zip
Notes
Diffstat (limited to 'games/blobby')
-rw-r--r--games/blobby/Makefile14
-rw-r--r--games/blobby/distinfo4
-rw-r--r--games/blobby/files/patch-src-RenderManagerGL2D.cpp12
-rw-r--r--games/blobby/files/patch-src-raknet-BinarySearchTree.h66
-rw-r--r--games/blobby/pkg-plist1
5 files changed, 89 insertions, 8 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 495bbf344b23..202e7a8896c0 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -6,28 +6,30 @@
#
PORTNAME= blobby
-PORTVERSION= 0.9b
-PORTREVISION= 1
+PORTVERSION= 0.9c
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/Beta%200.9b
+MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/Beta%20${PORTVERSION}
DISTNAME= blobby2-linux-${PORTVERSION}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Official continuation of the famous Blobby Volley 1.x game
+LICENSE= GPLv2
+
LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
drm:${PORTSDIR}/graphics/libdrm
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:${PORTSDIR}/devel/boost-libs
-LICENSE= GPLv2
-
USE_XORG= ice x11 xext xxf86vm xdamage xfixes xau xdmcp xrandr xrender
USE_SDL= sdl
USE_GL= glu
USE_CMAKE= yes
CMAKE_ARGS+= -DDATADIR:PATH="${DATADIR}"
-WRKSRC= ${WRKDIR}/blobby-beta-0.9b
+WRKSRC= ${WRKDIR}/blobby-beta-${PORTVERSION}
+
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*\.(c|h|cpp)
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
diff --git a/games/blobby/distinfo b/games/blobby/distinfo
index 81f492003072..726b8c7d1047 100644
--- a/games/blobby/distinfo
+++ b/games/blobby/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blobby2-linux-0.9b.tar.gz) = f50bec0fea054d0f8823a4f9d0ed6c2cdb8c4c49e999d906dd128df96ae54f76
-SIZE (blobby2-linux-0.9b.tar.gz) = 2105070
+SHA256 (blobby2-linux-0.9c.tar.gz) = e3ed8f92c70e16d24f109b6f0f4dccc25656a88780eb1a348d1223edcb7fc937
+SIZE (blobby2-linux-0.9c.tar.gz) = 2290384
diff --git a/games/blobby/files/patch-src-RenderManagerGL2D.cpp b/games/blobby/files/patch-src-RenderManagerGL2D.cpp
new file mode 100644
index 000000000000..a75986589660
--- /dev/null
+++ b/games/blobby/files/patch-src-RenderManagerGL2D.cpp
@@ -0,0 +1,12 @@
+--- src/RenderManagerGL2D.cpp.orig 2011-11-10 17:25:30.977965807 +0100
++++ src/RenderManagerGL2D.cpp 2011-11-10 17:25:31.029970322 +0100
+@@ -284,7 +284,8 @@
+ SDL_Rect r = {x, 0, fontSurface->w, fontSurface->h};
+ SDL_BlitSurface(fontSurface, 0, textbase, &r);
+ SDL_BlitSurface(highlight, 0, hltextbase, &r);
+- r = {sx, 0, fontSurface2->w, fontSurface2->h};
++ r.x = sx; r.y = 0;
++ r.w = fontSurface2->w; r.h = fontSurface2->h;
+ SDL_BlitSurface(fontSurface2, 0, smalltextbase, &r);
+ SDL_BlitSurface(highlight2, 0, hlsmalltextbase, &r);
+ //GLuint ballImage = loadTexture(sf, false);
diff --git a/games/blobby/files/patch-src-raknet-BinarySearchTree.h b/games/blobby/files/patch-src-raknet-BinarySearchTree.h
new file mode 100644
index 000000000000..13cbb9fdb6cd
--- /dev/null
+++ b/games/blobby/files/patch-src-raknet-BinarySearchTree.h
@@ -0,0 +1,66 @@
+--- src/raknet/BinarySearchTree.h.orig 2011-11-10 19:09:02.760002087 +0100
++++ src/raknet/BinarySearchTree.h 2011-11-10 19:16:43.285213671 +0100
+@@ -338,12 +338,12 @@
+ if ( current->left == 0 )
+ left_height = 0;
+ else
+- left_height = height( current->left );
++ left_height = this->height( current->left );
+
+ if ( current->right == 0 )
+ right_height = 0;
+ else
+- right_height = height( current->right );
++ right_height = this->height( current->right );
+
+ if ( right_height - left_height == 2 )
+ {
+@@ -371,7 +371,7 @@
+ if ( current == this->root )
+ break;
+
+- current = find_parent( *( current->item ) );
++ current = this->find_parent( *( current->item ) );
+
+ }
+ }
+@@ -400,7 +400,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->right ) > height( A->left );
++ return this->height( A->right ) > this->height( A->left );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -409,7 +409,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->left ) > height( A->right );
++ return this->height( A->left ) > this->height( A->right );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -446,8 +446,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->right;
+
+ if ( A )
+@@ -510,8 +510,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->left;
+
+ if ( A )
diff --git a/games/blobby/pkg-plist b/games/blobby/pkg-plist
index 7b1f26b8032c..66396d7af15b 100644
--- a/games/blobby/pkg-plist
+++ b/games/blobby/pkg-plist
@@ -7,6 +7,7 @@ bin/blobby-server
%%DATADIR%%/lang_de.xml
%%DATADIR%%/lang_en.xml
%%DATADIR%%/lang_fr.xml
+%%DATADIR%%/rules.lua
%%DATADIR%%/scripts.zip
%%DATADIR%%/server.xml
%%DATADIR%%/sounds.zip