aboutsummaryrefslogtreecommitdiff
path: root/games/blockout
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-16 14:19:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-16 14:19:25 +0000
commit9bbcf4d0ccbc9da248eee74457fc8b0cef6bed23 (patch)
tree9d6aeb93fc6947879d62169774b3776d6ea29a41 /games/blockout
parent598d1dedac4d1ddf922f9b925019cf95d036457a (diff)
downloadports-9bbcf4d0ccbc9da248eee74457fc8b0cef6bed23.tar.gz
ports-9bbcf4d0ccbc9da248eee74457fc8b0cef6bed23.zip
Notes
Diffstat (limited to 'games/blockout')
-rw-r--r--games/blockout/Makefile16
-rw-r--r--games/blockout/distinfo6
-rw-r--r--games/blockout/files/patch-BlockOut__Utils.cpp32
-rw-r--r--games/blockout/files/patch-BotPlayer.cpp11
-rw-r--r--games/blockout/files/patch-BotPlayerAI.cpp11
-rw-r--r--games/blockout/files/patch-GLFont.cpp10
-rw-r--r--games/blockout/files/patch-GLSprite.cpp10
-rw-r--r--games/blockout/files/patch-Http.cpp12
-rw-r--r--games/blockout/files/patch-Makefile57
-rw-r--r--games/blockout/files/patch-gif.cpp (renamed from games/blockout/files/patch-gif.c)6
-rw-r--r--games/blockout/pkg-plist4
11 files changed, 114 insertions, 61 deletions
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index dfdc0ce8499c..8197eea5cd8f 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -2,26 +2,26 @@
# $FreeBSD$
PORTNAME= blockout
-PORTVERSION= 2.4
-PORTREVISION= 4
+PORTVERSION= 2.5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/BlockOut%20${PORTVERSION}/ \
http://www.stasyan.com/devel/distfiles/
-DISTNAME= bl24-src-linux-i586
+DISTFILES= bl25-src${EXTRACT_SUFX} bl25-linux-x86${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= BlockOut II is an adaptation of the original Blockout DOS game
LICENSE= GPLv2 # or later
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_SDL= mixer sdl
USES= gmake dos2unix
-DOS2UNIX_FILES= ${WRKSRC}/ImageLib/src/gif/gif.c
+DOS2UNIX_FILES= ${WRKSRC}/ImageLib/src/gif/gif.h ${WRKSRC}/ImageLib/src/gif/gif.cpp
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
USE_GL= gl glu
-WRKSRC= ${WRKDIR}/bl24_lin_src
+WRKSRC= ${WRKDIR}/BL_SRC
BUILD_WRKSRC= ${WRKSRC}/BlockOut
post-patch:
@@ -32,6 +32,8 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BlockOut/blockout ${STAGEDIR}${PREFIX}/bin
- cd ${WRKSRC}/BlockOut && ${COPYTREE_SHARE} "images sounds" ${STAGEDIR}${DATADIR}
+ cd ${WRKDIR}/blockout && ${COPYTREE_SHARE} "images sounds" ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/blockout/distinfo b/games/blockout/distinfo
index f012136eea4d..ff198cc034f8 100644
--- a/games/blockout/distinfo
+++ b/games/blockout/distinfo
@@ -1,2 +1,4 @@
-SHA256 (bl24-src-linux-i586.tar.gz) = c95766b8d6fce9820e14a23cd1bdea28591c01d8fdf5ece06cca1071f082c088
-SIZE (bl24-src-linux-i586.tar.gz) = 5017393
+SHA256 (bl25-src.tar.gz) = 3abf61c4a7bd921988596a2239d76a5800fc94d8fd84dcc82c720d4d4f84cf0f
+SIZE (bl25-src.tar.gz) = 479743
+SHA256 (bl25-linux-x86.tar.gz) = 2bf9ab1798e7d3f82a372a3fae26a5c7699d1c57263253dce66f07fa418b702b
+SIZE (bl25-linux-x86.tar.gz) = 4379299
diff --git a/games/blockout/files/patch-BlockOut__Utils.cpp b/games/blockout/files/patch-BlockOut__Utils.cpp
index 698ccfc2a82c..833f9afc61a3 100644
--- a/games/blockout/files/patch-BlockOut__Utils.cpp
+++ b/games/blockout/files/patch-BlockOut__Utils.cpp
@@ -1,16 +1,16 @@
---- BlockOut/Utils.cpp.orig 2008-01-09 21:29:06.000000000 +0300
-+++ BlockOut/Utils.cpp 2014-12-02 07:58:58.452013513 +0300
-@@ -162,11 +162,9 @@
- return FALSE;
- }
-
-- char *blockoutHome = getenv("BL2_HOME");
-+ const char *blockoutHome = getenv("BL2_HOME");
- if( blockoutHome==NULL ) {
-- printf("BL2_HOME environement variable if not defined !\n");
-- printf("Please set the BL2_HOME to the BlockOut II installation directory (ex: BL2_HOME=/usr/local/bl2).\n");
-- return FALSE;
-+ blockoutHome="%%DATADIR%%";
- }
- strcpy( bl2Home , blockoutHome );
-
+--- BlockOut/Utils.cpp.orig 2014-05-06 16:47:55.000000000 +0700
++++ BlockOut/Utils.cpp 2015-08-17 10:34:51.000000000 +0600
+@@ -207,11 +207,9 @@
+ return FALSE;
+ }
+
+- char *blockoutHome = getenv("BL2_HOME");
++ const char *blockoutHome = getenv("BL2_HOME");
+ if( blockoutHome==NULL ) {
+- printf("BL2_HOME environement variable if not defined !\n");
+- printf("Please set the BL2_HOME to the BlockOut II installation directory (ex: BL2_HOME=/usr/local/bl2).\n");
+- return FALSE;
++ blockoutHome="%%DATADIR%%";
+ }
+ strcpy( bl2Home , blockoutHome );
+
diff --git a/games/blockout/files/patch-BotPlayer.cpp b/games/blockout/files/patch-BotPlayer.cpp
new file mode 100644
index 000000000000..49812b548085
--- /dev/null
+++ b/games/blockout/files/patch-BotPlayer.cpp
@@ -0,0 +1,11 @@
+--- BlockOut/BotPlayer.cpp.orig 2015-08-20 21:42:27.000000000 +0600
++++ BlockOut/BotPlayer.cpp 2015-08-20 21:42:41.000000000 +0600
+@@ -16,7 +16,7 @@
+ */
+
+ #include "BotPlayer.h"
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/games/blockout/files/patch-BotPlayerAI.cpp b/games/blockout/files/patch-BotPlayerAI.cpp
new file mode 100644
index 000000000000..a99bff55382d
--- /dev/null
+++ b/games/blockout/files/patch-BotPlayerAI.cpp
@@ -0,0 +1,11 @@
+--- BlockOut/BotPlayerAI.cpp.orig 2015-08-20 21:43:41.000000000 +0600
++++ BlockOut/BotPlayerAI.cpp 2015-08-20 21:43:51.000000000 +0600
+@@ -15,7 +15,7 @@
+ GNU General Public License for more details.
+ */
+ #include "BotPlayer.h"
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/games/blockout/files/patch-GLFont.cpp b/games/blockout/files/patch-GLFont.cpp
index 6810c1ea4184..c7aa25f1cc54 100644
--- a/games/blockout/files/patch-GLFont.cpp
+++ b/games/blockout/files/patch-GLFont.cpp
@@ -1,11 +1,11 @@
---- BlockOut/GLApp/GLFont.cpp.orig 2009-08-06 15:16:50.000000000 +0700
-+++ BlockOut/GLApp/GLFont.cpp 2009-08-06 15:16:58.000000000 +0700
-@@ -3,7 +3,7 @@
+--- BlockOut/GLApp/GLFont.cpp.orig 2014-05-06 16:47:55.000000000 +0700
++++ BlockOut/GLApp/GLFont.cpp 2015-08-17 10:31:54.000000000 +0600
+@@ -2,7 +2,7 @@
+ // Simple 2D font
// -----------------------------------------------
#include "GLFont.h"
- #include <CImage.h>
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include <string.h>
-
+ #undef LoadImage
diff --git a/games/blockout/files/patch-GLSprite.cpp b/games/blockout/files/patch-GLSprite.cpp
index 022fe7bffd46..2fa745b81432 100644
--- a/games/blockout/files/patch-GLSprite.cpp
+++ b/games/blockout/files/patch-GLSprite.cpp
@@ -1,11 +1,11 @@
---- BlockOut/GLApp/GLSprite.cpp.orig 2009-08-06 15:17:24.000000000 +0700
-+++ BlockOut/GLApp/GLSprite.cpp 2009-08-06 15:17:46.000000000 +0700
-@@ -3,7 +3,7 @@
+--- BlockOut/GLApp/GLSprite.cpp.orig 2014-05-06 16:47:55.000000000 +0700
++++ BlockOut/GLApp/GLSprite.cpp 2015-08-17 10:37:35.000000000 +0600
+@@ -2,7 +2,7 @@
+ // 2D sprites
// -----------------------------------------------
#include "GLSprite.h"
- #include <CImage.h>
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include <string.h>
-
+ #undef LoadImage
diff --git a/games/blockout/files/patch-Http.cpp b/games/blockout/files/patch-Http.cpp
index 6934c87eec66..a188e80a6fea 100644
--- a/games/blockout/files/patch-Http.cpp
+++ b/games/blockout/files/patch-Http.cpp
@@ -1,12 +1,14 @@
---- BlockOut/Http.cpp.orig 2009-08-06 15:04:34.000000000 +0700
-+++ BlockOut/Http.cpp 2009-08-06 15:14:02.000000000 +0700
-@@ -24,11 +24,16 @@
+--- BlockOut/Http.cpp.orig 2014-05-06 16:47:54.000000000 +0700
++++ BlockOut/Http.cpp 2015-08-17 10:39:47.000000000 +0600
+@@ -25,6 +25,7 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
+#include <netinet/in.h>
-
-
+ #define closesocket close
+ #else
+ #include <Winsock2.h>
+@@ -46,6 +47,10 @@
#define WAIT_FOR_READ 1
#define WAIT_FOR_WRITE 2
diff --git a/games/blockout/files/patch-Makefile b/games/blockout/files/patch-Makefile
index 27384e32e7a7..b9e21d555e0e 100644
--- a/games/blockout/files/patch-Makefile
+++ b/games/blockout/files/patch-Makefile
@@ -1,25 +1,50 @@
---- BlockOut/Makefile.orig 2008-01-10 00:29:06.000000000 +0600
-+++ BlockOut/Makefile 2014-02-09 13:17:22.000000000 +0700
-@@ -34,17 +34,17 @@
-
- #---------------------------------------------------------------------
+--- BlockOut/Makefile.orig 2014-05-06 16:47:56.000000000 +0700
++++ BlockOut/Makefile 2015-08-30 12:41:52.375668000 +0600
+@@ -41,33 +41,37 @@
+
+ ADD_LIBS = ../ImageLib/src/libimagelib.a
+
+-ifdef _linux64
+-SDL_LIBS = /usr/lib/x86_64-linux-gnu
+-else
+-SDL_LIBS = /usr/lib/i386-linux-gnu
+-endif
++#ifdef _linux64
++#SDL_LIBS = /usr/lib/x86_64-linux-gnu
++#else
++#SDL_LIBS = /usr/lib/i386-linux-gnu
++#endif
++SDL_LIBS = /usr/local/lib
++
++#CXX = g++
--SDL_ROOT = /users/pons/test/opengl/SDL
--IMGLIB_ROOT = ../ImageLib
+-CXX = g++
+SDL_ROOT = /usr/local
+IMGLIB_ROOT = ../ImageLib/src
--CXX = g++
-+#CXX = g++
+ ifdef _release
- CXXFLAGS = -g -D_DEBUG -Dlinux -c \
-- -I$(SDL_ROOT)/include/SDL -I$(IMGLIB_ROOT) -I.
-+ -I/usr/include -I$(SDL_ROOT)/include/SDL -I$(SDL_ROOT)/include -I$(IMGLIB_ROOT) -I.
+ CXXFLAGS = -O2 -Dlinux -c \
+- -I/usr/include/SDL -I../ImageLib/src -I.
++ -I/usr/include -I$(SDL_ROOT)/include/SDL -I$(SDL_ROOT)/include -I$(IMGLIB_ROOT) -I.
+
+ LFLAGS = -Wl,--strip-all \
+ $(ADD_LIBS) \
+ -lSDL_mixer -lSDL -lasound \
+- -lGL -lGLU -lpthread -lm -ldl
++ -lGL -lGLU -lpthread -lm
- LIBS = -L$(SDL_ROOT)/lib -L$(IMGLIB_ROOT)
+ else
+
+ CXXFLAGS = -g -D_DEBUG -Dlinux -c \
+- -I/usr/include/SDL -I../ImageLib/src -I.
++ -I/usr/include -I$(SDL_ROOT)/include/SDL -I$(SDL_ROOT)/include -I$(IMGLIB_ROOT) -I.
--LFLAGS = $(LIBS) -limagelib -lGL -lGLU -lSDL_mixer -lSDL -lpthread -lm -ldl
-+LFLAGS = $(LIBS) -limagelib -lGL -lGLU -lSDL_mixer -lSDL -lpthread -lm
+ LFLAGS = -L $(SDL_LIBS) \
+ $(ADD_LIBS) \
+ -lSDL_mixer -lSDL -lasound \
+- -lGL -lGLU -lpthread -lm -ldl
++ -lGL -lGLU -lpthread -lm
- #--------------------------------------------------------------------
+ endif
diff --git a/games/blockout/files/patch-gif.c b/games/blockout/files/patch-gif.cpp
index 896fd98f820d..df0029ab1fb5 100644
--- a/games/blockout/files/patch-gif.c
+++ b/games/blockout/files/patch-gif.cpp
@@ -1,5 +1,5 @@
---- ImageLib/src/gif/gif.c.orig 2009-08-07 15:16:48.000000000 -0400
-+++ ImageLib/src/gif/gif.c 2009-08-07 15:19:01.000000000 -0400
+--- ImageLib/src/gif/gif.cpp.orig 2015-08-20 21:29:33.000000000 +0600
++++ ImageLib/src/gif/gif.cpp 2015-08-20 21:29:46.000000000 +0600
@@ -4,7 +4,7 @@
/* Use an ultra fast compression method */
/***************************************************/
@@ -7,5 +7,5 @@
-#include <malloc.h>
+#include <stdlib.h>
#include <memory.h>
+ #include <string.h>
#include "gif.h"
-
diff --git a/games/blockout/pkg-plist b/games/blockout/pkg-plist
index 961f05623886..432d3360b1ba 100644
--- a/games/blockout/pkg-plist
+++ b/games/blockout/pkg-plist
@@ -1,5 +1,4 @@
bin/blockout
-%%DATADIR%%/images/allPieces.png
%%DATADIR%%/images/background.png
%%DATADIR%%/images/background2.png
%%DATADIR%%/images/background3.png
@@ -28,8 +27,9 @@ bin/blockout
%%DATADIR%%/sounds/level2.wav
%%DATADIR%%/sounds/line.wav
%%DATADIR%%/sounds/line2.wav
-%%DATADIR%%/sounds/music.mp3
+%%DATADIR%%/sounds/music.ogg
%%DATADIR%%/sounds/tchh.wav
%%DATADIR%%/sounds/welldone.wav
%%DATADIR%%/sounds/welldone2.wav
%%DATADIR%%/sounds/wozz.wav
+%%PORTDOCS%%%%DOCSDIR%%/README.txt