aboutsummaryrefslogtreecommitdiff
path: root/games/blockout
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2009-09-04 13:59:20 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2009-09-04 13:59:20 +0000
commitf8ba6c00a2b73186ccd95aff8c3d7de51ee66bf7 (patch)
tree1a2353528ec4145172c53547851be2475bc81c1f /games/blockout
parent3256846cea00bd54819c978a18e74ae37e0600cb (diff)
downloadports-f8ba6c00a2b73186ccd95aff8c3d7de51ee66bf7.tar.gz
ports-f8ba6c00a2b73186ccd95aff8c3d7de51ee66bf7.zip
Notes
Diffstat (limited to 'games/blockout')
-rw-r--r--games/blockout/Makefile49
-rw-r--r--games/blockout/distinfo3
-rw-r--r--games/blockout/files/patch-GLFont.cpp11
-rw-r--r--games/blockout/files/patch-GLSprite.cpp11
-rw-r--r--games/blockout/files/patch-Http.cpp19
-rw-r--r--games/blockout/files/patch-Makefile24
-rw-r--r--games/blockout/files/patch-gif.c11
-rw-r--r--games/blockout/files/patch-hpng.c8
-rw-r--r--games/blockout/pkg-descr6
-rw-r--r--games/blockout/pkg-message8
-rw-r--r--games/blockout/pkg-plist39
11 files changed, 189 insertions, 0 deletions
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
new file mode 100644
index 000000000000..f7a0c29e177e
--- /dev/null
+++ b/games/blockout/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: games/blockout
+# Date created: 06 Aug 2009
+# Whom: Stas Timokhin <stast@bsdportal.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blockout
+PORTVERSION= 2.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= blockout
+DISTNAME= bl24-src-linux-i586
+
+MAINTAINER= stast@bsdportal.ru
+COMMENT= BlockOut II is an adaptation of the original Blockout DOS game
+
+ONLY_FOR_ARCHS= i386
+
+USE_SDL= mixer sdl
+USE_GMAKE= yes
+USE_GL= gl glu
+
+WRKSRC= ${WRKDIR}/bl24_lin_src
+BUILD_WRKSRC= ${WRKSRC}/BlockOut
+
+FETCH_ARGS?= -pRr
+
+pre-build:
+ cd ${WRKSRC}/ImageLib/src && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/BlockOut/blockout ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/ImageLib/src/libimagelib.a ${PREFIX}/lib
+ ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR}/sounds
+ ${MKDIR} ${DATADIR}/images
+. for i in allPieces background background2 background3 font gameover gameovera marble \
+marbleg menuback menucredits menufont menufont2 menupit online onlinea spark sparka sprites spritesa star_crystal_grid
+ ${INSTALL_DATA} ${WRKSRC}/BlockOut/images/${i}.png ${DATADIR}/images
+. endfor
+. for s in blub empty empty2 hit level level2 line line2 tchh welldone welldone2 wozz
+ ${INSTALL_DATA} ${WRKSRC}/BlockOut/sounds/${s}.wav ${DATADIR}/sounds
+. endfor
+ ${INSTALL_DATA} ${WRKSRC}/BlockOut/sounds/music.mp3 ${DATADIR}/sounds
+post-install:
+ ${SED} -e "/%%PREFIX%%/s//${PREFIX:S/\//\\\//g}/g" ${PKGMESSAGE};
+
+.include <bsd.port.mk>
diff --git a/games/blockout/distinfo b/games/blockout/distinfo
new file mode 100644
index 000000000000..a618f73a8e8c
--- /dev/null
+++ b/games/blockout/distinfo
@@ -0,0 +1,3 @@
+MD5 (bl24-src-linux-i586.tar.gz) = 40f899491c38edfbbd984ba732417d7d
+SHA256 (bl24-src-linux-i586.tar.gz) = c95766b8d6fce9820e14a23cd1bdea28591c01d8fdf5ece06cca1071f082c088
+SIZE (bl24-src-linux-i586.tar.gz) = 5017393
diff --git a/games/blockout/files/patch-GLFont.cpp b/games/blockout/files/patch-GLFont.cpp
new file mode 100644
index 000000000000..6810c1ea4184
--- /dev/null
+++ b/games/blockout/files/patch-GLFont.cpp
@@ -0,0 +1,11 @@
+--- BlockOut/GLApp/GLFont.cpp.orig 2009-08-06 15:16:50.000000000 +0700
++++ BlockOut/GLApp/GLFont.cpp 2009-08-06 15:16:58.000000000 +0700
+@@ -3,7 +3,7 @@
+ // -----------------------------------------------
+ #include "GLFont.h"
+ #include <CImage.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+
diff --git a/games/blockout/files/patch-GLSprite.cpp b/games/blockout/files/patch-GLSprite.cpp
new file mode 100644
index 000000000000..022fe7bffd46
--- /dev/null
+++ b/games/blockout/files/patch-GLSprite.cpp
@@ -0,0 +1,11 @@
+--- BlockOut/GLApp/GLSprite.cpp.orig 2009-08-06 15:17:24.000000000 +0700
++++ BlockOut/GLApp/GLSprite.cpp 2009-08-06 15:17:46.000000000 +0700
+@@ -3,7 +3,7 @@
+ // -----------------------------------------------
+ #include "GLSprite.h"
+ #include <CImage.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+
diff --git a/games/blockout/files/patch-Http.cpp b/games/blockout/files/patch-Http.cpp
new file mode 100644
index 000000000000..6934c87eec66
--- /dev/null
+++ b/games/blockout/files/patch-Http.cpp
@@ -0,0 +1,19 @@
+--- BlockOut/Http.cpp.orig 2009-08-06 15:04:34.000000000 +0700
++++ BlockOut/Http.cpp 2009-08-06 15:14:02.000000000 +0700
+@@ -24,11 +24,16 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netdb.h>
++#include <netinet/in.h>
+
+
+ #define WAIT_FOR_READ 1
+ #define WAIT_FOR_WRITE 2
+
++#ifndef ENOSR
++#define ENOSR 9922
++#endif
++
+ // -------------------------------------------------------
+
+ Http::Http() {
diff --git a/games/blockout/files/patch-Makefile b/games/blockout/files/patch-Makefile
new file mode 100644
index 000000000000..b4bfb259a8c1
--- /dev/null
+++ b/games/blockout/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- BlockOut/Makefile.orig 2009-08-06 14:55:56.000000000 +0700
++++ BlockOut/Makefile 2009-08-06 15:39:07.000000000 +0700
+@@ -34,17 +34,17 @@
+
+ #---------------------------------------------------------------------
+
+-SDL_ROOT = /users/pons/test/opengl/SDL
+-IMGLIB_ROOT = ../ImageLib
++SDL_ROOT = /usr/local
++IMGLIB_ROOT = ../ImageLib/src
+
+ CXX = g++
+
+ CXXFLAGS = -g -D_DEBUG -Dlinux -c \
+- -I$(SDL_ROOT)/include/SDL -I$(IMGLIB_ROOT) -I.
++ -I/usr/include -I$(SDL_ROOT)/include/SDL -I$(SDL_ROOT)/include -I$(IMGLIB_ROOT) -I.
+
+ LIBS = -L$(SDL_ROOT)/lib -L$(IMGLIB_ROOT)
+
+-LFLAGS = $(LIBS) -limagelib -lGL -lGLU -lSDL_mixer -lSDL -lpthread -lm -ldl
++LFLAGS = $(LIBS) -limagelib -lGL -lGLU -lSDL_mixer -lSDL -lpthread -lm
+
+ #--------------------------------------------------------------------
+
diff --git a/games/blockout/files/patch-gif.c b/games/blockout/files/patch-gif.c
new file mode 100644
index 000000000000..81f295f78657
--- /dev/null
+++ b/games/blockout/files/patch-gif.c
@@ -0,0 +1,11 @@
+--- ImageLib/src/gif/gif.c.orig 2009-08-07 15:16:48.000000000 -0400
++++ ImageLib/src/gif/gif.c 2009-08-07 15:19:01.000000000 -0400
+@@ -4,7 +4,7 @@
+ /* Use an ultra fast compression method */
+ /***************************************************/
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <memory.h>
+ #include "gif.h"
+
diff --git a/games/blockout/files/patch-hpng.c b/games/blockout/files/patch-hpng.c
new file mode 100644
index 000000000000..57046eea85f1
--- /dev/null
+++ b/games/blockout/files/patch-hpng.c
@@ -0,0 +1,8 @@
+--- ImageLib/src/png/hpng.c.orig 2009-08-06 15:35:01.000000000 +0700
++++ ImageLib/src/png/hpng.c 2009-08-06 15:35:10.000000000 +0700
+@@ -1,4 +1,4 @@
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <math.h>
+ #include "png/png.h"
+ #include "hpng.h"
diff --git a/games/blockout/pkg-descr b/games/blockout/pkg-descr
new file mode 100644
index 000000000000..ab31bff629db
--- /dev/null
+++ b/games/blockout/pkg-descr
@@ -0,0 +1,6 @@
+BlockOut II is an adaptation of the original Blockout DOS game
+edited by California Dreams(1989). It uses Direct3D on Win32 and
+OpenGL on Linux/Unix. BL II has the same features than the original game.
+Score calculation is also nearly similar to the original.
+
+WWW: http://sourceforge.net/projects/blockout/
diff --git a/games/blockout/pkg-message b/games/blockout/pkg-message
new file mode 100644
index 000000000000..c1a8d90c0d8f
--- /dev/null
+++ b/games/blockout/pkg-message
@@ -0,0 +1,8 @@
+
+*************************************************************************
+
+ Set the environment variable:
+
+ BL2_HOME=%%PREFIX%%/share/blockout
+
+*************************************************************************
diff --git a/games/blockout/pkg-plist b/games/blockout/pkg-plist
new file mode 100644
index 000000000000..53aef418fc87
--- /dev/null
+++ b/games/blockout/pkg-plist
@@ -0,0 +1,39 @@
+bin/blockout
+lib/libimagelib.a
+%%DATADIR%%/images/allPieces.png
+%%DATADIR%%/images/background.png
+%%DATADIR%%/images/background2.png
+%%DATADIR%%/images/background3.png
+%%DATADIR%%/images/font.png
+%%DATADIR%%/images/gameover.png
+%%DATADIR%%/images/gameovera.png
+%%DATADIR%%/images/marble.png
+%%DATADIR%%/images/marbleg.png
+%%DATADIR%%/images/menuback.png
+%%DATADIR%%/images/menucredits.png
+%%DATADIR%%/images/menufont.png
+%%DATADIR%%/images/menufont2.png
+%%DATADIR%%/images/menupit.png
+%%DATADIR%%/images/online.png
+%%DATADIR%%/images/onlinea.png
+%%DATADIR%%/images/spark.png
+%%DATADIR%%/images/sparka.png
+%%DATADIR%%/images/sprites.png
+%%DATADIR%%/images/spritesa.png
+%%DATADIR%%/images/star_crystal_grid.png
+%%DATADIR%%/sounds/blub.wav
+%%DATADIR%%/sounds/empty.wav
+%%DATADIR%%/sounds/empty2.wav
+%%DATADIR%%/sounds/hit.wav
+%%DATADIR%%/sounds/level.wav
+%%DATADIR%%/sounds/level2.wav
+%%DATADIR%%/sounds/line.wav
+%%DATADIR%%/sounds/line2.wav
+%%DATADIR%%/sounds/music.mp3
+%%DATADIR%%/sounds/tchh.wav
+%%DATADIR%%/sounds/welldone.wav
+%%DATADIR%%/sounds/welldone2.wav
+%%DATADIR%%/sounds/wozz.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%