aboutsummaryrefslogtreecommitdiff
path: root/games/bomberclone
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-07 15:26:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-07 15:26:29 +0000
commit5b516f11467b1eca54c8243fa4e29b70781aff0b (patch)
tree0109eabe5ec6bdd9a4a85ae82ce76e1fffbfe41b /games/bomberclone
parentd6777210d4061ca29804cf3813a3bbeef8277549 (diff)
downloadports-5b516f11467b1eca54c8243fa4e29b70781aff0b.tar.gz
ports-5b516f11467b1eca54c8243fa4e29b70781aff0b.zip
- Add LICENSE_FILE
- Switch to USES=localbase - Switch to options helpers
Notes
Notes: svn path=/head/; revision=437927
Diffstat (limited to 'games/bomberclone')
-rw-r--r--games/bomberclone/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/bomberclone/Makefile b/games/bomberclone/Makefile
index bf328842e5e6..93ec25ec6e41 100644
--- a/games/bomberclone/Makefile
+++ b/games/bomberclone/Makefile
@@ -11,13 +11,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Reimplementation of Atomic Bomber Man
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake
+USES= gmake localbase
USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --target="" --disable-werror
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
+CONFIGURE_ARGS= --disable-werror
+
+LIBS+= -lm
PORTDOCS= AUTHORS ChangeLog README TODO
@@ -33,13 +34,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|share/games/${PACKAGE}|share/${PACKAGE}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} \
- -e 's|install-data-am: install-bomberclonedocDATA|install-data-am: |' \
+ -e 's|install-data-am: install-bomberclonedocDATA|install-data-am: |' \
${WRKSRC}/Makefile.in
post-install:
${LN} -sf ${DATADIR}/pixmaps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}