aboutsummaryrefslogtreecommitdiff
path: root/games/bomberclone
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2013-10-12 00:46:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2013-10-12 00:46:05 +0000
commita14f43391af4cb8c739a5abfa01958bab6672867 (patch)
tree714be0f52502b45fd0e2c8bf814ee5e830074221 /games/bomberclone
parent1a4180c77c5b418625e4b51d4b9941491538befa (diff)
downloadports-a14f43391af4cb8c739a5abfa01958bab6672867.tar.gz
ports-a14f43391af4cb8c739a5abfa01958bab6672867.zip
Fix build on 10.
Upgrade to latest version. Note that the SF location is atypical and doesn't fit the standard macros.
Notes
Notes: svn path=/head/; revision=330108
Diffstat (limited to 'games/bomberclone')
-rw-r--r--games/bomberclone/Makefile8
-rw-r--r--games/bomberclone/distinfo4
-rw-r--r--games/bomberclone/files/patch-src-single.c11
3 files changed, 16 insertions, 7 deletions
diff --git a/games/bomberclone/Makefile b/games/bomberclone/Makefile
index f052ee50486b..6620a67ab314 100644
--- a/games/bomberclone/Makefile
+++ b/games/bomberclone/Makefile
@@ -2,19 +2,17 @@
# $FreeBSD$
PORTNAME= bomberclone
-PORTVERSION= 0.11.8
-PORTREVISION= 8
+PORTVERSION= 0.11.9
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= http://master.dl.sourceforge.net/project/${PORTNAME}/${PORTNAME}/
MAINTAINER= edwin@mavetju.org
COMMENT= Reimplementation of Atomic Bomber Man
USE_SDL= image mixer sdl
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --target=""
+CONFIGURE_ARGS= --target="" --disable-werror
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
diff --git a/games/bomberclone/distinfo b/games/bomberclone/distinfo
index c509da014c34..69a594a0b83e 100644
--- a/games/bomberclone/distinfo
+++ b/games/bomberclone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bomberclone-0.11.8.tar.bz2) = 2f6993ee4a63e8cea51f9605e35de4b4ec12a5abafd25309c313ddb0fba35230
-SIZE (bomberclone-0.11.8.tar.bz2) = 7966452
+SHA256 (bomberclone-0.11.9.tar.gz) = 71eb2788f95c136fd3eecaee15d05a80dea07221b5b3530dc869e433e02ff68d
+SIZE (bomberclone-0.11.9.tar.gz) = 8109837
diff --git a/games/bomberclone/files/patch-src-single.c b/games/bomberclone/files/patch-src-single.c
new file mode 100644
index 000000000000..71e05df46ab2
--- /dev/null
+++ b/games/bomberclone/files/patch-src-single.c
@@ -0,0 +1,11 @@
+--- src/single.c.orig 2013-10-12 22:40:49.000000000 +1100
++++ src/single.c 2013-10-12 22:41:09.000000000 +1100
+@@ -476,7 +476,7 @@
+ };
+
+
+-inline int
++int
+ ai_checknewpos (_point pos, int d)
+ {
+ _point m;