aboutsummaryrefslogtreecommitdiff
path: root/games/bouncy
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-05-02 15:44:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-05-02 15:44:31 +0000
commit57e1777e91936a84f4ca0ca0ab62fdc9da78cf30 (patch)
treee6b1a7c7ffffd837564fbbe1f9a0848492688cc0 /games/bouncy
parentb243855f9fc4ac76491afe1408b402df03c025d4 (diff)
Notes
Diffstat (limited to 'games/bouncy')
-rw-r--r--games/bouncy/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/games/bouncy/Makefile b/games/bouncy/Makefile
index d992a0d20b15..51ce07dab432 100644
--- a/games/bouncy/Makefile
+++ b/games/bouncy/Makefile
@@ -12,7 +12,7 @@ DISTFILES= ${PORTNAME}-post-${DISTVERSION}.tgz \
DIST_SUBDIR= python
EXTRACT_ONLY= ${PORTNAME}-post-${DISTVERSION}.tgz
-MAINTAINER= nemysis@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= You are a hungry rabbit. Eat food to complete the level
LICENSE= GPLv2
@@ -26,20 +26,24 @@ USE_PYTHON= 2
PORTDOCS= README.txt
+OPTIONS_DEFINE= DOCS SHADER
+SHADER_DESC= Hardware shader support
+OPTIONS_DEFAULT= SHADER
+
INSTALLS_ICONS= yes
SUB_FILES= ${PORTNAME}
-DESKTOP_ENTRIES="Bouncy the Hungry Rabbit" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" false
-
-OPTIONS_DEFINE= SHADER
-SHADER_DESC= Hardware shader support
-OPTIONS_DEFAULT= SHADER
+DESKTOP_ENTRIES="Bouncy the Hungry Rabbit" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
.include <bsd.port.options.mk>
-post-extract:
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.py' | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|^.*#!.*python.*$$|#!${PYTHON_CMD}|'
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+
.if ${PORT_OPTIONS:MSHADER}
@${REINPLACE_CMD} -i '' '/#try/,/# print/s/#//' ${WRKSRC}/objects.py
.endif
@@ -53,15 +57,12 @@ do-install:
${WRKDIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- @${MKDIR} ${STAGEDIR}${DATADIR}
-
-.for d in *.py *.pyc *.pyo
- @(cd ${WRKSRC} ; ${INSTALL_SCRIPT} ${d} ${STAGEDIR}${DATADIR})
-.endfor
-
.for d in data pyglyph
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
+.for f in *.py *.pyc *.pyo
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
+.endfor
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/