aboutsummaryrefslogtreecommitdiff
path: root/games/briquolo/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:45:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:45:35 +0000
commitf24c0b09ace3326f0331174613036ff545832ae7 (patch)
tree452e788068f9e2310179569e7bcc9b87bb526c0a /games/briquolo/Makefile
parent91c87e6b5ba498c385c3cfc305f784f41803c5eb (diff)
downloadports-f24c0b09ace3326f0331174613036ff545832ae7.tar.gz
ports-f24c0b09ace3326f0331174613036ff545832ae7.zip
Notes
Diffstat (limited to 'games/briquolo/Makefile')
-rw-r--r--games/briquolo/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index f004e001b457..1001aa9e3e88 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -6,32 +6,33 @@
#
PORTNAME= briquolo
-PORTVERSION= 0.4.2
-PORTREVISION= 2
+PORTVERSION= 0.5
CATEGORIES= games
MASTER_SITES= http://briquolo.free.fr/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Breakout clone with an OpenGL 3D representation
-LIB_DEPENDS= GUI.0:${PORTSDIR}/graphics/guilib \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
+USE_SDL= mixer sdl
+USE_GCC= 3.4
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-USE_SDL= mixer sdl
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} \
- ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
- @${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
- ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
+ @${REINPLACE_CMD} -e 's|="-Wall"|="$$CXXFLAGS"|g ; \
+ s|-O3||g' ${WRKSRC}/configure
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|SDL/SDL|SDL|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>