aboutsummaryrefslogtreecommitdiff
path: root/games/briquolo
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2013-10-30 07:53:37 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2013-10-30 07:53:37 +0000
commit379e3fbd881d73ff98fae131068f570a7fd3c4e4 (patch)
treea9d154b6c3856636782e270f4e589bbfbda7c167 /games/briquolo
parent4819fa70fff1f22529ecd1a9d1b93f34ff44d338 (diff)
Notes
Diffstat (limited to 'games/briquolo')
-rw-r--r--games/briquolo/Makefile20
-rw-r--r--games/briquolo/files/patch-desktop-Makefile.in11
-rw-r--r--games/briquolo/files/patch-src-Constante.cpp10
-rw-r--r--games/briquolo/pkg-plist2
4 files changed, 26 insertions, 17 deletions
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 4a0cc1825b95..28da1081e888 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -3,23 +3,22 @@
PORTNAME= briquolo
PORTVERSION= 0.5.7
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= http://briquolo.free.fr/download/
MAINTAINER= martymac@FreeBSD.org
COMMENT= Breakout clone with an OpenGL 3D representation
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-
LICENSE= GPLv2
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+
USE_BZIP2= yes
USES= iconv
USE_GL= gl
USE_SDL= mixer sdl ttf
-USE_GMAKE= yes
-USE_GNOME= desktopfileutils
+USES= gmake desktop-file-utils
USE_XORG= x11
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -27,22 +26,13 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
-#.if defined(WITHOUT_NLS)
-#BROKEN= Unsupported: wants to link against libintl anyway
-#CONFIGURE_ARGS+= --disable-nls
-#PLIST_SUB+= NLS="@comment "
-#.else
+# Mandatory: wants to link against libintl anyway
USES+= gettext
PLIST_SUB+= NLS=""
-#.endif
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|g' \
-e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
${WRKSRC}/src/MOGL/MOGL_Image.cpp
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/games/briquolo/files/patch-desktop-Makefile.in b/games/briquolo/files/patch-desktop-Makefile.in
new file mode 100644
index 000000000000..c33e56b5a64a
--- /dev/null
+++ b/games/briquolo/files/patch-desktop-Makefile.in
@@ -0,0 +1,11 @@
+--- desktop/Makefile.in.orig 2013-10-29 17:36:03.000000000 +0100
++++ desktop/Makefile.in 2013-10-29 17:36:23.000000000 +0100
+@@ -204,7 +204,7 @@
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+-icondir = $(DESTDIR)$(datadir)/pixmaps
++icondir = $(datadir)/pixmaps
+ icon_DATA = briquolo.svg
+ EXTRA_DIST = briquolo.desktop briquolo.svg
+ all: all-am
diff --git a/games/briquolo/files/patch-src-Constante.cpp b/games/briquolo/files/patch-src-Constante.cpp
new file mode 100644
index 000000000000..94c0377ebf4a
--- /dev/null
+++ b/games/briquolo/files/patch-src-Constante.cpp
@@ -0,0 +1,10 @@
+--- src/Constante.cpp.orig 2013-10-29 17:15:21.000000000 +0100
++++ src/Constante.cpp 2013-10-29 17:18:30.000000000 +0100
+@@ -32,6 +32,7 @@
+ #define WIN32_LEAN_AND_MEAN
+ #include <windows.h>
+ #else
++#include <cstdlib>
+ #include <unistd.h>
+ #endif
+
diff --git a/games/briquolo/pkg-plist b/games/briquolo/pkg-plist
index b7eba4f36527..998e42dd4325 100644
--- a/games/briquolo/pkg-plist
+++ b/games/briquolo/pkg-plist
@@ -113,5 +113,3 @@ share/pixmaps/briquolo.svg
%%NLS%%share/locale/pl/LC_MESSAGES/briquolo.mo
%%NLS%%share/locale/pt/LC_MESSAGES/briquolo.mo
%%NLS%%share/locale/sk/LC_MESSAGES/briquolo.mo
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true