aboutsummaryrefslogtreecommitdiff
path: root/games/brutalchess
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-10-01 21:13:17 +0000
committerJohn Marino <marino@FreeBSD.org>2013-10-01 21:13:17 +0000
commit7ab7a478aa60fd2816c510ff0c24af185f297440 (patch)
tree9929f120f419350b523a231bd0358c05bdbd0376 /games/brutalchess
parenta5b6e13d4a5b9cafc8a98827664c723f53d02547 (diff)
downloadports-7ab7a478aa60fd2816c510ff0c24af185f297440.tar.gz
ports-7ab7a478aa60fd2816c510ff0c24af185f297440.zip
Notes
Diffstat (limited to 'games/brutalchess')
-rw-r--r--games/brutalchess/Makefile2
-rw-r--r--games/brutalchess/files/patch-src_board.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/games/brutalchess/Makefile b/games/brutalchess/Makefile
index 5f720d64a258..f8797f1dca54 100644
--- a/games/brutalchess/Makefile
+++ b/games/brutalchess/Makefile
@@ -18,7 +18,7 @@ USE_XORG= x11 xext xt xmu xi
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-
+USE_DOS2UNIX= yes
USE_GL= yes
USE_SDL= sdl image
diff --git a/games/brutalchess/files/patch-src_board.h b/games/brutalchess/files/patch-src_board.h
new file mode 100644
index 000000000000..857147f510cb
--- /dev/null
+++ b/games/brutalchess/files/patch-src_board.h
@@ -0,0 +1,10 @@
+--- src/board.h.orig 2013-10-01 21:08:24.000000000 +0000
++++ src/board.h
+@@ -12,6 +12,7 @@
+ #include <cstdio>
+ #include <iostream>
+ #include <vector>
++#include <unistd.h>
+
+ #include "bitboard.h"
+ #include "boardmove.h"