aboutsummaryrefslogtreecommitdiff
path: root/games/bsdgames
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-12-12 15:15:34 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-12-12 15:15:34 +0000
commitf0e043a401e6526204862683b5264a13a95e8899 (patch)
tree4ae55d9b872866be3db7a7c7ddf393713329a5dc /games/bsdgames
parent361a77eacc4e8ea43cf7a11f275b47fc552b7ca6 (diff)
downloadports-f0e043a401e6526204862683b5264a13a95e8899.tar.gz
ports-f0e043a401e6526204862683b5264a13a95e8899.zip
Notes
Diffstat (limited to 'games/bsdgames')
-rw-r--r--games/bsdgames/Makefile2
-rw-r--r--games/bsdgames/files/patch-trek_computer.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 29a7080c3c3e..2ec7ba2b5672 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bsdgames
PORTVERSION= 3.8.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= games
# Fetched from git://git.dragonflybsd.org/dragonfly.git, v${PORTVERSION}, /games
diff --git a/games/bsdgames/files/patch-trek_computer.c b/games/bsdgames/files/patch-trek_computer.c
new file mode 100644
index 000000000000..58a062a4d35d
--- /dev/null
+++ b/games/bsdgames/files/patch-trek_computer.c
@@ -0,0 +1,15 @@
+--- trek/computer.c.orig 2014-12-12 15:10:37 UTC
++++ trek/computer.c
+@@ -175,10 +175,10 @@ computer(int v __unused)
+ tqy = Ship.quady;
+ } else {
+ ix = getintpar("Quadrant");
+- if (ix < 0 || ix >= NSECTS)
++ if (ix < 0 || ix >= NQUADS)
+ break;
+ iy = getintpar("q-y");
+- if (iy < 0 || iy >= NSECTS)
++ if (iy < 0 || iy >= NQUADS)
+ break;
+ tqx = ix;
+ tqy = iy;